Jump to content

  •  


AVSIM NOTAM

The AVSIM Forums will be temporarily offline for software upgrades beginning 23FEB17 at 22:00Z. The upgrade could last as long as 7 hours. We apologize for any inconvenience.


In Loving Memory Of

Tom Allensworth,
Founder of AVSIM Online


AVSIM Online
Flight Simulation's Premier Resource!


AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!


Click here for more information and to see all donations year to date.

Photo

If I update only the client file in V3.0 to V3.4+ should I expect problems in add ons?


  • Please log in to reply
5 replies to this topic

#1 Noel

Noel

    Member - 4,000+

  • Donor
  • 4,971 posts

Posted 17 February 2017 - 01:13 PM

I have lots of ORBX FTX sceneries, PMDG 737/777, RA Turbine Duke & Lancer, FSCaptain and use ActiveSky Next.  If I just do the client file update is it reasonable to expect no real problems post update to P3D 3.4, or is that wishful thinking?   What I don't get is if all that is needed to update to the current version is the Client update, why the other two components are offered, and more specifically, why does one decide to do all three versus just the Client?

 

On LM's website, they say:

 

We have 3 Update Component Installers,  Client  Content and Scenery 


I) Install_ Client.msi...Client is the Primary Update (Main) that will Update Prepar3D to the most current Version (Update Version). The Core folders like Licences and ShadersHLSL will be Updated with Client.  
* If you want to Update Prepar3D to the most current Version You only Need the Client update

II) Install_Content.msi...Content is an Optional Update that will Update folders like,  EffectsSoundsSimobjectsand Textures to name a few

III) Install_Scenery.msi...Scenery is also an Optional Update that will update the Scenery files within Prepar3D v3

 

I have a cloned back up done just a day ago so if troubles happen I should be able undo them, but OTOH I don't want to fiddle around much with repairing broken things.  Please advise if you would be so kind.

 

Thanks!


  • 0
Noel

Help AVSIM continue to serve you!
Please donate today!

#2 hesynergy

hesynergy

    Member - 1,000+

  • Members
  • 1,111 posts

Posted 17 February 2017 - 01:40 PM

Having not flown P3d for a couple of months now because I am testing out and engrossing myself with X-Plane 11 beta, I would love to know the answer to this is well… One the reasons that I like X-Plane ( don't get me wrong it has its shortcomings as well) is the fact that tweaking is almost nonexistent and flying time is a joy!

Chas
  • 0
My first sim flight simulator pD25zEJ.jpg

Take a ride to Stinking Creek! http://youtu.be/YP3fxFqkBXg
I7-2600K OC'd to 4.3 GC,GeForce 770, 27" Dell TouchScreen,TM HOTAS Warthog,TrackIR5,Saitek Combat Rudder Pedals.

#3 wsmeier

wsmeier

    Member

  • Donor
  • 225 posts

Posted 17 February 2017 - 01:53 PM

Noel,

 

If you're going from 3.0 all the way to 3.4, I would recommend updating the Content as well. There were some changes made that could lead to issues if you don't, specifically some in-sim menus, such as Active Sky or other those of other third parties may not work properly under the old Content version.

 

Only minor changes were made to Scenery. You can read the release notes for each version to see if any of those interest you. Not updating Scenery will not cause any issues.


  • 0

Walter Meier


#4 Noel

Noel

    Member - 4,000+

  • Donor
  • 4,971 posts

Posted 17 February 2017 - 04:51 PM

Thank you Walter.   If I have the latest versions of my various mentioned add ons installed do I need to update those again do you know?



One the reasons that I like X-Plane ( don't get me wrong it has its shortcomings as well) is the fact that tweaking is almost nonexistent and flying time is a joy!

 

Chas, this is why I'm still using V3.0.  I value stability and flying over updating.   Every time I make a change the potential for trouble starts.  The only reason I am considering going up to 3.4 is that the Majestic Dash 8 folks only support 3.3 and up and there are issues w/ it, minor ones, but issues nonetheless.   Were I The Donald I would command LM to release updates every 2 years, while of course publishing where they are in the project frequently so as to not lose the attention of customers.  This was users could fly and content developers could relax a little, and this would translate into lower costs ultimately to the consumer since they would not have to do the work to keep up with these inane incremental updates from P3D.   I know they made big headway in V3, but still.  I'd rather be flying!


  • 0
Noel

#5 wsmeier

wsmeier

    Member

  • Donor
  • 225 posts

Posted 17 February 2017 - 08:47 PM


Thank you Walter. If I have the latest versions of my various mentioned add ons installed do I need to update those again do you know?

If you do in fact already have the latest versions of those addons, I think you should be ok. I've never leaped over so many versions, so I couldn't tell you for sure. I imagine worst case scenario would have you installing one of those again.


  • 0

Walter Meier


#6 Noel

Noel

    Member - 4,000+

  • Donor
  • 4,971 posts

Posted 17 February 2017 - 09:13 PM

Sounds good thanks.  I will try to find the instructions on P3D website to make the installations of client and content and see how it shakes out.


  • 0
Noel