Jump to content

Sign in to follow this  
aitrafficgroup

G2d.dll error...again

Recommended Posts

Guys,Have been monitoring this forum for the past week or so and looking up previous threads about the G2d.dll CTD that some people have had in FS9, and now its really beginning to annoy me.Whether i fly the ifdg Airbuses, the Level D 767, the Feelthere 737s etc i always seem to get g2d.dll errors at addon sceneries with the exception of UK2000 Heathrow Pro, Aerosofts CDG and a few 3rd party sceneries from the library.However I was just flying into Zurich where i have an addon scenery and it crashed about 7 miles out on final to runway 14, also Frankfurt crashes, as does ISD's Rome and Flytampas Vienna. But i believe these problems may have only commenced since i installed Vienna, but could that single scenery affect all the other places FS has been crashing on me? For example could a bad file in the Vienna folder cause a CTD in Zurich, or could it more likely be my Traffic.bgls (one of the 300 or so I have), or perhaps an AFCAD?With the AFCADs, I make sure I have no duplicates of actual airports with runways and parking etc but sometimes a file such as LFPG_signs.bgl might pop up appearing as an airport. Is there anything I can do about that?My hardware is as follows:AMD 64 3500ATI X800 XT PE - latest Omega drivers that i updated yesterday haven't seemed to help the problem at all.1gb RAMCH Yoke & PedalsAny help is much appreciated, I'm getting very sick of this problem :(Henry

Share this post


Link to post
Share on other sites
Guest firehawk44

The G2D.dll CTD has been discussed frequently in the AVSIM forums. I hope you did a "g2d.dll" search on AVSIM. It looks like you might have since you mentioned some possible solutions. This .dll was updated when MS released FS9.1 so make sure your G2D.dll in the Modules folder is dated 9/1/2004. I have received the G2D CTD in the past and fixed it by uninstalling/reinstalling my ATI drivers (I might have been lucky). I have the same video card you have but use only the ATI drivers. I have used the Omega drivers in the past and they never caused a CTD so I don't think you have a problem with Omega. You could be missing a scenery texture though. I am almost positive your Vienna scenery cannot cause a CTD in Zurich or Rome as the scenery works within its own addon scenery folder. Do you have Ground Environment installed? That program changes default scenery files and it could be missing a texture or it became corrupted. If you started seeing several CTD's after installing FlyTampa's Vienna, I would simply disable the program in the scenery library and see if the CTD's continue. Make sure your scenery.cfg is not corrupted too (Areas/Layers do not match; not in sequence; duplicated areas; etc). That has been known to cause CTD's. I'm sorry but this is all I know about possibly fixing your problem. Unfortunately, there is no "magic bullet" that fixes this problem as you probably read in all the threads regarding the G2D CTD. I hope you can fix your problem soon as I know how frustrating CTD's can be.Best regards,JimYoung

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...