Jump to content

Sign in to follow this  
Guest mattcu

TCS button problem with the Dash-8

Recommended Posts

Guest mattcu

I've been flying the PSS Dash-8 recently and I've been having a ball. The only problem is that I cannot get the TCS function to 'accept' a joystick button being assigned to it through PanelEdit. For that matter, I can't get any other panel functions to either.For example, I have 'Z' assigned as the autopilot on/off command and 'Ctrl-Shift-T' assigned as TCS. I also tried to assign these to Buttons 1 & 2 on my yoke respectively. No joy.I ensured that the buttons were not assigned elsewhere in FS2002. They were to start with, but no longer. Still no joy.I have the CH Flight Sim Yoke (USB) and CH Foot Pedals (USB). I noted that FS sees the Pedals as the first joystick rather than the yoke. So I used PanelEdit to change the joystick number to Joystick 2. And lo... nothing happened.So I blanked all the settings out of PanelEdit and resorted to programming the buttons manually using FSUIPC. Success... to an extent. The autopilot will now switch on and off using button 1 but I still can't get the TCS to work nice. I have assigned button 2 to it and told FSUIPC to repeat the keystroke with the button pressed down, but the FCS system stutters rather than working smoothly and consequently is still effectively useless.The next step, I guess, is to crank the polling rate of FSUIPC right up to the limit but I don't see why that should be necessary, why general performance should need to suffer just for the benefit of TCS... surely there must be a better way. Why doesn't it just... work?Another anomaly, just for interest. PanelEdit starts its button numbering from Joystick 1/Button 1 yet FSUIPC and FS both start from Joystick 1/Button 0. Is this a factor?My system: FS2002 on a 2.4Ghz Athlon-based windows PC. Full version (3.22) of FSUIPC, USB versions of the CH FlightSim Yoke and Pedals.Ease my anguish if you can!Many thanksMatt

Share this post


Link to post
Share on other sites
Guest ahellner

Hi,have the same problems with TCS: TCS works fine with the keyboard but not with a joke button.My configuration`:FS2004Windows XPUnregistered version of FSUIPCAnybody here who knoes a solution?(Would be great to have the other hand free for e.g. radio tuning while in TCS)ThanksA.H.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    5%
    $1,290.00 of $25,000.00 Donate Now
×
×
  • Create New...