Jump to content

Sign in to follow this  
Guest tjf4375

Taxi problems

Recommended Posts

Guest tjf4375

Hi all,This seems to be a unique problem not experienced before (I've scoured the forums without success!). I've had the PSS -8 for some years now and decided to make a flight in 2004 today. All went well until I'd finished pushing back, and realised I couldn't actually move! My engines are running fine, but the plane simply wont budge from its spot, no matter how much I rev the engines. Brakes released, and there isn't any shaking that would suggest a brake being left on. Can anyone suggest anything? Am I being daft?Many thanks for your help,Tim F

Share this post


Link to post
Share on other sites
Guest Phoenix5

Where the props feathered?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    15%
    $3,765.00 of $25,000.00 Donate Now
×
×
  • Create New...