Sign in to follow this  
Guest loud

Problem with lights

Recommended Posts

Hi! I really enjoy PSS products but PSS 777 and 757 I dont get lights. I switch on off but nothing! All systems is on and all running but lights not! What should I do?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Which lights do you mean?And please sign your name - nice to know whom we are talking to.John Rooum

Share this post


Link to post
Share on other sites

all: nav land taxi beacon strobe.. I have same problem with my gears on 757... it not retractloud

Share this post


Link to post
Share on other sites

hey guysmake sure the default cessna is loadedmake sure master switches are on and the avionics are onthat cleared it up for mesteven figured that one out for menick baa-ret

Share this post


Link to post
Share on other sites

>hey guys>make sure the default cessna is loaded>make sure master switches are on and the avionics are on>that cleared it up for me>steven figured that one out for me>>>>>>>nick b>aa-retthx very much!!! All is working when I press Shift+M :)) I must turn on master battery on FS before I turn on Master battery on aircraftloud

Share this post


Link to post
Share on other sites

Loud - that can't be your real name, is it?Anyway, please look at the FAQ on the PSS website - there are full details on how to load PSS aircraft correctly to avoid just these problems.John rooum

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this