Sign in to follow this  
garydpoole

Only V3.4.0 of FSUIPC is able to Talk to FS

Recommended Posts

Hi GuysI've recently installed Level-D's 767-300 a side-effect of which, was to update my (registered) version of FSUIPC from 3.4.0 to 3.7.0.Now ActiveSky is unable to communicate with FS - stating that FS is not connected. If I go back to 3.4.0, then all's fine.I've also tried 3.4.4 and 3.4.8 with no success. It's only 3.4.0 that ActiveSky works with even though, when it loads, it tells me that I need a newer version of FSUIPC!I could go back to 3.4.0 but I'd like to also run AISmooth, and it needs 3.4.8 or later to run. However, when I install 3.4.8 or later, it too is unable to communicate with FS.FSUIPC is still stating that I have a registered copy with any version installedso I don't think there's a registration problem.So it appears that I can only talk to FS with FSUIPC 3.4.0.Any one have any thoughts ?Many thanksGary

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Go to Pete Dowson's site and get version 3.73...3.70 had some major issues.Bob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites

I've been wondering, since it's apparent that almost every add-on depends on some version of FSUIPC, which, as far as I can tell, is only developed and supported by Pete Dowson....what will become of our flight sim when he quits making them? Seems like FSUIPC is the life blood of FS, without it nothing seems to work right. One realy hates to think this way, but can FS survive without it? Are there alternatives to FSUIPC right now, or plans for something in the near future?I hope Pete stays with this forever, but reality tells you that will not be the case. Anyway, I was just wondering.John M

Share this post


Link to post
Share on other sites

Well, the appearance of of SimConnect in FSX is a sign that MS sees the importance of an interface to the internals of FS.Agree that we're spoiled to have a guy with Pete's talents dedicating himself to this critical piece of the hobby.CheersBob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites

>Go to Pete Dowson's site and get version 3.73...3.70 had some>major issues.>Thanks for the reply. Downloaded it but still no go - nether ActiveSky or AISmooth seem to be able to communicate with FS. AISmooth displays FSUIPC as "version" 0.0.0Still only able to get ActiveSky to see FS if i'm using 3.4.0Gary

Share this post


Link to post
Share on other sites

Do you by any chance have the WinXP cryptographic service disabled in your FS config? FSUIPC v3.70 and beyond requires the crypto service to validate the digital sig embedded into the module. If you use Ken Salter's FSAutoStart, it recommends stopping the crypto service, too, which now is a clear no-no.RegardsBob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites
http://forums.simflight.com/viewtopic.php?...50519b3e5372a7bdiscusses this topic to some degree. Also make sure fsuipc.dll, the fsuipc.ini, and the fsuipc.key file (if used) all reside in your modules folder.Also in your modules folder is fsuipc.log which is created each time it runs. Read this with notepad to look for any errors.In addition make sure only one copy of fsuipc exists anywhere in your FS and subfolders and that must be for FS9 in your modules folder. Right click on that file, select properties, and check the version number.

Share this post


Link to post
Share on other sites

>Do you by any chance have the WinXP cryptographic service>disabled in your FS config? To clarify, I mean is the crypto service disabled in the WinXP configuration used to run FS, not some sort of setting in your fs9.cfg or other MSFS configuration option.RegardsBob ScottATP IMEL Gulfstream II-III-IV-VSantiago de Chile

Share this post


Link to post
Share on other sites

Hi Gary,Cut and paste the FSUIPC.key file out and see what happens. Yes, I know this makes FSUIPC unregistered. You may have a bad .key file.Thanks,Jimhttp://www.hifisim.com/Active Sky V6 Development Team Active Sky V6 Proud SupporterHiFi Beta TeamRadar Contact Supporter: http://www.jdtllc.com/AirSource Member: http://www.air-source.us/FSEconomy Member:http://www.fseconomy.com/

Share this post


Link to post
Share on other sites

>Hi Gary,>>Cut and paste the FSUIPC.key file out and see what happens.>Yes, I know this makes FSUIPC unregistered. You may have a bad>.key file.>>Thanks,>Jim>Thanks for that, Jim - it "sort" of worked. Well, it worked ok with version 3.4.8 whilst I left it unregistered. However, as soon as I re-registered it, i lost communication again. It seems I can only talk to ActiveSky and AISmooth with version 3.4.8 or higher if they're unregistered. Go figure ???Btw, FSUIPC definitely says i registered OK after restarting FS.Thanks again for your inputGary

Share this post


Link to post
Share on other sites

Hi,You will need to contact Pete about this. He will require that you use the latest official version as yours is very old. Between you and him, this will be worked out.Thanks,Jimhttp://www.hifisim.com/Active Sky V6 Development Team Active Sky V6 Proud SupporterHiFi Beta TeamRadar Contact Supporter: http://www.jdtllc.com/AirSource Member: http://www.air-source.us/FSEconomy Member:http://www.fseconomy.com/

Share this post


Link to post
Share on other sites

I've always gotten good support on Pete's support forum. FSUIPC has some logging capabilites that can be turned on in the ini, and Pete can use the results to determine what is going wrong.scott s..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this