Archived

This topic is now archived and is closed to further replies.

modano

Pmdg 747

Recommended Posts

hi.whats wrong with the pmdg 747 and out of memory i get that every time i fly with that aircraft none of my other aircraft does it im so tired of it.this is my pc.E8400gtx 2804 gb memory (cossair)raptor 300 gb harddisk i have UT and ground envoriment pro installed it does not matter if i fly 200 nm or 3000 nm it does it in every airport exept fra dubai from flytampa which is the only airport i have been abel to land the 747 without an OOM message.have any one else the same problem or is i the only one and what can i do.i dont runing with virituel memory because even with that i get an OOM with that aircraft.please help if somebody know what the problem is.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You don't state what OS your using? Firstly do a search on Avsim for 3GB fix. Ok about your system, I am going to assume your using windows xp/vista 32 bit The max memory you can use is 3 gig your card is a GTX280 and is hogging 1 gig of your system memory. I use the ATI4870 512 and that is more then enough for my needs, if I upgrade to a card with more memory I would likely see a decrease in performance unless I switch to 64 bit.UT is known to have memory leaks so make sure you have the latest patches, also check the performance tab in task manager and see what memory and cpu hogging tasks you have running in the background. I could go on forever but these are the main things you should be looking for. The 747 is complex sim and requires a lot of memory.My specs - All the Major scenery addons -Intel Core 2 Duo E8600 LGA775 'Wolfdale' "Overclocking E0 Stepping" 4.0GHz (1333FSB) - 2 Gig of Ram Sapphire ATI Radeon HD 4870 512MB GDDR5 TV-Out/Dual DVI/HDMI (PCI-Express) Rob

Share this post


Link to post
Share on other sites

sorry i forgot im running xp sp3.i know that about UT but i have landed in wienna a lot of times with pmdg 737 and never had a oom problem also i have tried the wilco and level-d and yes no problem i think the 744 is the main problem

Share this post


Link to post
Share on other sites

The 747 is the main problem for you for reasons other than the 747 being the cause of the out of memory errors. The root cause is windows 32b system method of allocating memory when you have a large video memoy. The video memory may be a separate piece of hardware but it is mapped with main memory. Your OS is simply not capable of 4Gb of memory.There has been a lot written both here and in other forums about this error. An advanced search will show that. One solution is to use the /3GB switch in the boot.ini file for XP. See the article: http://www.vfxpedia.com/index.php?title=FAQ/3GB_SwitchThere are also performance monitors available to help you discover what specifically is cause the error. The advanced search will lead you to these.

Share this post


Link to post
Share on other sites

If you use the /3G switch alone in the boot.ini (the way it is shown in the link above) with a 1G graphics card I very much doubt that your system will boot!The address space in 32-bit XP is divided by default into 2G for the system and 2G for the user (regardless of how much physical memory you have). The 1G graphics memory on your card will have to be taken from the system address space, which in the default config leaves 1G to the OS itself. You can "steal" some of that for user processes such as FSX with the /3G and /userva switches in the boot.ini, but your system will not run if you steal it all, which is what the /3G switch does if used alone.On my system with a 512MB graphics card I use the switches "/3G /userva=2816" to give myself 2816MB address space. That leaves 768MB to the OS when my 512MB graphics memory is subtracted from the total of 4096MB (=4GB). In your system the same switches would leave just 256MB for the OS, which is most likely insufficient. You could try with "/3G /userva=2304" and see if that fixes your OOM problems - that will give your OS the same memory space as mine, I'm on XP SP3 also and on my system this setting works without any performance impact. If you still have OOM problems try "/3G /userva=2560", which still leaves 512MB for the OS.You can find some details about the boot.ini switches here: http://support.microsoft.com/kb/316739This is not just an issue with PMDG products, I have seen it with a number of FSX addons. It may be a coding issue (e.g. the reference to memory leaks in another reply), but more likely it is because it is so tempting to add all sorts of addons to FSX to improve the experience, and at one point the combined memory usage becomes too high and FSX quits. The only real solution is to eventually switch to 64-bit operating systems and applications.Good luck,Tom

Share this post


Link to post
Share on other sites

ok that sounds like a fair reason2 things should i try to take out 2 gb of memory on my pcor would it help to buy a winxp 64 biti am open to sugesstions.

Share this post


Link to post
Share on other sites

No, don't remove physical memory from your computer unless you have some other reason to think it is defective. You are not getting any benefit from the last 1G of the 4G in your system (since it is "shadowed" by the graphics memory) so I suppose you could remove 1G if that configuration is supported by your chipset. It does no harm to leave it in, though.I can't comment on 64-bit XP, but I'm also interested in hearing about other users' experience running the PMDG product on that OS.Cheers,Tom

Share this post


Link to post
Share on other sites

I am running Vista64 SP1 on a Q9650 with 4Gb memory. I have not had any Vista-related problems (except I can't get 64b drivers for my old scanner or Palm). In fact, I wouldn't want to go back to XP now that I have become accustomed to Vista. However, my upgrade was forced on me by a Dell failure, which I replaced with a self-built system. The new OS also required an upgrade to my office suite (Office 2007) so there are costs involved. Maybe best to stick with what you got until your system is due for upgrade. There are solutions to the OOM problem (don't throw the baby out with the water).

Share this post


Link to post
Share on other sites

i now found out of what causes the oom in my logbook it says it was the file PANELS.DLL which i found in the fs9 module folder

Share this post


Link to post
Share on other sites

i have now bought an win xp 64 bit and until now everything has worked out just fine,i have had no problems with aircraft or other things.Now i want to take some trips in my 747 to see if the oom problem is solved.thanks for good help. :(

Share this post


Link to post
Share on other sites
i have now bought an win xp 64 bit and until now everything has worked out just fine,i have had no problems with aircraft or other things.Now i want to take some trips in my 747 to see if the oom problem is solved.thanks for good help. :(
I had this problem with a 32-bit system as well but only when using UT in conjunction with the 747. I removed UT and the OOM's went away when flying the 747. My final fix came when I built a new machine and went to Vista64 and 4GB of RAM, I am now able to fly the 747 with UT and have not seen one OOM ever since doing that. It seems 64-bit and 4GB is the permanent fix and avoids using the /3gb hack which I never really trusted anyway!Specs: QX9650 CPU, 4GB Corsair, 4870x2 2GB vid card, 2 x750GB SATAII, 1000W PSU, more and bigger fans than the Denver Broncos and a CPU cooler the size of Jupiter.

Share this post


Link to post
Share on other sites

How would you solve the OOM problem if you are running:3x 465 GTX21GB of RAMi7 ProcessorWin 7 Ultimate 64 bit1200w PSUI am with Modano.... I don't think its has to do with UT.... because I don't even have it.

Share this post


Link to post
Share on other sites