Archived

This topic is now archived and is closed to further replies.

Guest Harpo

Fs9 747 Primary Flight Display Not Turning On

Recommended Posts

Okay, so here is yet another problem I am having with FS9. This one, however, I wasn't expecting in such an upscale plane.Anyways, my Primary Flight Display (Attitude Indicator, Heading Indicator, ect.) will not activate. I've tried at least five or six different cold and dark start-up tutorials, but none of them activate the display. Can somebody please tell me what might be wrong and if not, give me another start-up checklist?-James Koets

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Cold and Dark: 1. Turn on battery 2. Stand by selector to Auto3. Turn APU selector RUN.4. Wait for APU to spool up and turn on both APU 1 and 2 on the electric panelFollowing this the ND and PFD should be on but you will then have to align the IRS to get any data.

Share this post


Link to post
Share on other sites
Okay, so here is yet another problem I am having with FS9. This one, however, I wasn't expecting in such an upscale plane.Anyways, my Primary Flight Display (Attitude Indicator, Heading Indicator, ect.) will not activate. I've tried at least five or six different cold and dark start-up tutorials, but none of them activate the display. Can somebody please tell me what might be wrong and if not, give me another start-up checklist?
James,unless you don't tell us what exactly you are doing we can't tell you what you are doing wrong :( Could it be that your IRS are still in the alignment phase?Regards,Markus

Share this post


Link to post
Share on other sites
Okay, so here is yet another problem I am having with FS9. This one, however, I wasn't expecting in such an upscale plane.Anyways, my Primary Flight Display (Attitude Indicator, Heading Indicator, ect.) will not activate. I've tried at least five or six different cold and dark start-up tutorials, but none of them activate the display. Can somebody please tell me what might be wrong and if not, give me another start-up checklist?-James Koets
Does this happen only when you cold start or anytime you load the plane?Probably this from the PMDG 744 FAQ- "Why do I see blank screens after loading the plane?This is a failure of the validation system. First try reinstalling the aircraft and if the problem persists, contact Support with your name and order ID and we'll get the issue sorted out!" support@precisionmanuals.comhttp://ops.precisionmanuals.com/wiki/PMDG_...ng_the_plane.3FJay V

Share this post


Link to post
Share on other sites

James,The other displays are working though? If so it's possible you just have the brightness control for the PFD all the way down. Check the knobs, they're accessible from the VC by looking to the left of the glareshield. If the other displays are also blank, it's probably a validation issue, as someone else alread said.

Share this post


Link to post
Share on other sites

Well, I have my IRS set for instant alignment, so it definitely can't be those.And "Tabs", can you be more specific about this brightness knob? What it is labeled, ect.And yes, all of my other displays are working fine. I've even programmed my FMC for a flight after my ILS had aligned, but my panel still did not "come alive". So if you could be a bit more specific about said knob, I would be really grateful.-James

Share this post


Link to post
Share on other sites
Well, I have my IRS set for instant alignment, so it definitely can't be those.And "Tabs", can you be more specific about this brightness knob? What it is labeled, ect.And yes, all of my other displays are working fine. I've even programmed my FMC for a flight after my ILS had aligned, but my panel still did not "come alive". So if you could be a bit more specific about said knob, I would be really grateful.-James
James, the brightness knobs are located on the far left side of the glareshield in the VC. There's two knobs, one for the PFD and one for the ND. Check page 320 of the downloadable 747 manual, it shows a screenshot of it. I'd take one myself but I'm traveling right now and can't run FS on my laptop...

Share this post


Link to post
Share on other sites

I feel somewhat bad about asking this, at I may seem kind of annoying at this point but um...where can I get the manual? :(

Share this post


Link to post
Share on other sites

Well, I went through my start-up procedures as normal and after my ILS had aligned, I switched to the virtual cockpit to light up the panels and...Well, the "panel" knob didn't do anything and I couldn't even get the "Map" knob to turn. And, in case this helps anyone, if I don't go to Cold and Dark cockpit, I get my PFD for about thirty seconds and then it goes off. But the plane keeps running, I can still use the FMC, Lights, etc. So...any other advice?-James

Share this post


Link to post
Share on other sites

Well that sounds very much like a validation problem:

Does this happen only when you cold start or anytime you load the plane?Probably this from the PMDG 744 FAQ- "Why do I see blank screens after loading the plane?This is a failure of the validation system. First try reinstalling the aircraft and if the problem persists, contact Support with your name and order ID and we'll get the issue sorted out!" support@precisionmanuals.comhttp://ops.precisionmanuals.com/wiki/PMDG_...ng_the_plane.3FJay V

Share this post


Link to post
Share on other sites