Sign in to follow this  
Guest Tashunca-Uitco

Tile Proxy guide

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Bonsoir à tous,J'ai depuis quelques jours, une connexion Internet plus performante, et je voudrais m'essayer à Tileproxy, j'ai donc téléchargé et installé la dernière version disponible sur le site SourceForge, à savoir le version Beta8. Après installation j'ai modifié le fichier Proxyuser.ini en m'inspirant des conseils trouvé sur ce forum, voir le contenu de ce fichier ci-après.J'ai lancé Tileproxy via le menu "Start Tileproxy" il y a quelques erreurs qui s'affichent,(j'ai une copie d'écran de la console mais je ne sais pas comment placer une image) puis j'ai lancé FSX, je me suis placé dans une zone ne comportant que des textures originales, j'ai attendu plusieurs dizaines de minutes, sans rien voir de nouveau au niveau des textures.J'ai parcouru et lu les 9 pages de cette rubrique, j'ai bien que j'avais lu, mais pas forcement tout compris.Si parmis les spécialistes de Tileproxy, quelqu'un peu prendre quelques minutes pour m'aiguiller vers une solution, je l'en remercie d'avance.PierreMa config:Proc: Q9550 2.83GHz-4Go DDR3-CG ATI 5850-Window 7 64FSX sur Disque D: 500GoTileProxy Photoreal World sur Disque F: 400GoO&O Defrag 14Le fichier Proxyuser.ini### Start a line with # to comment it out.#[TileProxy]master_enable=On#logfile="C:\logfile.txt"diskless_mode=Offoffline_mode=offmax_lod=15preload_min_lod=8preload_max_lod=15max_contexts=512water_mask=Onwater_blending=Onblend_distance=500.0blend_exponent=1.0alpha_min=0.2678alpha_max=0.7water_rgb=#000D1Awater_smoothing=Offwater_threshold=0.33cache_bytes_limit=100000000cache_tiles_limit=100000source=VE#source=Google Earth#source=Yahoo Maps#source=Webatlasmenu_sources="Google Earth|Virtual Earth|Webatlas|Yahoo Maps"enable_hooking=Noenable_dx9hook=Noenable_movingmap=Nomovingmap_alpha=255movingmap_color=#ff000000movingmap_xpos=88movingmap_ypos=15movingmap_width=60movingmap_height=80movingmap_radius=60[Google Earth]cache_folder=F:\cache.service1network_module=libnettilemodule_config="server=http://kh*.google.com|path=/kh?t=t%s&n=404&v=17|quad=qrts|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=17color_hack=Nocolor_level=0bulk_extend=50[VE]cache_folder=F:\cache.service2network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17map_version=637level_mapping=10,10,12,14,14,15,16,17#level_mapping=9,10,11,14,14,14,15,16,17,18#level_mapping=9,10,11,12,14,14,15,16,17,18,19 more radius HQ (13->14)#level_mapping=9,10,11,14,14,14,15,16,17,18,19 even more radius in HQ (12,13->14)color_hack=Nocolor_level=0bulk_extend=50[Yahoo Maps]cache_folder=F:\cache.service3network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17level_mapping=10,10,12,14,14,15,16,17map_version=1.9color_hack=Nocolor_level=0bulk_extend=50 [Webatlas]cache_folder=F:\cache.service4network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://ts1*.webatlas.no|path=/qt_1881/%s.png?s=%v|quad=0123|balance=0123456|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17map_version=1level_mapping=10,11,14,14,15,15,16,17color_hack=Yescolor_level=13bulk_extend=50

Share this post


Link to post
Share on other sites
Bonsoir à tous,J'ai depuis quelques jours, une connexion Internet plus performante, et je voudrais m'essayer à Tileproxy, j'ai donc téléchargé et installé la dernière version disponible sur le site SourceForge, à savoir le version Beta8. Après installation j'ai modifié le fichier Proxyuser.ini en m'inspirant des conseils trouvé sur ce forum, voir le contenu de ce fichier ci-après.J'ai lancé Tileproxy via le menu "Start Tileproxy" il y a quelques erreurs qui s'affichent,(j'ai une copie d'écran de la console mais je ne sais pas comment placer une image) puis j'ai lancé FSX, je me suis placé dans une zone ne comportant que des textures originales, j'ai attendu plusieurs dizaines de minutes, sans rien voir de nouveau au niveau des textures.J'ai parcouru et lu les 9 pages de cette rubrique, j'ai bien dit que j'avais lu, mais pas forcement tout compris.Si parmis les spécialistes de Tileproxy, quelqu'un peu prendre quelques minutes pour m'aiguiller vers une solution, je l'en remercie d'avance.PierreMa config:Proc: Q9550 2.83GHz-4Go DDR3-CG ATI 5850-Window 7 64FSX sur Disque D: 500GoTileProxy Photoreal World sur Disque F: 400GoO&O Defrag 14Le fichier Proxyuser.ini### Start a line with # to comment it out.#[TileProxy]master_enable=On#logfile="C:\logfile.txt"diskless_mode=Offoffline_mode=offmax_lod=15preload_min_lod=8preload_max_lod=15max_contexts=512water_mask=Onwater_blending=Onblend_distance=500.0blend_exponent=1.0alpha_min=0.2678alpha_max=0.7water_rgb=#000D1Awater_smoothing=Offwater_threshold=0.33cache_bytes_limit=100000000cache_tiles_limit=100000source=VE#source=Google Earth#source=Yahoo Maps#source=Webatlasmenu_sources="Google Earth|Virtual Earth|Webatlas|Yahoo Maps"enable_hooking=Noenable_dx9hook=Noenable_movingmap=Nomovingmap_alpha=255movingmap_color=#ff000000movingmap_xpos=88movingmap_ypos=15movingmap_width=60movingmap_height=80movingmap_radius=60[Google Earth]cache_folder=F:\cache.service1network_module=libnettilemodule_config="server=http://kh*.google.com|path=/kh?t=t%s&n=404&v=17|quad=qrts|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=17color_hack=Nocolor_level=0bulk_extend=50[VE]cache_folder=F:\cache.service2network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17map_version=637level_mapping=10,10,12,14,14,15,16,17#level_mapping=9,10,11,14,14,14,15,16,17,18#level_mapping=9,10,11,12,14,14,15,16,17,18,19 more radius HQ (13->14)#level_mapping=9,10,11,14,14,14,15,16,17,18,19 even more radius in HQ (12,13->14)color_hack=Nocolor_level=0bulk_extend=50[Yahoo Maps]cache_folder=F:\cache.service3network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17level_mapping=10,10,12,14,14,15,16,17map_version=1.9color_hack=Nocolor_level=0bulk_extend=50 [Webatlas]cache_folder=F:\cache.service4network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://ts1*.webatlas.no|path=/qt_1881/%s.png?s=%v|quad=0123|balance=0123456|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17map_version=1level_mapping=10,11,14,14,15,15,16,17color_hack=Yescolor_level=13bulk_extend=50

Share this post


Link to post
Share on other sites

Bonjour,Je voulais éditer mon post de manière a ajouter un mot que j'ai sauté lors de la redaction de ma demande, et malheureusement j'ai fait une erreur, si un administrateur peut enlever le dernier post afin de ne pas encombrer la rubrique.Merci d'avance.Pierre

Share this post


Link to post
Share on other sites

Bonjour Pierre et bienvenue dans le monde de TPNormalement, l'installation de tileproxy doit se passer sans aucun problème pour autant que tout soit fait correctement :( A ta place je dé-installerais TP et je recommencerais tout à Zéro, comme suit :En premier lieu, lire, en français :Une introduction a Tileproxy : http://patricegarret.spaces.live.com/et une documentation en français, elle date un peu, mais est toujours valable : http://v443oe.pjointe.com/IMPORTANT pour W7 : Désactive l'UAC et la vérification de la signature des pilotes (F8 au boot)Avant d'installer, il te faudra créer trois dossiers vides, de préférence sur un autre disque, où au moins une autre partition que C:/ et que tu nommeras :cache.service1cache.service2cache.service3Note bien leurs emplacements (chemin que tu devras indiquer à l'installation de Tileproxy)Réinstalle TileproxyTu devras indiquer où tu veux installer "Tileproxy Photoreal World" (préférable de ne pas le mettre sur C:/)Ensuite pour les cache.service, indique le bon chemin vers ou tu les a créés.Poursuit l'installation, une fois celle-ci finie, renomme le ProxyUser.ini d'origine (qui ne fonctionne pas) en ORIGINALProxyUser.iniet remplace le par celui qui suit (réglages FSX/Paramètres - affichage/ Décors/ Résolution de la texture en 1 mètre).Il est éprouvé, c'est une base sure pour voler entre 1'000 et 3'000 pieds/sol à une vitesse de 70-110 nœuds.------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------[TileProxy]master_enable=Ondiskless_mode=Offoffline_mode=Nomax_lod=15preload_min_lod=8preload_max_lod=15max_contexts=512water_mask=Onwater_blending=Onblend_distance=500.0blend_exponent=1.0alpha_min=0.2678alpha_max=0.7water_rgb=#407B80water_smoothing=Offwater_threshold=0.33cache_bytes_limit=800000000cache_tiles_limit=200000source=Virtual Earth#source=Webatlas#source=Yahoo Mapsmenu_sources="Virtual Earth|Webatlas|Yahoo Maps"enable_hooking=Noenable_dx9hook=Noenable_movingmap=Nomovingmap_alpha=255movingmap_color=#ff000000movingmap_xpos=88movingmap_ypos=15movingmap_width=60movingmap_height=80movingmap_radius=60[Virtual Earth]cache_folder=I:\cache.service1network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17map_version=637level_mapping=10,11,12,14,14,15,16,17color_hack=Yescolor_level=13bulk_extend=50[Webatlas]cache_folder=I:\cache.service2network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://ts1*.webatlas.no|path=/qt_1881/%s.png?s=%v|quad=0123|balance=0123456|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17map_version=1level_mapping=10,11,12,14,14,15,16,17color_hack=Yescolor_level=13bulk_extend=50[Yahoo Maps]cache_folder=I:\cache.service3network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=10max_level=17level_mapping=10,11,12,14,14,15,16,17map_version=1.9color_hack=Nocolor_level=0bulk_extend=50------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Réglages : D'autre part, il faut être cohérent, je rappelle une énième fois la règle de configuration :Si preload_min_lod = 8 alors le min_level doit être égal à 8 + 2 soit 10Si max_lod et prelod_max_lod = 15, le max_level doit être égal à 15 + 2 soit 17Je précise aussi aussi que j'utilise le level_mapping pour faire disparaitre une transition désagréable au niveau des couleurs du level 13 (surtout avec VE)Abuser du level_mapping, vous expose à des pertes de performances significatives....TP ne gère que 10 niveaux de mapping au maximum (de 10 à 19), en indiquer plus, comme de min 5 jusqu'à max 19 ne sert strictement à rien.Ne pas oublier de désactiver l'antivirus, et de paramétrer le pare feu standard de windows pour autoriser dans les exceptions lesprocessus "FSX.exe et Proxyuser.exe". Pour les autres pare feu : parfois nécessaire de les désactiver.Régler impérativement les FPS entre 15 et 20, pas plus de 25 maxi. Au delà, vous n'obtiendrez qu'une chute dramatique de la vitesse de chargement des "tuiles".Ne jamais utiliser FPS_Limiter_V2 avec Tileproxy.Voilà, à toi de jouer, je reste à ta disposition PatricePS : Webatlas est un petit service pour la Norvège. Je rappelle que l'ancien service 2 (Google Maps) ne nous est plus accessible depuis 2008 !!!

Share this post


Link to post
Share on other sites

Bonjour Patrice,Merci pour ces conseils, que je vais appliquer tout de suite, en fait entre temps j'ai relu les divers post sur le sujet, et j'ai téléchargé et appliqué le petit utilitaire dseo13b ce qui m'a permis de lancer Tileproxy sans erreur au lancement de la console, par contre après lancement de FSX, le chargement du terrain s'arrête à 44%.Autre chose, l'expérience avec le Robinson R22, çà continu ou non.Bons vols virtuel ou non.Pierre

Share this post


Link to post
Share on other sites

Bonjour Pierre,Le blocage du chargement des "tuiles" vers 44% est assez typique d'un Tileproxy qui commence à charger les tuiles en mémoire mais qui ne trouve pas ses "cache.service" pour pouvoir les stocker.Reprend donc tout à la base, comme indiqué.Pour le R22, oui, l'expérience continue... En fonction de mon budget !A+ Pat

Share this post


Link to post
Share on other sites

OUPS !!!!J'ai oublié un détail :Chez moi, le chemin pour les cache.service c'est I:\Bien sur, chez toi, ce sera peut-être différent, il faut donc corriger ton ProxyUser.ini[Virtual Earth]cache_folder=(Ton chemin)cache.service1Et pareil pour les deux autres services

Share this post


Link to post
Share on other sites

Merci Patrice pour cette précision, j'avais modifié le chemin pour tenir compte de l'emplacement des "cache.service" sur ma machine, qui sont sur le disque F.A+Pierre

Share this post


Link to post
Share on other sites

Update your ProxyUser.iniService 1 Virtual Earth (Microsoft Bing maps) map_version=662

Share this post


Link to post
Share on other sites

Good morning AvsimUpdate your ProxyUser.iniService 1 Virtual Earth (Microsoft Bing maps) map_version=664

Share this post


Link to post
Share on other sites

Bonsoir et merci à Patrice pour les informations et le guide ce qui me permet de voler sur FSX & TP. Je commence d'ailleurs un tour de France VFR :)

Share this post


Link to post
Share on other sites
Bonsoir et merci à Patrice pour les informations et le guide ce qui me permet de voler sur FSX & TP. Je commence d'ailleurs un tour de France VFR :)
BonjourC'est ton premier post, donc... (il est d'usage, ici, de les signer avec son vrai prénom)Je te souhaite la bienvenue parmi nous et beaucoup de plaisir avec TP.A+ patricePS : Service 1 (VE - Bing) map_version=671

Share this post


Link to post
Share on other sites

Bonjour :)J'ai un problème avec mon TP (W7 + FSX SP2). Il est correctement configuré avec l'aide de ce poste, se lance bien avant FSX et je vois bien mon aérodrome local avec la cartographie satellite. En revanche quand je vole et que je m'éloigne, TP ne télécharge que par pics et FSX ne semble pas réactualisé les textures ce qui fait que plus je m'éloigne de mon point de départ initial plus les textures au sol sont grossières. Est-ce que cela vous dit qqchose ?Merci !Olivier

Share this post


Link to post
Share on other sites

Bonsoir Olivier,A priori, c'est assez typique d'un TP qui ne trouverait pas ses cache.service sur disque. Au début, il charge les tiles en RAM, pas de problème... Mais après ! Ça coince !!!Va donc vérifier qu'à l'emplacement que tu as défini et indiqué à TP à l'installation pour tes cache.servicetes dossiers "cache.service1, cache.service2 et cache.service3" existent bien. Si pas crée les (vides, ils se rempliront tout seuls)Petit exemple : [Virtual Earth]cache_folder=J:\cache.service1network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=11max_level=17map_version=671level_mapping=11,12,14,14,15,16,17color_hack=Yescolor_level=13bulk_extend=50Chez moi, le chemin correct est J et les dossiers cache.service sont bien là et ils se remplissent au fur et à mesure de l'utilisation de TP.Ce chemin peut bien sur être différent chez toi :( Si c'est pas ça, poste ici ton ProxyUser.ini, que je puisse le vérifier.A+ Patrice

Share this post


Link to post
Share on other sites

Merci de ta réponse Patrice, curieusement cela fonctionne correctement à nouveau. Cela dit j'ai remarqué ce problème surtout en résolution 17 car je viens de commencer un tour de France VFR, et mon 1er vol entre Nice et Saint Tropez s'est correctement réactualisé tout le long (résolution 15)En parlant de résolution voici quelques captures en 17 dans les Alpes, que c'est beau ! Je ne pourrai plus voler sans TPhttps://picasaweb.google.com/phullbrick/FlightSimulatorXTileproxy?authkey=Gv1sRgCIeFi5Hjup7kRg&feat=directlinkBonne soirée :)Olivier

Share this post


Link to post
Share on other sites

Bien le bonjour. Je vais vous faire part d'un "essai" : Vous avez du vous rendre compte que la map_version Vitual Earth / Bing Maps changeait souvent et que celle de Yahoo Maps pouvait rester immuable pendant des mois.J'ai donc creusé un peu le sujet et je me suis rendu compte que 1.9 était le numéro de map_version principal mais qu'en fait le numéro complet était 1.9.6.11Et que lui, par contre, change donc beaucoup plus souvent. Alors pourquoi pas l'essayer dans mon proxyuser.ini En route pour les USA (avec les excellents meshs free en 10 m. de Raymondo Taburet)Départ de Cody près du Yellowstone en direction de l'ouest vers le lac. Pour l'essai, je n'ai rein changé dans mes réglages en 1.1 m/pixel (max_lod=15 et preload_max_lod=15 donc max_level=17)J'ai fait un moment de vol avec 1.9.6.11, puis j'ai sauvegardé et fermé FSXRedémarrage avec 1.9 faire encore un bon bout de vol et j'ai recommencé en alternance l'opération plusieurs fois map_version=1.9.6.11#map_version=1.9 #map_version=1.9.6.11map_version=1.9 Ce que je vais dire n'est ni prouvé, ni scientifique, c'est plutôt un sentiment, une impression : En utilisant 1.9.6.11 , non seulement ça fonctionne, mais ça parait charger plus vite en particulier dans le dernier ovale (Level 17) et la définition me semble visuellement meilleure. Si un certain nombre d'entre vous veulent essayer et me faire part de leurs impressions ce serait cool. Nice fligths, Pat

Share this post


Link to post
Share on other sites

Super boulot, Pat. On aimerait bien que tous les tutos soient du même métal. Petit truc : la manip avec le gestionnaire des taches pour l'affinité peut être remplacée par : [JOBSCHEDULER]AffinityMask=3 //3 (2cores), 7 (3cores), 15 (4 cores), 63 (6 cores) dans fsx.cfg Et la plomberie, ça tient ?smile.png

Share this post


Link to post
Share on other sites

Merci pour les compliments, N'ayant jamais fait de blog... Je découvre, je complète et j'améliore au fur et à mesure. Merci Philippe, bon, je connaissais le truc et je l'utilise avec FSX, mais il ne fonctionne pas avec TP... Seule la manip via le gestionnaire de tâche est efficace. Sinon la plomberie va nickel LOL.gif A+ Patrice

Share this post


Link to post
Share on other sites

Beau travail !Merci aussi pour la tenue à jour des diverses versions.Essai avec "Yahoo 1.9" comme proposé ne donne pas de résultats flagrants mais j'ai trop peu d'expérience avec ce fournisseur (plus avec VE sur la France)Pierre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this