Jump to content

Sign in to follow this  
GerarDream

FS2004 killed by Windows 7? (RTM 32 bits)

Recommended Posts

Hi. I beta tested Windows 7 from the beginning.I have trouble with FS 2004 and the second beta version (I don't remember the number :( ) but with the release of the RC version (and the new nVidia drivers) the trouble has gone.With the release of the RTM version and the new 190 nVidia drivers I have the problem again: I can't change my view with the S key. In fact, I almost can't change my view anyway. If I do this via the menu, I see a mix of two or three views together :( I changed the nVidia drivers for the older versions but the trouble is still here, so I return to the last ones.Is this a known issue? I have informed it in the microsoft windows 7 beta testers forum but nobody cares B) I have FSX, but in my PC is too slow. More, with W7 I can use a slow FSX but with XP what I see is a slide session instead of a simulation :( Thanks

Share this post


Link to post
Share on other sites

Hello, I've been running FS2004 on W7 RC x64 since May 2009 with no major problems. I do have a few payware products that either won't install or have glitches, but 80% of my payware runs fine.I have a GTX260 w/ the latest drivers too. The only big video problem I have is blurry ground textures, but I had that problem using XP too. My experience has been that any product claiming compatibility with Vista will run in W7 x64.

Share this post


Link to post
Share on other sites

I don't think it is a known issue. Using Win7 since the early betas and FS9 runs fine: change views are ok. Used the 180 nvidia drivers without problems.Am now using the 190's versions but that is because of a game "Wolfenstein" that will not run on any other driver.

Share this post


Link to post
Share on other sites

Hi, thanks. As I said, I'm beta tester, so I'm using W7 from the very beginning and with some version I had no problems and with other I had it.I'm referring to the RTM (the last version). But if you are using it and have no problems, could be something in my PC, my Windows.... or my head :( :( :(Thanks.

Share this post


Link to post
Share on other sites

I've got the same problem with an X1950pro (AGP), so it's not a Nvidia thing. It works OK in full screen, but as I use 2 monitors in windowed mode (the second for popups) I'm going to keep trying to get it working in windowed mode. My Pentium D (3.4GHz) seems to be better utilized in Win 7 (both cores carry more of a load for some reason), so that's my encouragement!Cheers, SLuggy

Share this post


Link to post
Share on other sites

Success! I disabled the Aero theme, and it worked no worries, able to drag windows to the other monitor no worries, and the windowed mode worked fine.The best bit was when I quit FS9, re-enabled the Aero theme and I can STILL do the same! For some reason the above procedure must of jogged something in the display driver or FS9. Don't know what, but am happy to take the win! :( Cheers, SLuggy

Share this post


Link to post
Share on other sites
Success! I disabled the Aero theme, and it worked no worries, able to drag windows to the other monitor no worries, and the windowed mode worked fine.The best bit was when I quit FS9, re-enabled the Aero theme and I can STILL do the same! For some reason the above procedure must of jogged something in the display driver or FS9. Don't know what, but am happy to take the win! :( Cheers, SLuggy
I confirmed: it worked.Thanks a lot :(

Share this post


Link to post
Share on other sites

This was a known issue with FS9 running in Vista as well.RegardsBob ScottColonel, USAF (ret)ATP IMEL Gulfstream II-III-IV-VColorado Springs, CO

Share this post


Link to post
Share on other sites

Yes - FS2004 isn't "Desktop Composition" aware, so it gets all messed up if you run with Aero.BUT - Do not disable Aero via your desktop settings! Just do it on the application level with the shortcut!(Applicable in both Vista and Windows 7)Right click on your FS2004 shortcut... Properties...Compatibility Tab...Check off the box for "Disable Desktop Composition"This will temporarily disable Aero when you launch FS2004, and restore Aero once you are done. No muss, no fuss, and "permanently" set on the shortcut! This is done automatically for us users of FSX, as FSX has the code in it to look for composition. Just make that simple shortcut adjustment and you'll be enjoying Aero without having to keep it off to support your flying habits. Good luck!-Greg

Share this post


Link to post
Share on other sites
Hello, I've been running FS2004 on W7 RC x64 since May 2009 with no major problems. I do have a few payware products that either won't install or have glitches, but 80% of my payware runs fine.I have a GTX260 w/ the latest drivers too. The only big video problem I have is blurry ground textures, but I had that problem using XP too. My experience has been that any product claiming compatibility with Vista will run in W7 x64.
Specifically which add-ons are you having problems with?

Share this post


Link to post
Share on other sites

I have no problems with W7. More: FS9 goes a little faster, but FSX goes very faster than in Xp or Vista.All of my addons worked fine: PMDG 747 and 737 (and 747 and MD11 in FSX), Radar Contact, ActiveSky, Wilco Embraer, Aeroworx Beechcraft, FlightSim Commander, FSNavigator, FSBuild, SuperFlight Planner (yes, I know, I have too much flight planners....), FS PanelStudio, Jeppessen, and more, as I said, without problems in Windows 7.

Share this post


Link to post
Share on other sites

Had a weird thing last night. Running Win 7 Pro and had issues with saving FSUIPC configs (they won't stick, have to do them over each time I fly the aircraft) so I decided to run FSX as admin. When I tried to center my Track IR with F12 I got the satellite view. Very strange.

Share this post


Link to post
Share on other sites

Grateful for any help please:

I have installed FS9 successfully onto my C:/ drive (non 86) in Windows 7 Pro, but am unable to install scenery add-on software using Installshield. We have no choice but to use the version of Installshield, but it partially operates and then hangs before cancelling itself out. Can anyone help me to find a way to install my FS9 add-on software on the Windows 7 Pro OS please? Thanks in advance for any advice offered. Marwel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...