Jump to content

Archived

This topic is now archived and is closed to further replies.

davidv

JS41 and Windows 7 UAC

Recommended Posts

Ryan mentioned in a thread in the Windows 7 forum that there may be an issue with UAC and the JS41.The first thing I did after getting Windows 7 installed was to turn off UAC and I've left it off ever since. I installed FSX after turning UAC off but Ryan said there may be an issue with running the JS41 and UAC off.As it's looking close for release should I just leave things as is and try it out or should I reformat Windows 7 and reinstall everything with UAC set to default?


David V

Share this post


Link to post

I would defiantly not do anything until a problem actually occurs, kinda like fixing your car before it breaks. Even if there is a problem just turn UAC back on. Good luck


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post

From what I was told simply turning it back on wouldn't solve the issue and that a full format may be required.


David V

Share this post


Link to post

Guys, we're really not sure what the issue is exactly yet. Something does happen, several of us have verified it, but most of the team is not running Win 7 RTM yet (if you're running the RC you're fine, this issue is occurring only with the final RTM code that MSDN people etc have access to) I was able to verify that a full FSX uninstall (including registry entries etc) does reset the issue, you don't have to format.We're going to look at this after release and we'll hopefully have it resolved before the actual retail Windows 7 release. My fingers are very much crossed that MS didn't do something that isn't going to get fixed because of ACES no longer existing... it worked perfectly fine in the RC, so I was pretty upset to see this come up with the RTM. Initially I thought everything was fine with the RTM too, but then this popped up a few days after I'd installed RTM.There is a workaround I discovered, and that's to load up the default Cessna 172 first and then load the J41 from there. It's an inconvenience, but the plane does work when you do this.Here's what the issue looks like - deflected control surfaces in the Free Flight screen and then blank/frozen gauges in the plane once you actually load it.Please note too that this issue is not guaranteed to occur or something like that, it's working correctly for me right now and has been for the last few RC versions. We did see it for sure after installing the plane with UAC off though, but I've seen it happen with UAC on now too, just randomly starts happening.


Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post

Typical MS screw-up.If you could debug it to death on both RC and RTM, and let us know exactly what is different, it would be greatly appreciated.Best regards,Robin.

Share this post


Link to post
Guest 413X3

I see strange issues with vista x64 and UAC turned off with the PMDG 747X, disappearing textures, messed up panel states, etc. I wonder if its some general issue?

Share this post


Link to post

I don't know, 413X3, I use Vista64 with UAC off (always) and never knew it could be a problem.


Dan Downs KCRP

Share this post


Link to post
Typical MS screw-up.If you could debug it to death on both RC and RTM, and let us know exactly what is different, it would be greatly appreciated.Best regards,Robin.
Well obviously RTM is the version we have to deal with... I ran RC for most of the beta test and I see no differences at all aside from this issue as far as FSX goes. The RTM version is faster and more snappy in the general use of the OS though, which is good.

Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post

I also run Vista 64-bit with UAC disabled and haven't noticed any adverse side-effects.I'm currently running the Win 7 RC with UAC disabled, and so far it is running very well.Good to hear that generally the RTM is even quicker. Shame about this problem.Are you running the 32-bit or 64-bit version of Win 7?Best regards,Robin.

Share this post


Link to post

I used to get some problems with textures missing and some crashes but I recently did a fresh install of Vista and activated the real Administrator account ( the one that they hide from you) And I seem to have less oddities when using FSX. I'll will probably do the same when and if I ever upgrade to 7.


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Guest jlaine128
I also run Vista 64-bit with UAC disabled and haven't noticed any adverse side-effects.I'm currently running the Win 7 RC with UAC disabled, and so far it is running very well.Good to hear that generally the RTM is even quicker. Shame about this problem.Are you running the 32-bit or 64-bit version of Win 7?Best regards,Robin.
His signature says x64

Share this post


Link to post

Thanks for the reply Ryan. I'm running the RC so I'll just leave things be and see how things go. When running a beta of anything, especially Windows, issues are bound to occur - just wanted a heads up on whether or not I should quickly format ahead of time or not. Seems that's a not fortunately :)


David V

Share this post


Link to post
Guest ziporama

UAC can be turned off in Windows 7 RTM if that's an issue, and it's a simple matter of dragging a slider down - no longer a complex procedure requiring an advanced degree or certificate :)Cheers,

Share this post


Link to post
UAC can be turned off in Windows 7 RTM if that's an issue, and it's a simple matter of dragging a slider down - no longer a complex procedure requiring an advanced degree or certificate :)Cheers,
That's the entire issue here - with it OFF, you see this issue. That slider does not appear to do what disabling UAC did in Vista either, it's no longer possible to have it fully off, all the slider does is essentially tell the OS to click the UAC prompts internally for you.

Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post
×
×
  • Create New...