Jump to content

Sign in to follow this  
bojote

Bojote's Shader 3.0 mod for FSX

Recommended Posts

Isn't there another dll file to put in the main fsx folder as well? Or is it just that animation one
You're right, David - there is another file, but I don't remember its name, and didn't spot it in any of the "auto" and "freeze" searches I did (on the three or four "neatnick" forums we now have to deal with when we have problems) to find the one that pointed to uiautomation.dll.. Oh well - I got it in the end. This is the one that fixed the freeze, and I don't honestly know what the other one was for. :(

Share this post


Link to post
Share on other sites

*******, just noticed you have the NewMaterialUsage flag set to false in the swarmcloud.fx file. Is that what you intended? I've been seeing some flashing clouds (The whole sky not individual clouds) since. Put it back to true and the flashing stopped. It did cost me a couple of fps (That probably has accounted for my perceived performance gain with this mod.), but it looks better now.


Thanks

Tom

My Youtube Videos!

http://www.youtube.com/user/tf51d

Share this post


Link to post
Share on other sites
*******, just noticed you have the NewMaterialUsage flag set to false in the swarmcloud.fx file. Is that what you intended? I've been seeing some flashing clouds (The whole sky not individual clouds) since. Put it back to true and the flashing stopped. It did cost me a couple of fps (That probably has accounted for my perceived performance gain with this mod.), but it looks better now.
Hi Tom, individual CLOUD flashing is caused by having NewMaterialUsage set to 'True' SKY flashing is due to having water set to LESS than HIGH 2.0 when using BP=0 (FSX is very strange sometimes) :)You don't really need special 'material' textures for clouds, they are 'sprites' little tiny dots, not actual 'textures' like runways or AC, so you are perfectly fine having NewMaterialUsage set to false. it was discovered some time ago by a user who posted here recently :)

Share this post


Link to post
Share on other sites
Hi Tom, individual CLOUD flashing is caused by having NewMaterialUsage set to 'True' SKY flashing is due to having water set to LESS than HIGH 2.0 when using BP=0 (FSX is very strange sometimes) :)You don't really need special 'material' textures for clouds, they are 'sprites' little tiny dots, not actual 'textures' like runways or AC, so you are perfectly fine having NewMaterialUsage set to false. it was discovered some time ago by a user who posted here recently :)
Thanks! I don't use the BP=0 tweak, as it doesn't work well on my system. It lowers performance, and causes CTD's I didn't have before on long flights with complex aircraft, like the PMDG 744. I'm sure it's because of the limitation of my video card which is only a 9800GTX with 512MB. (Running on an E6850 3.0Ghz 4GB system). I do use the TextureMaxLoad tweak, which helps IQ considerably (As well as this Shader mod). 2X high water will probably cause a higher performance hit on my system then leaving the NewMaterialUsage to True, so I'll just leave it at that.Thanks!

Thanks

Tom

My Youtube Videos!

http://www.youtube.com/user/tf51d

Share this post


Link to post
Share on other sites
Hi all,Can any ATI 5870 users trying ******* Mod please try these settings and report back there IQ & FPS findings. Make sure you fly in fairly dense weather. I'm getting some very encouraging results with SSAAand Shader 3.0, Ive just removed the 10.4 beta driver and installed the Release version, so I need people to verify things, I wasn't seeing with the Beta (ie. Big improvements)10.4 Release DriversShader update V1.1 (Shader Model 3.0)FSX AA UN-TICKEDCCC settings:Use application settings UNTICKEDAA Super-Sample x 4 with Wide-tent filter (samples x8)AF x16AI AdvancedAA Mode QualityMipMap Qualityfingers crossed...........
Entered those exact settings and have had no trouble. By chance where I flew today (YMML) had a really dirty day with heavy rain and visibility down to ~300ft. Not a bad test and the 5870 had no glitches whatsoever.OTOH yesterday it was constantly stuttering with CS B763 over water.BTW addons are REX2, My Traffic 2010, FTX AU Blue and CS B763.EDIT: Catalyst 10.4 finalMy sound is dropping to around 10% of its normal level but I'm sure that's another issue altogether.

Share this post


Link to post
Share on other sites

I using the shaders 3 mod, have one question, can I still use the fs water configurator with it?


 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
Hi Tom, individual CLOUD flashing is caused by having NewMaterialUsage set to 'True' SKY flashing is due to having water set to LESS than HIGH 2.0 when using BP=0 (FSX is very strange sometimes) :)You don't really need special 'material' textures for clouds, they are 'sprites' little tiny dots, not actual 'textures' like runways or AC, so you are perfectly fine having NewMaterialUsage set to false. it was discovered some time ago by a user who posted here recently :)
*******, is NewMaterialUsage set to false? I think so, but not sure how to interpret this!float4 g_vEyePoint : VIEWPOSITION;const bool EffectDeclaration< string Name = "SwarmCloud"; string Class = "Basic"; bool NewMaterialUsage = false;> = true;

Noel

Share this post


Link to post
Share on other sites
I using the shaders 3 mod, have one question, can I still use the fs water configurator with it?
No.

Share this post


Link to post
Share on other sites
No.
Simple enough, thanks for letting me know.

 

as.jpg

Seinfeld Quote of the Month:

"Course, it would have to be someone who hasn't heard the story before. Someone who is unencumbered by any emotional attachment. Someone whose heart is so dark, it cannot be swayed by pity, compassion, or human emotion of any kind"

Share this post


Link to post
Share on other sites
I using the shaders 3 mod, have one question, can I still use the fs water configurator with it?
I tried that and ended up with white water textures so I reverted back . Looked nice before that though.jja

Jim Allen
support@skypilot.biz
SkyPilot Software home of FSXAssist / P3DAssist

LionheartVictoryBanner02s-369x97.png

Share this post


Link to post
Share on other sites

Just want to add that Shader mod 3.0 is working great here as well on my HD5870! Noticed much smoother/fluid flight and able to maintain consistant FPS thru all kinds of heavy weather conditions.Using CCC 2X Super Sampling AA16X AFBP=0Affinity Mask=14HighmemfixForceFullScreenVSync=1Shader Mod 3.0EnbseriesActive Sky EvolutionREX2My FSX experience looks better and runs smoother than it ever has! The only thing I noticed is the water reflections seem a bit too much. FSX water set at High 2X. Is there a way to tone down the water reflections a bit? Could it be the REX2 water textures? Thanks everyone!


  • ASRock Extreme6,  Intel 6700K@4.6, GSkill DDR4-3400, Gigabyte GTX1070 G1,

Samsung 850 EVO, WD Black 2TB, Corsair 850HX, Noctua NH-D14,Cooler Master HAF 932, BenQ 32" 2K, WIN 10 Pro

Share this post


Link to post
Share on other sites

Vandolf,If you get the latest drivers installed you might well be able to up the SSAA to x4 or x8... :(


Craig Sells

Share this post


Link to post
Share on other sites

Sadly it doesn't work for me.In FSX preview window all aircraft appear without textures already.Some runways from addon airports are black, clouds with edges and the wing of the glider i.e. is displaced by 90 degrees with front gear on top of the wing lol.I deleted shader cache and made the two entries under graphic section.Could it be a problem of OS? Does this tweak only work with Win 7?


Regards,

Mats Weinberger

Share this post


Link to post
Share on other sites
FSX water set at High 2X.
Vandolf, that is why. Set it to Low 2X, or Mid 2X. Water textures don't dictate the reflective state.

tfuchsavsim.jpg

Share this post


Link to post
Share on other sites
Vandolf, that is why. Set it to Low 2X, or Mid 2X. Water textures don't dictate the reflective state.
The problem with this is per *******' post and my own experience, you will get flashing clouds with this mod unless water is set 2Xhigh. To avoid this when water is set lower, you need to rebuild the shaders with the NewMaterialUsage flag set to "true" in the SwarmCloud.fx file. This can cause individual popping of clouds though, so it's sort of a catch 22.

Thanks

Tom

My Youtube Videos!

http://www.youtube.com/user/tf51d

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    2%
    $540.00 of $25,000.00 Donate Now
×
×
  • Create New...