Jump to content

Archived

This topic is now archived and is closed to further replies.

terspok

Out of memory Windows 7 64-bit

Recommended Posts

All,I have a slightly odd issue with the MD11 in that I get out of memory errors when running on Windows 7 64-bit.I own all of the PMDG add-ons for FSX (J41\747) and have not experienced any of these issues with these planes or any other. I tend to get the error after 40 minutes or so of flying and when running in windowed mode I can see that memory for fsx is hitting 3gb which is not unusual and normally past that level with most add-ons.My system is a quad core Q9400 overclocked to 3.36GHZ, 4GB memory (Kingston HyperX).What I have seen of the plane is breathtaking and I thought the J41 was good, this is amazing!Thanks in advance,Chris Stanhope

Share this post


Link to post
Share on other sites

OOM errors in a 64-bit system is very unusual. You didn't mention the specific error or indication that is informing you of a memory problem. Is it crashing or what?Make sure you have the HIGHMEMFIX statement in your fsx.cfg file. See the pinned topic on graphics corruption in the general section of this forum.

Share this post


Link to post
Share on other sites

Thanks DownCC,A box appears saying that the system is out of memory and to try and reduce graphics or traffic settings. Have not followed the instructions as I don't get it on other add-ons so wanted to make sure there was not something else.I have done the highmemfix I believe but will double check.Thanks,Chris

Share this post


Link to post
Share on other sites

Try running some hardware diagnostics. You should get OOM errors no mater how much you have running. I routinely run FSX with several other apps running such as Outlook and Explorer.

Share this post


Link to post
Share on other sites

Hi,I think I have fixed it, I added the following to the fsx.cfg (I read about this on the concorde X site):STALE_BUFFER_THRESHOLD=2147483647If I switch between windowed and full screen the memory footprint reduces a fair amount.Currently doing a flight between LHR and Abu Dhabi so will see if it comes up again.Thanks for your help.Chris Stanhope

Share this post


Link to post
Share on other sites

I had this problem whit vista 32 bit... fsx as run out of virtual memory and need to close....I fix it using command prompt be careful using this fix make a bcdbackup..Anyways here it is, use at ur own risk.open command prompt whit admin right.type this at the prompt....bcdedit /export c:\bcdbackup <-------ur backup bcdedit /increasurva ""2000-3072 <dont remember the exact syntaxlook at this tread..http://forum.avsim.net/topic/280863-bcdedit-set-increaseuserva-2560-windows-7/

Share this post


Link to post
Share on other sites
Guest 413X3

I was getting OOM errors in win7 64bit, and found a few duplicate afcad files to be the cause.

Share this post


Link to post
Share on other sites

I know this reply is quite late, but I found that the source of this problem on my Win7 64bit machine was a faulty or missing SP2 for FSX.I uninstalled/reinstalled FSX with SP1 and 2, and never had the problem again. The reinstall also solved some other problems as a bonus.

Share this post


Link to post
Share on other sites

Glad I saw this post. Was about to give up on flying with CTDs always on FInal it seemd. Did what the post link said and now I am all good!!! been looking for this info for YEARS!!

Share this post


Link to post
Share on other sites

I also had this problem with Win7/64 but since I only do flights in adm mode and no problem anymore.John

Share this post


Link to post
Share on other sites
Hi,I think I have fixed it, I added the following to the fsx.cfg (I read about this on the concorde X site):STALE_BUFFER_THRESHOLD=2147483647If I switch between windowed and full screen the memory footprint reduces a fair amount.Currently doing a flight between LHR and Abu Dhabi so will see if it comes up again.Thanks for your help.Chris Stanhope
That's actually a completely bogus entry that can do more harm that good. It was from one of ******* Altuve's very early posts about the settings he discovered. We were told by Microsoft that setting it at anything other than default is not intended and that at high levels it can actually be a detriment. Some people didn't pay attention to further posts ******* made where it was clarified and I still see it showing up in some of these "apps" that put tweaks in for you.

Share this post


Link to post
Share on other sites

×
×
  • Create New...