Sign in to follow this  
Followers 0
KL Oo

FSX-MS
Why does my aircraft spin out of control in slew mode?

16 posts in this topic

Strange on this one...Whenever a activate slew mode (pressing Y) the aircraft spins around in cirlce at great speed. It just rotates 360 around in circcles until I press Y again. I can still control the aircraft whilst in slew mode by using the keys or yoke, but of course its all over the place because the direction the aircraft is facing changes a million times a second.I've only just finished building my new rig and the only thing different about this to previous builds is the Saitek yoke and rudder pedals. I thought I might ask here if anybody has any expirence with this before I start pulling them all out.Cheers,Kael

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You need to calibrate your control devices (joysticks/rudder pedals etc) for Slew mode as well (or remove their assignments if you don't use them), you will find if you increase the deadzone/null/centre of the axes it will stop this erratic behaviour when the devices are at rest/centred. I think you can also quickly disable all joystick type devices by pressing CTRL + K on the keyboard this should also stop the spinning in slew mode, then use the keyboard shortcuts instead to move around.

0

Share this post


Link to post
Share on other sites

Yes, I have had this issue ever since installing CH Pedals about 5 years ago!Doesn't matter how they're callibrated.The ONLY solution I ever found is the one posted above.It is possible to create a large 'dead zone' in the center, but that spoils the effectiveness of the pedals.I suspect Andy's solution is your best bet.

0

Share this post


Link to post
Share on other sites

Most likely the rudder axis is assigned to a joystick twist in slew mode - joystick assignments must be made separately for slew.

0

Share this post


Link to post
Share on other sites

Solved as per Andys solution above. I'm happy to use the keyboard for slewing! Thanks mate

0

Share this post


Link to post
Share on other sites
Your welcome, glad I could help.
Mine was tied to my mouse? Not sure how that happened but deleting the mouse link solved my problem.
0

Share this post


Link to post
Share on other sites

FSX makes odd and random key and axis assignments, you could go into the controllers section and see what axes are linked to slew movements.Case in Point, I have a USB trim wheel, it's just a wheel with one axis but FSX adds tons of buttons and non-existent axes to it which I have to manually remove.

0

Share this post


Link to post
Share on other sites

Every USB joystick type device gets a default set of assignments set to it by FSX whether or not it actually has any buttons or axes on it.

0

Share this post


Link to post
Share on other sites

If I use slew mode while parked at the gate, whenever I come out of slew mode, the a/c surges forward across the ground as if in flight at full speed. This occurs while using Ready For Pushback B747 and some other a/c as well. Any way to fix this. FS2004. Thanks.

0

Share this post


Link to post
Share on other sites

My setup does the same sometimes. CH pedals and Saitek X45 stick and throttle have to be calibrated separately. When initiating a turn from the gate my setup puts me into full-throttle. It adds a bit of drama to the day.

0

Share this post


Link to post
Share on other sites

I just use the keyboard, Been using it for 20 years. Never even tried pedals and a yoke. I think it has something to do with config file maybe. Anyone know why some a/c don't stay parked after coming out of slew mode?

0

Share this post


Link to post
Share on other sites

To stop the aircraft doing this nonsense - go to Settings->Controls->Buttons/Keys.. In the upper right corner is a box with two round silver buttons, marked 'Normal' and 'Slew' - the 'Normal' one having a black dot in it's middle..In the upper center there's a longish drop-down box with all of the controllers listed, the first one being Mouse Yoke.Leave Mouse Yoke visible. Left-Click on the 'Slew' button, such that the black dot is now in the Slew button center.Select the 'Event Category' (left side) - 'All Events'.Now go down the list of events and make sure that there is nothing in the 'Joystick' column:Repeat this for 'Mouse Look':Repeat this for each controller you have. On your main controller - you can select View (Pan) and assign it to the Hat switch.In terms of buttons - still in the Slew mode - the MS default are mostly the keypad numbers, and they're all fine. Once this is done - you should have no more idiot shooting off the runway, up, forward, etc.. If you wish to absolutely preserve your 'sanity' - you can also make the 'Standard.xml' file 'read-only' It is in your C:\Users\[your user_id]\AppData\Roaming\Microsoft\FSX\Controls\ folder.The problem with making it read-only is that anytime you wish to change a control - you need to make the file readable again before modifying it. The way around that is to assign all controls except Slew through FSUIPC.

0

Share this post


Link to post
Share on other sites

I have the saitek yoke with ch rudders. When I want to slew I simultaneously press Y and the brake button on the yoke. That stops the spinning. Then I can slew as I need to without spinning. When done, I hit the Y again, and all is set.sherm

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0