Archived

This topic is now archived and is closed to further replies.

Artem Crum

Bug reports

Recommended Posts

This topic is for bug reports only.Please read carefully the FAQ section before reporting a bug.Note:Please supply your reports with detailed information on your system config, hardware equipment connected and the LINDA Console output.Console could be opened from the LINDA menu on th Settings page or by pressing F1. If console output is empty for some reason then attach fsuipc4.log and linda2.log files to your report.Current bugz list:

  • Keypress recorder doesn't record Numpad keys correctly -- low priority

Share this post


Link to post
Share on other sites

Hi,I buy today the MCP Combo so it is my first attempt to use it.Following the Testing Guide i write in FSUIPC exactly the necessary lines.First I dont pay attention of the port number.In fact my used port is not COM3 but COM5.The LINDA console show me that i am not on the good port.I modify in LINDA Setup MCP Combo and in FSUIPC.INI and all is ok now.MCP is running well for the first knobs i turn (ALT, HDG, ...).Just a message appears when i click in the console windows (see picture 1).I thinck also that all is not completed in the console.It stop writting there : see picture 2MCP works well after the error but nothing more in the console.I continue the tests and settings ....Michel

Share this post


Link to post
Share on other sites

Hi again,I try to settup the PMDG MD11.Clicking the 3 blocks i read the "ident" of the different "mode"For the 3 block (RADIO) i have :- mode 1 ident EFIS- mode 2 ident LGHTlike for the block 1 (EFIS)Is that correct ?Michel

Share this post


Link to post
Share on other sites

Aha.. I'll check it tomorrow.'Efis' ident on the radios block is not correct, but you can change it yourself anytime.

Share this post


Link to post
Share on other sites

Another question ...When i click on a different button, it seems i must click 3 times before LINDA take it in account.On the same button the click is directly recognized.Exemple :MD11 settingClick on WPT : nothingClick on WPT : nothingClick on WPT : ok for WPTClick on APRT : WPT disapearsClick on APRT : WPT reapperasClick on ARPT : ok for ARPTIt is the same with the knob (turning it 3 times) and all the buttonsHave you an idea ?

Share this post


Link to post
Share on other sites

Hi,Some news about my problems this morning.1. Access violation : If i run LINDA first and FSX after then i have the error else notLesson : Start FSX first and LINDA after2. Need of multiple push on buttons to have a resultIf i run SerialFP first, close it, and then run LINDA then i have no problemIf i run FSX then LINDA then i have the problemLesson : Start SerialFP then start FSX, stop SerialFP then start LINDASo i have workarround for my problems.Have a good day then.Michel

Share this post


Link to post
Share on other sites
1. Access violation : If i run LINDA first and FSX after then i have the error else notLesson : Start FSX first and LINDA after
Confirmed. Fixed.
2. Need of multiple push on buttons to have a resultIf i run SerialFP first, close it, and then run LINDA then i have no problemIf i run FSX then LINDA then i have the problemLesson : Start SerialFP then start FSX, stop SerialFP then start LINDA
Trying to reproduce, but no luck.. Do you have the [VRinsight] section in your fsuipc.log?

Share this post


Link to post
Share on other sites

You need to remove the COM=* line in the FSUIPC4.ini that allows FSUIPC to find the MCP and assign buttons and dials directly, I saw the same problem until I removed it.You can leave any other COM entries for other VRi devices that are in the [VRinsight] section intact as they are not effected and can still be used in FSUIPC in the normal way.

Share this post


Link to post
Share on other sites

Guys (Andy, especially), check please, do you have any reaction delays on MCP Combo rotaries? Mine BARO and HDG rotaries are little laggy now. This could be detected by FAST rotating the knob. And then if you stop turning the knob, values inside FSX a still continue to change until some buffer is empty.

Share this post


Link to post
Share on other sites

BARO is a little slow and delayed, it continues to move for a short time after you have stopped turning the dial. HDG is not effected in the same way though, that is normal.The CRS dial is effected in the same way, i.e. slow to react and slow to stop. Interestingly if you use the CRS adjust function on the radio section of the MCP i.e. activate the DME display page then use the dial in the radio section this adjusts the CRS too and this one is not effected and works normally.I wonder if the CRS display information you are sending to the main display when using the CRS dial on the MCP is causing an issue as the main display isn't updated when using the CRS dial on the radio DME page.

Share this post


Link to post
Share on other sites

Yes, it seems to be conneted with display indication updates sent form Lua.Will try to fix it or reduce the delays at least..

Share this post


Link to post
Share on other sites

Have to revert back to setting com-port inside [VRinsight] of fsuipc4.ini.It works much stable than direct COM-port connection..That will be in the next update..

Share this post


Link to post
Share on other sites

I prefer using it that way anyway to be honest Artem, I find it much more convenient to be able to use a mixture of both LINDA and FSUIPC.

Share this post


Link to post
Share on other sites

I need to automize the fsuipc.ini editing then...It's simple in case of one VRI device in the system, but with the several devices it will not be so easy.

Share this post


Link to post
Share on other sites

Hi AndyI remove the line in FSUIPC.INI and all is ok nowThanks for the supportMichel

Share this post


Link to post
Share on other sites

Do we really need more FSUIPC integration such as mouse macros creation from within LINDA if FSUIPC still works with the MCP? I think you are creating unnecessary work for yourself that may not be used by that many people.

Hi AndyI remove the line in FSUIPC.INI and all is ok nowThanks for the supportMichel
Hi Michel,I'm glad I helped to get you going again, you will be required to put than line back again in the next release of LINDA as Artem is changing back again to the way it was before the Public Beta was released :)

Share this post


Link to post
Share on other sites
Do we really need more FSUIPC integration such as mouse macros creation from within LINDA if FSUIPC still works with the MCP? I think you are creating unnecessary work for yourself that may not be used by that many people.
I'm telling about automatically add the [VRinsight] section to fsuipc.ini.And as for the macros, there is a reason to make LINDA work with them (only execute them, not record). If you assign something on MCP button inside FSUIPC, then this action will be executed no matter what mode you are in in LINDA's notation.

Share this post


Link to post
Share on other sites

Back to PMDG MD11 setupA/T and F/D switch (picture 1) gives this (picture 2) at the console

Share this post


Link to post
Share on other sites

A/T is Ok nowF/D give errorAdded :With new file all (A/T and F/D)is okNo need to restart FSX or reload aircraft, just Reload Lua EngineThanks

Share this post


Link to post
Share on other sites

Delay of button presses?It looks like there is a queue of button presses somewhere. For instance, when I press LNAV, its only after a number of presses that it switches to NAV mode (FSX default). Sometimes it switches to other modes when pressing a button (for instance going to HDG mode when pressing LNAV). I cannot figure out any system in this.This is with RC2.

Share this post


Link to post
Share on other sites

That's why Artem is switching back to the system he used previous to the public beta release, he will release a new version in the near future I am sure.

Share this post


Link to post
Share on other sites