KiwiMatt

PMDG 737NGX Activation Problem

Recommended Posts

I am experiencing a real annoyance at the moment and it appears that the hot-fixes do NOT yet address the problems that certain users are experiencing while trying to activate the product. They anticipate that an updated hot-fix for this issue once their licensing partner has been able to identify/resolve the issue. ARE YOU KIDDING ME!!! - How come this is only affecting a small number of people???

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Copy your license number to clipboard. Open fsx and ngx. when asked for activation, be prepared for press ctrl+v and inmeadtly press ok. if back for activation another time close the window and fsx closes auto. reopen fsx and ngx will be activated.This method worked for me and more customers.Good luck

Share this post


Link to post
Share on other sites

Thanks Ryan... read that! Crock of Garbage! I have all their programs and this is the first I am having an issue with. I guess we'll just have to wait and see. let me know if you hear or see anything. I would appreciate it! Cheers

Share this post


Link to post
Share on other sites
Thanks Ryan... read that! Crock of Garbage! I have all their programs and this is the first I am having an issue with. I guess we'll just have to wait and see. let me know if you hear or see anything. I would appreciate it! Cheers
No problem !! If I spot anything about that problem I will PM you. Fred.

Share this post


Link to post
Share on other sites

HiI have the same problem now no activation window, waitinng 3 weeks now and counting.....ken

Share this post


Link to post
Share on other sites

same here

 

Official support for problems such as this needs to be through our official support system (linked in my signature). This is a user-to-user support forum, and users won't be able to help you with activation stuff.

  • Upvote 1

Share this post


Link to post
Share on other sites
I have been trying to resolve this 737 NG and 777 ER Activation - Failure to Initiate Problem with PMDG for more than a year. They illogically refuse to acknowlege that that their code ( for the 737 NG and 777 ER startup sequence ) causes the problem! The paragraphs below are the final part of a rather long dialog thread between them and me demonstrating their unwillingness to analyse and solve the problem: 

 

In my last reply the paragraph that begins "ARRRGGHHHHHHHH! So...... 2 hours later," was a quote from an Avsim forum problem posted in August in 2011. It was one sample of many posts meant to show that these symptoms have been recurring with many, many users for a significant period of time. I believe that this problem could be solved if looked at by someone who has written or has intimate knowledge of the internals of the PMDG 737NGX and 777ER startup sequence code. I respectfully suggest that you escalate this entire thread up the technical Guru chain at PMDG to seek a solution. I am a degreed Electrical Engineer and worked in the computer industry in many hardware and software disciplines for over 30 years and thus I know that [PMDG's assertion previously] "There are weird things that can go wrong with Windows that literally no one knows how to solve - this is probably one of them" is simply not a valid argument. This problem is caused by and is owned by the PMDG code, not the OS it runs under and you Folks know that code.

 

PMDG's Reply - [Digging their heels in further ... my comment] 

 

What I said is based on nearly 6 years of experience supporting this very product. I was intimately involved in its development and have supported it from release day in 2011. There's no one else higher up here for technical troubleshooting than me. I've seen it all over thousands upon thousands of tickets and I'm telling you that's what's happening here. 

I can virtually guarantee that a clean reinstall of Windows and FSX will solve the issue. Yes, there is a "reason" for it somewhere, but it is not in our code - how can it be if our code isn't even loading at all? That's what happens when this issue occurs, the gauge code never even starts executing - if it was, you'd see the activation window since that's among the very first things called in the initialization.

 

Ryan Maziarz

 

My Final Reply to PMDG -

 

Since I, and the Gentleman who’s post from August 2011 which I quoted as well as many others have both done many clean re-installs 737 NGX as well as FSX in his case FSX-SE in mine with no positive results, I’d take you up on your virtual guarantee. How can the problem not be with PMDG’s code when it must be that code which installs and then calls the gauges/switches/whatever routine?

 

I have spent untold hours trying to solve this problem and based upon my observations during this time I have concluded the following. What you have here is an intermittent, low probability of occurring software bug that seems to occur most often, but not exclusively, when a working (i.e Activated) PMDG aircraft installation is uninstalled, then re-installed as for an upgrade. The bug spans software versions/upgrades and products i.e. it shows up in both the 737 NGX and the 777 ER ( One really interesting symptom is that after the bug shows up on say a 737 NG installation, if the user then installs the 777 ER the bug also prevents the 777 from working ). Once the bug manifests itself on a given installation of FSX and/or FSX-SE no amount of external manipulation (re-installs etc.) will fix it. Thus one is led to conclude that some aspect of the uninstall/reinstall process leaves some artifact behind which causes the bug and that that artifact is impervious to normal external manipulations (i.e it is in some location external to but used by the PMDG installation such as a hidden file and/or registry entry ). Maybe you should take a look at the install/uninstall code and/or discuss this with FLEXnet? [FLEXnet is PMDG's activation system vendor] 

 

One would think that during PMDG’s development of these products you would have generated debugging tools which would allow you to observe various aspects of the software while running and to therefore be able to diagnose what’s going on with this problem quite easily. I guess I must be wrong about this or you would have solved this years ago. Incidentally, if you want a live test installation of a bug affected FSX-SE installation to examine, I would be happy to ship my hard drive to you gratis.

 

This will be my last reply to PMDG on this subject. I Believe it has become the classic example of “beating a dead horse.” I’m moving on to other things. I would, however, appreciate an acknowledgement that you received this note whether or not you would like me to ship you the disk drive.

 

Thank you for your effort working on this ticket and please have a Happy New Year. [ I have not received a reply as of this the date of this Post]

 

- Lee DuBois 

Share this post


Link to post
Share on other sites

Hi i have an issue with activating my PMDG 737NGX after updating my WIDOWS 10 computer

if with this issue how could help me that would be greatly appreciated :laugh:

CHEERS

  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, ONEWIZZ said:

Hi i have an issue with activating my PMDG 737NGX after updating my WIDOWS 10 computer

if with this issue how could help me that would be greatly appreciated :laugh:

CHEERS

Submit a trouble ticket to PMDG Product Support.  This is a user forum, and user to user assistance cannot resolve authentication problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now