Archived

This topic is now archived and is closed to further replies.

iainsmith

Full screen to Windowed mode

Recommended Posts

In FSX I can, usually, go from Windowed mode to full screen without difficulty. Coming back the other way though has become a problem. If I press "Esc" to bring up the "end flight" menu, the screen will go black for some considerable time and nothing else will happen. I then found that Ctrl + Alt + Del brings me the Windows menu to select Task Manager. Doing that clears the black screen and there I am with the End Flight menu in Windowed mode.Hitting Alt + Enter is hit and miss and often brings up the upper menu bar and then everything locks up. Then it's Ctrl + Alt + Del to get Task Manager.My rig is a Core2Quad Q9650, 3.0GHz (not o/clocked) with 4GB of DDR2 RAM, a Geforce GTX550Ti, 1GB using driver 280.26.I'd welcome any suggestions as although not a big deal, it is getting rather tiresome.ThanksIain Smith

Share this post


Link to post
Share on other sites
Guest firehawk44
In FSX I can, usually, go from Windowed mode to full screen without difficulty. Coming back the other way though has become a problem. If I press "Esc" to bring up the "end flight" menu, the screen will go black for some considerable time and nothing else will happen. I then found that Ctrl + Alt + Del brings me the Windows menu to select Task Manager. Doing that clears the black screen and there I am with the End Flight menu in Windowed mode.Hitting Alt + Enter is hit and miss and often brings up the upper menu bar and then everything locks up. Then it's Ctrl + Alt + Del to get Task Manager.My rig is a Core2Quad Q9650, 3.0GHz (not o/clocked) with 4GB of DDR2 RAM, a Geforce GTX550Ti, 1GB using driver 280.26.I'd welcome any suggestions as although not a big deal, it is getting rather tiresome.ThanksIain Smith
Sounds like a computer system problem to me. Alt+Enter should work both ways without any problem whatsoever. Do you have the FSX sliders moved all the way to the right? It sounds like there is some system memory strain being placed on your system whenever it's trying to bring FSX into focus. Alt-Enter should never bring up the upper menu bar. The Alt key will bring up the menu and remove the menu bar but not Alt-Enter. Have you defragged your harddrive? What is your OS? Is it 32 bit or 64 bit? Best regards,Jim

Share this post


Link to post
Share on other sites

Ive had similar issues when trying to go back into full screen mode after using alt-enter. Black screen that never loads the game, or black screen with the game running and sounds playing. I suspect its an enb issue or some kind of memory issue but I have no idea really. Its just really annoying, so I try to avoid using alt-enter unless I'm planning on quitting soon or don't care about lost progress.

Share this post


Link to post
Share on other sites

I think it's enb related too. This happened to me a lot until I changed "[GLOBAL] UseEffect=1" to "[GLOBAL] UseEffect=0". All this setting does is require you to turn on enb each time you switch between full/windowed mode which you can do with Shift+F12. It keeps enb from loading initially when you switch between full/windowed mode or whenever you go into one one of the menus, which I believe is the source of the lock-up. After the sim has made the transition, turning enb on doesn't seem to be a problem. It's a little irritating to have to press Shift+F12 all the time to start the enb effect, but not as irritating as having the display lock up halfway through a flight.Jim

Share this post


Link to post
Share on other sites
Sounds like a computer system problem to me. Alt+Enter should work both ways without any problem whatsoever. Do you have the FSX sliders moved all the way to the right? It sounds like there is some system memory strain being placed on your system whenever it's trying to bring FSX into focus. Alt-Enter should never bring up the upper menu bar. The Alt key will bring up the menu and remove the menu bar but not Alt-Enter. Have you defragged your harddrive? What is your OS? Is it 32 bit or 64 bit?Best regards,Jim
Jim, thanks for your response. I have recently done a re-install of Windows 7 64 bit, which was forced on me when a wireless adaptor I fiited in the PC would not work. I took the machine to my local specialist computer shop. Thet did a lot of tests and said there was something wrong with my Windows installation.The re-install certainly corrected the wireless problem and this full screen/windowed problem was there both before and after the re-install.I don't have all FSX sliders over to the right but I'll experiment by moving more over to the left and see if that makes a difference.Yes, after re-installing everything I have de-fragged the D drive on which FSX resides.Others have mentioned ENB but I don't have that.Iain Smith

Share this post


Link to post
Share on other sites

Jim Robinson, tgenius and billg1949, thanks for your responses. I don't have ENB so that cannot be the solution.If moving sliders to the left, as suggested by Jim firehawk44 doesn't have any effect I'll get my son-in-law on the case as he is also computer savvy!Iain Smith

Share this post


Link to post
Share on other sites
Guest firehawk44
Jim, thanks for your response. I have recently done a re-install of Windows 7 64 bit, which was forced on me when a wireless adaptor I fiited in the PC would not work. I took the machine to my local specialist computer shop. Thet did a lot of tests and said there was something wrong with my Windows installation.The re-install certainly corrected the wireless problem and this full screen/windowed problem was there both before and after the re-install.I don't have all FSX sliders over to the right but I'll experiment by moving more over to the left and see if that makes a difference.Yes, after re-installing everything I have de-fragged the D drive on which FSX resides.Others have mentioned ENB but I don't have that.Iain Smith
Sorry to hear you are still having problems. Instead of using Alt-Enter to switch windows, have you tried going into the FSX menu and clicking on the Views tab and unchecking Full Windows? That will take you out of full windows, then, when you are in windowed mode, you can do the same thing and enable Full Windows. It's a little hassle from the simply method of using Alt-Enter but some people have had to use this method for some odd reason. I did a Google search for 'alt enter not working in FSX' and see this has been a problem for some with no known solution (or none that I could find). Some fixed it by reinstalling their video card drivers but that didn't work for all. I still think you have a memory issue of some sort.Best regards,Jim

Share this post


Link to post
Share on other sites
Sorry to hear you are still having problems. Instead of using Alt-Enter to switch windows, have you tried going into the FSX menu and clicking on the Views tab and unchecking Full Windows? That will take you out of full windows, then, when you are in windowed mode, you can do the same thing and enable Full Windows. It's a little hassle from the simply method of using Alt-Enter but some people have had to use this method for some odd reason. I did a Google search for 'alt enter not working in FSX' and see this has been a problem for some with no known solution (or none that I could find). Some fixed it by reinstalling their video card drivers but that didn't work for all. I still think you have a memory issue of some sort.Best regards,Jim
Well Jim memory diagnostic testing has not revealed anything amiss. However, I have made a huge improvement to the problem. I've d/loaded and installed the earliest WHQL certified Nvidia driver I could find on their site for my video card, which is 275.33 and I installed this instead of the 280.26 that I had. The reason for this is because I've read here on the forums from several users who say that later Nvidia drivers are becoming less and less suitable for FSX.While this had not completely cured the issue it has made a huge improvement, particularly if I use Ctrl + Alt + Enter. I can 100% guarantee that I can go from Windowed mode to full screen. Coming the other way is still less certain but is much better than before with something like and 85 to 90% success rate.I will keep searching for the complete solution but in the meantime I can have a far less frustrating time with FSX.Kind regardsIain

Share this post


Link to post
Share on other sites

To avoid problems switching between windowed and full screen I always use the Alt key to bring up the menu bar and then select full screen or windowed mode from there. Using key strokes to do it has given me pronlems in the pasy but using the menu option works perfect for me.

Share this post


Link to post
Share on other sites
Guest firehawk44
I've d/loaded and installed the earliest WHQL certified Nvidia driver I could find on their site for my video card, which is 275.33 and I installed this instead of the 280.26 that I had. The reason for this is because I've read here on the forums from several users who say that later Nvidia drivers are becoming less and less suitable for FSX.Kind regardsIain
Hi Iain,I always keep the latest and greatest driver for my video card installed and have never had a problem moving in and out of windowed mode. If it were the fault of the drivers, I think we would be seeing more reports of this problem here on AVSIM. Although newer driver versions do not fix anything specifically for FSX, the drivers contain bug fixes and increase performance in games. Even benchmark software, like 3D Mark 11 shows performance increases everytime a driver is updated. So I respectfully disagree with the premise newer drivers are no longer good for FSX. It is possible that changing driver settings from those that Nvidia technicians developed for FSX may cause problems by placing too much emphasis on the video driver. FSX is not dependent on the GPU as in previous versions of Flight Simulator. Default settings should be sufficient. FSX is more dependent on the power of the CPU and system memory. I would continue to look for ways to reduce the demand for CPU power and memory usage. Best regards,Jim

Share this post


Link to post
Share on other sites