Jump to content
Sign in to follow this  
Eziocin

g3d.dll......help ..!

Recommended Posts

Are we looking to the dead end here, since we got crashing because of FSX models!?

Share this post


Link to post
Share on other sites

Tried the KORS > KPDX flight again, here's the log:********* FSUIPC4, Version 4.749b by Pete Dowson *********User Name=User Addr=FSUIPC4 Key is providedWIDEFS7 not user registered, or expiredRunning inside FSX on Windows 7Module base=61000000 31 System time = 29/11/2011 04:36:30 31 FLT path = "C:UsersJimDocumentsFlight Simulator X Files" 390 Trying to connect to SimConnect Acc/SP2 Oct07 ... 390 FS path = "C:Microsoft GamesMicrosoft Flight Simulator X" 577 LogOptions=00000000 00000001 577 Wind smoothing fix is fully installed 577 G3D.DLL fix attempt installed ok 577 SimConnect_Open succeeded: waiting to check version okay 577 Trying to use SimConnect Acc/SP2 Oct07 1778 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0) 1778 Initialising SimConnect data requests now 1778 FSUIPC Menu entry added 1809 c:usersjimdocumentsflight simulator x filesDefault Skyhawk at 65S.FLT 1809 C:Microsoft GamesMicrosoft Flight Simulator XSimObjectsAirplanesC172Cessna172SP.AIR 79701 C:Microsoft GamesMicrosoft Flight Simulator XSimObjectsAirplanesCarenado Skymaster 337C337.AIR 135206 System time = 29/11/2011 04:38:45, Simulator time = 14:21:59 (22:21Z) 135206 Aircraft="C337 Skymaster GREY" 135549 Starting everything now ... 139012 Advanced Weather Interface Enabled 187981 Weather Mode now = Custom 195781 ASE with WX requester detected 233299 Weather Mode now = Theme 233580 Weather Mode now = Custom 2793790 **** G3D Bad Ptr: 0x101F7213 2793790 Last file="C:Microsoft GamesMicrosoft Flight Simulator XSimObjectsAirplanesAirbus_A321modelAirbus_A321" So does "Last file" necessarily mean it was the file that caused the crash though?Thanks,Jim

Share this post


Link to post
Share on other sites

well i just tryeid lowi and got this in the log 635657 **** G3D Bad Ptr: 0x00B7D745 635657 Last file="C:FSX2SimObjectsAirplanesC172modelCessna172SP"


Best regards Lars N.

Share this post


Link to post
Share on other sites

Sorry a bit of topic, but I've noticed that everyone has 'Wind smoothing fix is fully installed'but in my log it says 'Wind smoothing fix is not installed'How do I fix this?Thanks


Clive Joy


beta.gif

Posted Image

Share this post


Link to post
Share on other sites
Are we looking to the dead end here, since we got crashing because of FSX models!?
No, I'm pretty sure it is corruption in memory. Maybe it's down to a bad file somewhere, and maybe it is more likely with high memory use (because there are a lot more places to trample on), but i really can't believe it's any specific bad MDL files. It just happens that they seem to be the one's trampled on and the functions in G3D.DLL without adequate checks.Pete
So does "Last file" necessarily mean it was the file that caused the crash though?
No, it's the file whose data appears to have been corrupted in memory. I've no way of working out WHAT is corrupting data. I can only look at either protecting it (difficult) or allowing FS to continue regardless.Pete
Sorry a bit of topic, but I've noticed that everyone has 'Wind smoothing fix is fully installed'but in my log it says 'Wind smoothing fix is not installed'How do I fix this?
the message is actually incorrect. It was a result of me re-ordering the loading sequence in FSUIPC a few versions back. The place where that message occurs ended up being BEFORE I applied the wind smoothing fix. I corrected this error in version 4.749.The testers in this thread are using > 4.749.RegardsPete

Win10: 21H1 19043.1052
CPU: 9900KS at 5.5GHz
Memory: 32Gb at 3900 MHz.
GPU:  RTX 24Gb Titan
2 x 2160p projectors at 25Hz onto 200 FOV curved screen

Share this post


Link to post
Share on other sites

Okay, try 4.749c. This is my last today. I'm running out of ideas for now. If it still doesn't help I'm sorry. If I do think of any further avenues to explore I'll do so, but i won't even think about it for a day or two. I need to catch up on other things and maybe even try a flight. ;-)http://fsuipc.simflight.com/beta/FSUIPC4749c.zipPlease do continue o let me know what happens, but don't necessarily expect any replies today.RegardsPete


Win10: 21H1 19043.1052
CPU: 9900KS at 5.5GHz
Memory: 32Gb at 3900 MHz.
GPU:  RTX 24Gb Titan
2 x 2160p projectors at 25Hz onto 200 FOV curved screen

Share this post


Link to post
Share on other sites

Tell me I'm dreaming... my EBBR flight went through...TWICE... gotta do couple of more test to confirm I'm NOT dreaming!!!!!!!!!!!!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites

Pete,We are very greatfull for all the help.If this approach does not work would it be possible to try a different appraoch ?As I have understood adding the MissingLibraryAlert=1 tweak in the fsx.cfg file will make a pop up appear and after clicking OK FSX continues.( FSX ignores the issue and continues ).Would it be possible to make this window very small, lets say 3x3 pixels and have FSUIPC "click" OK automatically ?Just my 2cents.


Gerard

12900K (8 cores @ 5.1-5.5 GHz / 8 cores @ 3.9 GHz ) - Asus ROG Strix Gaming D4 - GSkill Ripjaws 2x 16 Gb 4266 mhz @ 4000 mhz / cas 16- Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 2800/1800 2TB - 1x SSD M2 2800/1800 1Tb - Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 2x 8 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 2800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites

I just pushed the limit up to 3,83GB on the VAS, and I saw no g3.dll error, but the sim froze. Which is I guess a step forward! But with a normal usage, say about 3,4GB, all is well!!!!!EDIT: Successful pass with VAS 3.65. Anything way over, FSX freezes. I think this is a big step forward, as EBBR usually crashes with VAS 2.9GB. The difference was LOD_RAD 10.5 and 11.5. Also 11.5 passed if I don't pan around and make VAS jump to about 3.8.Continuing tests on EDDF and LOWI...

Share this post


Link to post
Share on other sites

I DID NOT GET A CTD ! !I have returned to my former high settings, PMDG at HD textures and even then FSX is running perfectly.Will try it again and also a flight from Schiphol to Brussels.Pete, It looks like you are really on to something !


Gerard

12900K (8 cores @ 5.1-5.5 GHz / 8 cores @ 3.9 GHz ) - Asus ROG Strix Gaming D4 - GSkill Ripjaws 2x 16 Gb 4266 mhz @ 4000 mhz / cas 16- Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 2800/1800 2TB - 1x SSD M2 2800/1800 1Tb - Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 2x 8 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 2800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites

I'm......I'm......I'm........Worried.gifWorried.gifWorried.gifWorried.gifWorried.gif .........HAPPY!!!!!!!! dance.gifdance.gifdance.gifdance.gifPete dude, can I...like...marry you brain...or at least your knowledge!? LMAO.gifLMAO.gifEDDF pass. LOWI pass. All with very very high VAS usage.For the serious part of my message: what did you do here? And, what is it doing to the sim?The most hardcore test is coming though: LOD 7.5, NGX flight from EGKK to LOWI, if it doesn't crash at RTT, we/you got the biatch!

Share this post


Link to post
Share on other sites
As I have understood adding the MissingLibraryAlert=1 tweak in the fsx.cfg file will make a pop up appear and after clicking OK FSX continues.( FSX ignores the issue and continues ).
I used that out of curiosity, but i never got to fly. the same object GUIDs re-occurred hundreds of times, and it happens all the time. maybe all my scenery is in a mess, but there's noway i'm going to put up with the jerks and hesitations having such a thing occur will cause.If this reduces or removes the G3D corruption errors it wil only because the reporting and hesitation allowmory garbage colector to tidy up the memory allocations. If you have a fast way, fast enough to be tolerable, it will defeat that.The same thing could probably be achieved by having FSUIPC or something calling the garbage collector every few milliseconds, but unless you have extremely fast memory and a processor running at 10 GHz i really thing this is not going to make for a flyable simulation.
Would it be possible to make this window very small, lets say 3x3 pixels and have FSUIPC "click" OK automatically ?
You wouldn't do it that way in any case, you'd just patch the call to the message box display and stop it happening.RegardsPete
The difference was LOD_RAD 10.5 and 11.5.
Phew. I tried 6.5 once and the frame rates were far too low for my liking. 5.5 is aobut the max I ever use, but the default 4.5 is my usual setting.I strive to achieve at least 20 fps with 80% UT2 plus 50% MTX at UK200o's Heathrow in complex ASE weather. Yes, elsewhere I can get 60-150 fps, but high detailed well populated airports are the most important to me. Airliner flying is really all airports, takeoffs and landings. the bit in between is mostly clouds and talking to ATC! ;-)Pete

Win10: 21H1 19043.1052
CPU: 9900KS at 5.5GHz
Memory: 32Gb at 3900 MHz.
GPU:  RTX 24Gb Titan
2 x 2160p projectors at 25Hz onto 200 FOV curved screen

Share this post


Link to post
Share on other sites
Phew. I tried 6.5 once and the frame rates were far too low for my liking. 5.5 is aobut the max I ever use, but the default 4.5 is my usual setting.I strive to achieve at least 20 fps with 80% UT2 plus 50% MTX at UK200o's Heathrow in complex ASE weather. Yes, elsewhere I can get 60-150 fps, but high detailed well populated airports are the most important to me. Airliner flying is really all airports, takeoffs and landings. the bit in between is mostly clouds and talking to ATC! ;-)Pete
Nono, don't get me wrong here. I use LOD_RADIUS 5.5-7.5 for my everyday use. This is due to NGX, high textures and all - if I would use anything higher, like some that use 9.5, I would be getting OOMs all over the place.The fact is though that I invoke g3d.dlls by using insanely high LOD_RADIUS thus having ability to "simulate" a long flight with NGX/high textures. I am just trying to push the VAS up, which in the end resulted a situations which are completely replicable for testing.For my rig, it's also a kill if I run 7.5, lowering to 5.5, I get way smoother flights especially with NGX. If it runs stable with the default CRJ and LOD 11.5, it's gonna run stable with NGX and LOD 5.5. Which yields about the same VAS usage inflight.

Share this post


Link to post
Share on other sites
The fact is though that I invoke g3d.dlls by using insanely high LOD_RADIUS thus having ability to "simulate" a long flight with NGX/high textures
So do you think I could force these errors on a default FSX install if I used even more insanely high LOD_RADIUS values? It would be interesting to try anfd make one happen on my developemt PC where i can see what really happens. If I can get the eventual hang you got maybe I could sort that then.To determine what a program is doing when it hangs you really do need to use a debugger.RegardsPete

Win10: 21H1 19043.1052
CPU: 9900KS at 5.5GHz
Memory: 32Gb at 3900 MHz.
GPU:  RTX 24Gb Titan
2 x 2160p projectors at 25Hz onto 200 FOV curved screen

Share this post


Link to post
Share on other sites

Just tried my ERROR flight for the last time with even AI Traffic ( My Traffic 5,4 _ Mt Live ) at 60%, lod-radius set at 8 and many sliders higher than I use to do and the sim is smooth and no issues.Bear in mind that I am using 3x 26"lcd screens as one wide view. So taxing the system to the max. I will do Schiphol - Zaventum later and will report back , but I feel that my issues are over. Pete, you may get the Nobel Price for Best Simulation Utility + Best support ! im Not Worthy.gif


Gerard

12900K (8 cores @ 5.1-5.5 GHz / 8 cores @ 3.9 GHz ) - Asus ROG Strix Gaming D4 - GSkill Ripjaws 2x 16 Gb 4266 mhz @ 4000 mhz / cas 16- Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 2800/1800 2TB - 1x SSD M2 2800/1800 1Tb - Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 2x 8 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 2800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...