Jump to content
Sign in to follow this  
styckx

Pitot heat effectiveness

Recommended Posts

Can someone verify this for me? It's quite possible I'm doing something wrong but I've deiced these things before a million times on other aircraft.

 

I wanted to test how prone to icing this aircraft was so I set the weather to Winter Wonderland and set out of KHQM and climbed out w/ the AP set for 15k.. Only about 5 minutes into the climb and around 12 degree Fahrenheit I lost my airspeed indicator.. Threw on pitot heat continued to climb, never regained my airspeed indicator.. Leveled out, descended down to 500ft where the temp was now 25 degrees Fahrenheit.. Pitot heat still running and I still have a non-functioning airspeed indicator. I managed to land by climing up and by tuning into a VOR and reading speeds off that and guessing the rest of the way when I was below its range.

 

Edit: Just tried two more times.. 21 and 19 degrees F is when the pitot tubes iced up.. Same results.. Pitot heat did absolutely nothing..


ASUS ROG STRIX Z390-E GAMING / i9-9900k @ 4.7 all cores w/ NOCTUA NH-D15S / 2080ti / 32GB G.Skill 3200 RIPJAWS / 1TB Evo SSD / 500GB Evo SSD /  2x 3TB HDD / CORSAIR CRYSTAL 570X / IPSG 850W 80+ PLATINUM 

Share this post


Link to post
Share on other sites

Thanks, that's what I thought.. Sent to Carenado..


ASUS ROG STRIX Z390-E GAMING / i9-9900k @ 4.7 all cores w/ NOCTUA NH-D15S / 2080ti / 32GB G.Skill 3200 RIPJAWS / 1TB Evo SSD / 500GB Evo SSD /  2x 3TB HDD / CORSAIR CRYSTAL 570X / IPSG 850W 80+ PLATINUM 

Share this post


Link to post
Share on other sites

i can confirm the loss of Airspeed indication and i always put on Pitot heat,

Share this post


Link to post
Share on other sites

Confirmed here as well, although mine seemed to be sporadic. On a flight from KAVP to KPHL with today's weather, I was pretty much in the icing layer shortly after takeoff (about 2000'). At about 4000' while climbing to 10000' I loss the airspeed. At 6000' feet it came alive again for about 2 minutes and then fell off line again. All appropriate DE-icing systems were on.

 

The airspeed remained off line for the duration of the flight.


KROSWYND    a.k.a KILO_WHISKEY
Majestic Software Development/Support
Banner_MJC8.png

i7 8700k, MSI GAMING MotherBoard, 32Gigs RAM, EVGA 1080Ti, 750 Corsair PSW, 1x500Gig WD Blue SSD, 1x1TB Samsung EVO 860, 1x1TB Crucial SSD, 1x2TB Samsung QVO SSD, 1x6TB SeaGate HHD:  Win OS 10 v2004
Simulators:  Prepar3D v4.5x & v5.1x/ X-Plane 11.50/ MSFS 2020:  YouTube Videos

Share this post


Link to post
Share on other sites

I suspect you still have to hit the "H" key to get the default pitot heat to work?

 

Martin

Share this post


Link to post
Share on other sites

Now THIS is really annoying. Makes it impossible to fly anywhere with real weather. Climb through a cloud and you have no ASI for the remainder of the flight.

 

I REALLY wanna like this plane. But SO many little (and huge, like this) annoyances!

 

 

Eddie


Eddie
KORF

Share this post


Link to post
Share on other sites

Folk, all though this snag is present, it does not stop you from enjoying this aircraft. These are other sources of acquiring the speed information, although not quite practical. Only major snag that one may encounter is flying on Vatsim where speed restrictions may be issued by ATC, and or flying by the numbers for the approach. I am sure this too will be addressed soon.


KROSWYND    a.k.a KILO_WHISKEY
Majestic Software Development/Support
Banner_MJC8.png

i7 8700k, MSI GAMING MotherBoard, 32Gigs RAM, EVGA 1080Ti, 750 Corsair PSW, 1x500Gig WD Blue SSD, 1x1TB Samsung EVO 860, 1x1TB Crucial SSD, 1x2TB Samsung QVO SSD, 1x6TB SeaGate HHD:  Win OS 10 v2004
Simulators:  Prepar3D v4.5x & v5.1x/ X-Plane 11.50/ MSFS 2020:  YouTube Videos

Share this post


Link to post
Share on other sites

Until the bug fix, try "Shift+H" for pitot heat which is the default in Acceleration. I believe "H" is engine anti-ice/carb heat by default.

 

Brian W

Share this post


Link to post
Share on other sites

Shift+H does seem to work for me. Hard to believe something like that has been missed by the team before release...


Intel i7 950 O/C @ 3.60

Gigabyte X58A-UDR3 Rev 2.0

ATI HD6970

6gig ram

Share this post


Link to post
Share on other sites

Now THIS is really annoying. Makes it impossible to fly anywhere with real weather. Climb through a cloud and you have no ASI for the remainder of the flight.

 

I REALLY wanna like this plane. But SO many little (and huge, like this) annoyances!

 

Eddie

 

 

I have been trying to keep positive about this purchase but I have to agree. I love the plane, but it's more about the plane itself and less about this product. Too many issues for the price.

Share this post


Link to post
Share on other sites

This is something most ALL Carenado planes have. Doesn´t matter you use C310, B58, many die on some environment, you dive, come back, die again. It is hard to believe after years of producing this still lives. Don´t get me wrong, i own many of Carenados planes, but this bug is an annoying artefact.

Share this post


Link to post
Share on other sites

I had the same problem, and so I went into the aircraft file and noticed in the electrical section it said 0 as the first number in the pitot heat. So I changed it to 1 and now it works just fine. A interim fix until a patch comes out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...