Archived

This topic is now archived and is closed to further replies.

Sen5ei

You are subscribed to this thread Cannot log in to MS Flight after reinstalling Windows

Recommended Posts

Hello guys,

Since the Flight is out, I am playing it almost every day for several hours. Three days ago I had problems with some malware and viruses and I had to reinstall Windows. Formatted my hard drive but I saved the things that I need, and one of that things is my MS Flight profile folder, cause I didn't want to loose my in-game progress.

After a fresh Windows installation, I downloaded MS Marketplace and GFW Live application, and installed MS Flight with add-ons, Hawaii Adventure pack and Maule plane. I started the game, tried to log in with my one and only MS Live account, and one and only gaming profile, and after a window "Downloading game profile" (or something like that), the other window pop-upped with the message "The product you provided has already been registered to another LIVE profile". Total nonsense! And that is impossible because it is my one and only account.

Then another window pop-upped and I have to enter my product key, but the key is already there in 5x5 blanks, and it is my key, the same key that is in my MS marketplace, under MS Flight.

 

The error is ERROR 0x80151801.

 

My real life friend reinstalled his system (his nick is Eevun on this forum) only a couple days before me, and reinstalled the game, but he didn't have these problems. And I tried to install the game on my sister's computer, and to log-in from there, but the same error!

I'm a bit frustrated, got to admit. I have around 200 flying hours, and this is the only "game" that I really like, and that relaxes me.

 

Need help guys.

Thank you in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Sen5ei (Ogn...?)

 

When you reinstalled Flight, did you copy paste your whole saved "MS Flight profile folder" on top opf the fresh install?

 

That could cause problems, It happened to me on one of my reinstalls, I think it has to do with security settings + hashed files + your gamertag + windows user ID + GUID's, etc.

 

I don't know of a short way to try to fix this, but if all fails try this: Uninstall Flight (and remove all its folders) then reinstall and play the first 2 mandatory introductory missions, then copy paste only your saved "career.xyz" files to your new PLayers->NumbersFolder->Career. (20 files total, the other files don't matter).

 

Hope this helps a bit.

Share this post


Link to post
Share on other sites

All these days I was serching for the solution, and after countless unsuccessful contacts with MS support, yesterday I finally found out what was the problem. And I hope that this would help anybody with similar problems. Somewhere on the internet I read that logs for WIN errors of this type are stored here:

C:\Users\%userprofile%\AppData\Local\Microsoft\Windows\WER\ReportQueue

 

After trying to connect to Games for Windows LIVE in the MS Flight, and after the "The product you provided has already been registered to another LIVE profile" and "ERROR 0x80151801" messages pop-upped, I immediately quited Flight and went to "C:\Users\%userprofile%\AppData\Local\Microsoft\Win dows\WER\ReportQueue" and checked the last report written there. The name of the folder was "NonCritical_vcredist_x86.exe_(some numbers and letters)". I opened the file "Report.wer" stored in this folder, and saw that the problem is with "Microsoft Visual C++ 2010 x86 Redistributable Setup".

 

After uninstalling "Microsoft Visual C++ 2010 x86 Redistributable Setup ver. 10.0.40219", and installing "Microsoft Visual C++ 2010 x86 Redistributable Setup ver. 10.0.30319", I managed to log-in to MS Flight without problems! No errors, no nothing. MS LIVE downloaded my profile and suddenly I was in game.

 

This is really weird cause, according to Microsoft, error " ERROR 0x80151801 " is related to connection or network issues (?^$#%^$#), so that can be a perfect mislead for solving the problem.

 

See you ingame guys.

Have a nice flight ;]

Share this post


Link to post
Share on other sites