Jump to content

Archived

This topic is now archived and is closed to further replies.

thegreek

Strange Problem with ACC and SP2

Recommended Posts

Hi there,

thats my first topic and i hope you guy's can halp me like you've done with others.

 

I have a very strange problem with my FSX. All started 3 weeks ago when i started the FSX to do a usual flight. After programming the FMC and started to taxi to the rwy, i noticed microstutters every 10-15 sec in hole of the flight! I restarte my PC and loeded again a flight, but the probleme were still there. I searched in several forum for solution by tweaking the fsx.cfg(Bojote) or even to tweak the PC but nothing changed. After that i was sure that not fsx causes the problem but some other software or even hardware settings, because the fsx befor that 3 weeks worked fine without stutters at 35 fps and now every 10-15 sec from 35 it goes to 5-8 for one second. Befor three weeks ive installed tuneup and i thought that this is the problem,bot no,even not tha antivirus(avast). so i decided to reinstall Windows.

After reinstalling windows, fsx and then acc nothing changed, the problem was still there. After second complete reinstallation of window i had no positive results. I was so desperate, that i decided to do a 3rd reinstall of windows. so i deinstalled first the acceleration, after that i wanted to deinstall also FSX, but there i stoped. I thought, the only thing that i've not tested was to run fsx without acc. So i loaded a flight and i was suprised! NO STUTTERS!!! but to do this right, i reinstalled fsx(after deinstall of corse), started a flight, everything was fine. Then i instaled acc, loaded a flight, problem again. Deinstalled acc, started fsx and loaded a flight, perfect. So i thought, the alternative to acc is the sp1 and sp2. So i installted sp1 and then sp2. I loaded a flight and the microstutters were there again!

Thats my problem now, how can I get the acc or sp's work perfectly? Thank god that i know now whats the problem is, but how can i solve it??

 

My system:

 

Toshiba Satelite L750

Intel I5 at 2,4Ghz with turbo untill 3,1 Ghz

6GB of Ram

Nvidia Geforce GT 525M

Windows 7 Prof x64Bit

 

Hope You can help me!!!

 

Sorry for my english!

 

Thanks!!!

Share this post


Link to post
Share on other sites
Guest firehawk44

FSX does not work as well on a laptop as a desktop computer. Stutters are common especially in commercial scenery addons and commercial aircraft addons and high settings. Turn your settings up too high and you'll get an occasional stutter especially when AI is set high and/or scenery sliders are set too high. Video card display settings will cause stuttering if AF or AA is set too high for your system. When you started up FSX for the first time, you had default settings Microsoft decided was best for your computer system. You should get stuttering at those settings and your fps should be very high. Start moving your settings up, both in FSX and display drivers, and you'll start seeing anamolies. There are two FSX guides you should check out when you first get FSX and that's the Setting Up FSX and Tuning it Guide - http://www.simforums...topic29041.html and an excellent guide prepared by Srdan Word Not Allowed here at AVSIM. His guide is pinned at the top of the Hardware forum. This is the best advice I can provide to potentially fix your problem(s). Hope this helps.

 

Best regards,

Jim

 

Amend my sentence above to the following: (shouldn't instead of should). Apologize for not proofing.

'You shouldn't get stuttering at those settings and your fps should be very high. Start moving your settings up, both in FSX and display drivers, and you'll start seeing anamolies.'

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Thanks for your quick reply!

i've tried the link you suggested me before but without succes. I know that fsx dont run on laptopt like it does on desktop, i have now my laptop with me by half year erasmus studing! at home i have a desktop! but I'm confused, before the stutters started, i've flown 12 flights for my VA without problems!And why it happens only when ACC or SP's are installed? Without its perfect, but because i have some addons i need the acc or sp!

Share this post


Link to post
Share on other sites
Guest firehawk44

Mos

And why it happens only when ACC or SP's are installed?

 

I've never seen that so something must be seriously wrong with your computer. Did you defrag your HDD after installing FSX/Acceleration. When installed, these programs throw files all over the HDD in unexplainable locations. In regards to SP's and Acceleration, you can only install Acceleration. You cannot install SP1/SP2 then Acceleration or you will have problems. Acceleration includes both SP1 and SP2. You cannot install Acceleration after installing SP1/SP2 without uninstalling SP2 first so don't know how you are doing your testing. Do you uninstall Acceleration then run SP1 and SP2, test, then uninstall SP2 and install Acceleration, then test? Make sure you defrag after every uninstall/reinstall. FSX/Acceleration are both very old software and programmings might need some fine tuning in today's environment but we won't ever see that so we have to live with what we have. Make sure you have Microsoft.net versions 1 thru 4 installed. Microsoft.net framework is used by the developer to manage and run FSX/Acceleration, to include managing the memory for the program. Versions are not backward compatible. They are usually included when you install FSX or Acceleration if the software does not see the version installed so you probably have them. Just make sure. You also need Microsoft Visual (MSV) C++ Redistributable 2005 with SP1 installed. Acceleration was published too soon to include SP1 so you need to make sure you have that installed. If you have addons, you should have versions 2008 and 2010 installed too. MSV's are not backward compatible either so you need them all. Make sure you run Windows Update as this software is updated frequently.

 

With FSX settings set to default, are you still experiencing stutters. You can test this by renaming your fsx.cfg to fsx.orig then restart FSX and fsx will rebuild the config. Now, without modifying the scenery or AI settings or the AA/AF settings, try running FSX and see if the stuttering continues. If that doesn't fix things, then you can go and rename the fsx.orig back to fsx.cfg and you're back where you started. Unfortunately there is no magic bullet that will make FSX run flawlessly on every system. You just have to tweak until you find the right settings for YOUR computer.

 

Best regards,

Jim

 

For your system I would set my display driver AA/AF settings to Managed by Application and turn both on in FSX.

Share this post


Link to post
Share on other sites

thanks for your help!! i had acc installed, then deinstalled and the SP's installed, not at the same time, its imposible.

I will try this with the Microsoft Visual C++ and tell you!

Share this post


Link to post
Share on other sites

unfortunatly nothing changed. now my stutters are every 3 seconds!!!! i dont know wat to do anymore. When i bought my laptot 2 months ago, everything was fine, then suddenly it started to make trubble!

Share this post


Link to post
Share on other sites
Guest firehawk44

Sorry you are still having problems. It sounds like maybe a video card driver or the video card itself is causing issues. Do you use the nvidiaInspector to tweak your settings? Check in your system Event Viewer and see if there are any strange messages/reports. If you're not familiar with the Event Viewer click on the Start button and select Help and Support. Once open, type in the search bar Event Viewer and you'll have a direct link to the viewer plus information on how it works and what to look for. You can also run Prime95 or the IntelBurnTest (google for the free apps) and check for system stability. FSX/Acceleration should run very smooth with FSX setting set at default. Things change when you try to tweak the FSX.cfg or move sliders up or have high display driver settings. Sorry. About the only advice I have left.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Sometimes, when you haven't done anything to cause it, Windows Update can start problems. Especially if it overwrites a souund or video driver. About 3 weeks ago (2nd Tue. of each month) the last updates came out. Since you have re-installed Windows, you have erased any clue in the change log. I suggest: a. Install all Windows Updates, b. Download and save the latest video driver from the Nvidia site, c. In Control Panel un-install the video driver, d. Install the driver you saved, e. Go here http://forum.avsim.n...-guide-for-fsx/ and setup your computer. Set AF=16x, AA=2x, "Allow" to "Clamp". If okay, try the suggested AA setting.

 

Windows 7 is nothing like Win95 and Win98 or even Xp. Re-install should be a drastic last step. Turn UAC off if FSX is installed in Program Files directory.

 

Dave

Share this post


Link to post
Share on other sites

thank you for your help but nothing fixed my problem! In the event viewer are several massengers, what do you mean with strange? i also tried to install an older gpu driver (03.2012) now i've installed the latest beta version. all windows updates are on date! the settings in the nvidia inspector didn't helped.

Im very angry right now, i dont now what to do?? I fixed every problem i had with the PC or FSX, but this stupid thing is an undestroyable enemy!!!

Share this post


Link to post
Share on other sites
Guest firehawk44

what do you mean with strange

 

Maybe a report that the system took an extraordinary amount of time to startup and shutdown (as an example), errors with the RED circle with an explanation point inside. Apologize for using the word 'strange'. Maybe 'unexplained errors' would have been better. Dave has some great suggestions too. I hope you tried those suggestions. As I stated above, if you are getting stuttering with the default FSX.cfg settings, something is wrong with your system/video card or installation. I know it's a pain, but I would reformat your HDD and reinstall Windows 7, get it all updated and running properly, then begin reinstalling FSX. When you reinstall FSX, it is very important that you start up FSX and run at least the default flight before installing any of the SP's. Once that is done, then install SP1. Start up FSX and run a flight again. Close FSX and install SP2. If you didn't do that with the original installation of FSX, instead of reformatting and reinstalling Windows, uninstall FSX completely (FSX does not uninstall completely and you have to manually delete leftover folders and run a freeware registry cleaner when all that is done. Then start the reinstallation of FSX.

 

For expert help on installing FSX, setting it up and tuning it, you should check out the excellent guide by Nick N at the following link: http://www.simforums.com/forums/topic29041.html. He also has suggestions for eliminating stuttering.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I've done what you two suggested me to do without any succes. Im very desperate now. I think that i have to wait untill new drivers or updates! i wish you could see my problem! Everything runs smooth but this every sec stutters drive me crazy! is there any video recording program for fsx?

Share this post


Link to post
Share on other sites

You have seen a change from 15 sec to 3 sec per stutter after installing c++ libraries?

 

When you say you reinstall Windows then FSX then Acc - what else do you install?

 

.

Share this post


Link to post
Share on other sites

Hi Steve,

first of all thank you for taking part at my problem.

The stutters are permanently after every 7sec. This 7 sec are smooth at 35fps(locked). Befor the reinstall of windows i installed c++ 2008 and after this 2010. Because this also dont fixed my prob i decided to reinstall windows. my steps after reinstalling windows were: Instalation of avast,restart,installation of Office, restart, installation of adobe, restart, installation of winrar and tuneup ut, restart, installation of current drivers und updates(everytime rebooted), then fsx, default flight loaded, restart, installation of acc, default flight loaded, restart. Installation of fsupc,airbusx,flytampa lgav(after every installation rebooted). the stutter are still there.

 

I have now only c++2005 should i install again 2008 and then 2010?

Share this post


Link to post
Share on other sites

I have a laptop that stutters a lot with FSX as well and I believe that one reason is that the CPU wants to slow (Speed Step) down occasionally (how often??)to cool itself - especially when the graphics GPU chip is being utilized heavily - when FSX is running. I wanted to try to stop that downstep but I also didn't want it to overheat so I haven't tried it yet - it would be addressed in Power Options probably. I also think that there are more stutters due to the lower performance disk drive (5400 rpm - not highspeed SATA). This would affect the texture loading and maybe cause more stutters. The fact that seems to be tied to SP2 might give us some clues if we knew what SP2 focused on - maybe it allowed more CPU cores to be used - what are you setting the Affinity Mask to?

Also, maybe you should try to temporarily shut off some of the services - like security software and others - leaving the CPU more time for FSX only.

Share this post


Link to post
Share on other sites

Hi whitav8 and thank you too,

my affintymask in fsx.cfg is at 14. i would like to try this thing with the cpu. do you know how exacly this option is called? BIOS-Power settings and then...

Share this post


Link to post
Share on other sites

I think you may need to install Windows and then your internet security package and then FSX+Acc, do not put anything else [except absolutely necessary drivers] on at this stage, not even any addons.

Share this post


Link to post
Share on other sites

If you get periodic stutters then, it's probably the internet security package or a hardware problem.

 

If all is well you can make restore points and tread carefully as you add each package.

Share this post


Link to post
Share on other sites

FINALY!!!!!

The winner is whitav8!!! I changed one setting in the bios power settings, its name was something with frequency, the options were: eneble(preselected)/allways low. I selected allways low. I rebooted and then i opend the cpuz, the core speed was permanently by 798Mhz. I loaded fsx and wanted to start a flight, the core speed was still there 798 and the fps were 2,5-3. I closed the fsx and restarted and went again to the bios to return this frequence to eneble. then i thought that maybe the tourbo boost caused this. the normal core speed is 2,4Ghz and with turbo boost its 3ghz. my scepsis was that while fsx is running at 3Ghz, the cpu automaticly turns it back for 1 sec to 2,4Ghz or even to 798Mhz and causes this stutters. So i disable turbo boost and loaded a flight. A wander happend, no stutters!!!! i've done 3 tuch and goes without stutters!!! i will do tomorow one or two flights to test this again but i think i fixed the problem!I will also test with turbo boost enebled to see by cpuz if the core speed real goes down(unfortunely i dont thought about to test with cpuz before)

 

But many many thanks to you all for helping and made me to understand the background of this programm and learned me many new stuff!

 

Its now 5am here in greece and i will go finaly after 3weeks happy to sleep!!! I will report tomorow if the tests will get well!

 

 

Again, many thanks to Steve,firehawk,whitav8 and OldMaintChief!!!!!!!!!!!

Share this post


Link to post
Share on other sites

Aha - hardware error :) It's all about eliminating things in order. Good job.

Share this post


Link to post
Share on other sites

On a laptop, set the Power to "Never" shut down the CPU, Hard Drive, and Monitor when on AC power.You can leave the Battery power to default options aince you probably don't run FSX on the battery. Also ensure screensavers are off.

 

Glad you got it fixed!

 

Dave

Share this post


Link to post
Share on other sites

×
×
  • Create New...