Jump to content

Archived

This topic is now archived and is closed to further replies.

Dirk98

What am I doing wrong (SBuilderX)?

Recommended Posts

Hello, I'm trying to remove autogen buildings from the commercial Mega Amsterdam in FSX. Following the advice by Meshman sometime ago I took on SbuilderX for this task. The problem can be seen here:

 

EHAMAGN.jpg

 

and here:

 

EHAMAGN2.jpg

 

 

These autogen buildings pop up in EHAM only when I use custom european land class packages, either from Scenery Tech or Cloud9 (though in different locations on the field). When I remove them from the library, the autogen buildings also go off in EHAM completely. I don't know yet if GEX can be a factor in this, I have it installed too, but I doubt it.

 

Since I wanted to continue using LC from SceneryTech I started reading and playing with SbuilderX in part of AB_ExcludeAutoGen polygon creation.

 

Yesterday I created a small 4-point polygon to put under one of the buildings. To place the polygon on the exact coordinates I used Point from Aircraft function in the SBuilderX Menu for all 4 points around that building. I slewed the plane on those points first and then used "Point from Aircraft". I checked then the coordinates of the polygon are correct by using Fly Aircraft Here - the plane dropped on the autogen building in question. I then compiled the BGL (CVX_PROJECT.BGL), placed it in a new folder: \Microsoft Flight Simulator X\aerosoft\Amsterdam Exclude\Scenery and added a new scenery layer between SceneryTech LC and Amsterdam.

 

Unfortunately the autogen building is still there when I check in FSX. Btw, I don't know the elevation that I should have assigned to the poly, I just clicked OK when referencing the points with Point from Aircraft (as the plane was standing on the required reference point each time).

 

Please enlighten me how it should be done.

 

Many thanks,

Dirk.

Share this post


Link to post
Share on other sites

Ok, as I'm reading on SbuilderX tutorial by Scott Smart, I have to correct some of my steps I did above:

1) Altitude has to be metric. So in case of EHAM it's -11 ft (in FSX Flight Planner) = -3.35m

2) For the sake of experiment I've made one big AB_ExcludeAutogen poly roughly covering the whole area of EHAM

 

Unfortunately all the agrestal autogen buildings are still there. I'm not sure about the scenery layer of the new bgl. Perhaps I should put it not between Amsterdam and Scenery Tech, but just below Scenery Tech.

 

I'd very much appreciate your thoughts and comments.

 

Much thanks,

Dirk.

Share this post


Link to post
Share on other sites

Guys, I'm out of ideas, I placed the new bgl in different layers below Scenery Tech (Area/Layer=116) above 115 Addon Scenery, above Scenery Tech etc., but the autogen buildings are still there. Please help.

 

Thanks,

Dirk.

Share this post


Link to post
Share on other sites

You need an exclusion rectangle not an airport background polygon. See the "Compiling BGL" section of the FSX SDK.

Share this post


Link to post
Share on other sites

×
×
  • Create New...