alpha117

If you think you have found something that's not working.........

Recommended Posts

Assuming you are open to wishlist requests, it would also be helpful if we could have a command "Set Thrust to bugs"

 

This has been implemented for Coolsky DC 9 in version 2.5.7.8

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This has been implemented for Coolsky DC 9 in version 2.5.7.8

 

Set Thrust to Bugs:  He read it back to me correctly, as in "setting thrust to One Point Nine Five", but he didn't actually set it correctly.  For example, with bugs set at 1.95, he actually set it to 2.1, and then upon commanding him again, he set it to 1.7.  My throttles were in a null detent too, (the button area on Saitek throttles normally used for thrust reverse, but in my case, unassigned) so it wasn't interference caused by the signals from my hardware.

Share this post


Link to post
Share on other sites

He read it back to me correctly, as in "setting thrust to One Point Nine Five", but he didn't actually set it correctly.  For example, with bugs set at 1.95, he actually set it to 2.1, and then upon commanding him again, he set it to 1.7.  My throttles were in a null detent too, (the button area on Saitek throttles normally used for thrust reverse, but in my case, unassigned) so it wasn't interference caused by the signals from my hardware.

 

OK, will fine tune in next update.

 

Expect it to be off by one decimal or two.

 

2.10 instead of 1.95 is way off though.

 

It's impossible to get it bang on target without going through an extremely slow loop that moves the throttle slightly, waits for the engine to spool up, reads actual EPR, and continues the process as long as the current EPR is different from the target.

Share this post


Link to post
Share on other sites

Oh, that makes perfect sense.  Don't worry about it though, it's not too important.  I'm just happy that my voxscripts are now cranking along!

Share this post


Link to post
Share on other sites

On the PMDG MD11. No door control (mech and purser, cargo and passenger doors). Both confirm, but nothing happens. I've tried with 'armed' and 'disarmed' doors.

 

Should be OK now with version 2.5.7.8

 

Also sorted, issue you reported in Post #112

 

And FO can now dial QNH on Majextic Q400.

Share this post


Link to post
Share on other sites

Thanks for the information, Gerald.  :smile:  Will check it soon.

Share this post


Link to post
Share on other sites

"Minimums" callout seems to be hardwired for all planes I've tried at 200 feet agl.  I should have reported this long ago, but I just remembered it this moment.  Can we see this pegged to the radar altimeter, and perhaps even made an optional callout somehow, since on many planes the airplane has it's own audible for this event?

Share this post


Link to post
Share on other sites

Hello,

 

There are two bugs regarding PMDG 737 ngx.

1: If you tell your copilot to set your virticle speed to a  negative number, (eg on descend) he will set it to +6000 no matter what you say.

me: Set virticle speed minus two thousand.

co-pilot: setting virticle speed minus two thousand.

(sets it up to +6000)

I have to  do the command for the second or third time for him to do the action and bring it back to negative. sometimes, he will set Vspeed, but forgets to push the  Vspeed button.

 

bug 2: the buttons like, (speed hold, altitude hold, approach hold, track hold)

If you tell your co-pilot to turn them off, he always says that they are already off, while they can be either on or off. (it's like that he always considers them as off)

but if you command him to turn them on, he will press the button. if you command him to turn it on again, he presses the button and it will turn off.

so, in theory, the turn off commands does not work at all, and you have to use the engage/set on/turn on commands to switch them on and off..

 

me: track hold on

co-pilot: roger, track hold, activated now. (he turns it on.)

me: track hold off.

co-pilot: "track hold, it's already  off captain" or "track hold, already disengaged"  (he does not do anything and the switch remains armed)

 

me: track hold on

co-pilot: roger captain, track hold, engaged  (he turns off the switch)

 

IS there any possibilities for this bug to be fixed? or  it's because the way that pmdg switches work. I'm a blind pilot, and  it's very annoying because I have no idea that if either these switches are on right now, or off.

 

Thank you.

 

Not really bugs.

 

Regarding V speed.

 

MCE will look at your current Vspeed.

 

If you are descending and say "set vertical speed 2000", it will assume you meant -2000. The opposite is true when climbing.

 

Regarding other items...

 

MCE interfaces the NGX via the PMDG SDK.

 

You need to install Service Pack SP1c for a start

 

It is important MCE only connects to it when it has finished initialising completely.

 

If you have set MCE to automatically start with FSX and you're getting FO dialling wrong numbers, just restart MCE with NGX fully running, after the 20 seconds onscreen countdown has elapsed.

Share this post


Link to post
Share on other sites

Hello.

 

Are the FeelThere E-Jets v.2 (Embraer 175/195) currently supported by MCE?

 

Apologies if I have posted this question to the wrong thread

 

Thanks

Dwayne

Share this post


Link to post
Share on other sites

Hello.

 

Are the FeelThere E-Jets v.2 (Embraer 175/195) currently supported by MCE?

 

Apologies if I have posted this question to the wrong thread

 

Thanks

Dwayne

 

Co-pilot can handle just about every switch on the Embraer 175/195 overhead panel.

 

Right now, only some items on the MCP (autopilot panel) can be handled correctly.

 

Feelthere ERJ 145 & 135 are fully supported.

 

Share this post


Link to post
Share on other sites

Thank you for the info. If I come across FO commands not functioning or functioning incorrectly in the Embraer 175 is it  appropriate to log it here, or would it be considered "not supported?"

 

Thanks

Dwayne

Share this post


Link to post
Share on other sites

Thank you for the info. If I come across FO commands not functioning or functioning incorrectly in the Embraer 175 is it  appropriate to log it here, or would it be considered "not supported?"

 

Thanks

Dwayne

 

Report it and we'll do our best to implement whatever is missing and is essential to you.

 

 

With aircraft that have SDK like PMDG NGX, Level-D 767, iFly 737 it's straightforward. The SDK tells you what to do to interface button A or B and how to read C etc… It usually doesn’t take more than 3 weeks.

 

Without SDK, we have to use home grown techniques. You could be stuck forever with one single aircraft if you wanted say to give control to pedestal lighting via voice. Therefore we tend to leave out this kind of control unless users really intend to use it

 

We proceed from the most relevant things to the least.

 

We consider overhead panel and MCP as essential, and won’t say we fully support aircraft X until we have full control on these at the very least.

 

Currently supporting…

 

PMDG 737 NGX, MD-11, 747, J41

Aerosoft Airbus X extended

Majestic Q400

Feelthere ERJ 135 & 145

Quality Wings Bae146, 757

Captain Sim 777, 767, 757

CoolSky DC-9, MD 80

iFly 737

Level-D 767

Simcheck A300B4  (3 man crew with simulated flight engineer)

Milviz 737

 

I forgo a couple more, and I didn’t mention all default aircraft and aircraft that are fully compliant with Microsoft SDK, which will work out of the box too.

Share this post


Link to post
Share on other sites

FSX Ifly 737 ver 3.2 -Win7 x64 problem.

 

Just a very quick test with a few commands, but the co-pilot won't set the flaps. He will acknowledge my command, but won't execute and then MCE crashes.

 

Update it will only accept commands over flaps 25,30,40. Below that nothing. Flaps down command will default to flaps 10.

 

Just tested PMDG 737 with the same results, using the latest MCE, downloaded yesterday.

Share this post


Link to post
Share on other sites

Hi All

I'm still fairly new to MCE, and I love it. I currently fly the PMDG 737-800 WL set to Cold and Dark, and MCE works as it should when asking Trav ..."Electrical power up with APU", and through out the rest of the flight, but when I switch aircraft to the PMDG 737-700 W/Winglets and ask Trav ...."Electrical power up with APU", he responds "hydraulic electrical off already. This only happens in the 737-700 W/Winglets all other variants seem to work just fine. Note: I always start MCE after PMDG initialization..

 

Thanks

Share this post


Link to post
Share on other sites

I know why this is.  The 737-700NGX WL doesn't have the vox scripts in it's directory, while all the rest of them do.  It's clearly an oversight, and since I have known about this for months, I should have reported it to FS++ in this thread a long time ago. :blush:

 

Just copy the scripts from the 737-700NGX to the 737-700NGX WL.  Assuming default installation directory, these will be in C:/Program Files(x86)/Support/Files/VoiceScripts/Copilot/Aircraft/(PMDG 737-700NGX and PMDG 737-700NGX WL).  If this doesn't automatically give you the correct scripted flows the next time you run the -700 Winglet, copy those same scripts into Documents/MyVoiceScripts/copilot/Aircraft/(PMDG 737-700NGX WL).  This directory appears to be your working copy of the scripts that MCE actually uses, and allows you to modify, without screwing up the originals in your installation directory.

 

Also, while on the subject, I should also mention to FS++ that when originally setting up the Checklists for the NGX, I noticed that some of those airplanes were not set to point to the correct Checklists by default.  That was some months ago, so I don't remember the details, but I believe that some of the NGXes were actually calling up the checklists meant to go with the earlier FS9 version, instead of the more generic and more appropriate one called "PMDG 737_NGX.txt", that matches the accompanying documentation (PMDG NGX MCE.pdf).  This might be something worth checking out for the next version of MCE to make sure everything is pointing to the intended defaults, both checklists and voxscript flows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now