Jump to content

Archived

This topic is now archived and is closed to further replies.

some1

HQ antialiasing for NVidia cards

Recommended Posts

Hello,

 

below is very simple way to enable High Quality sparse grid supersampling antialiasing for nvidia cards. This actually uses an acknowledged bug in nvidia drivers that causes transparency AA setting to apply to whole scene, not only transparent textures. More story here: http://www.overclock.net/t/1250100/nvidia-sparse-grid-supersampling

 

But it effectively allows us to achieve the same image quality as through usual combined MSAA/SSAA settings in DX9.

 

 

Just forget about fsx.cfg settings for AA and set your nvidia inspector like this:

 

Capture5.png

 

You can also enable FXAA to further smoothen (but also blur) image.

 

It's the best and only way to remove jaggies and shimmering caused by high resolution textures at low zoom levels. Here are shots taken directly from FSX VC at lowest zoom level, 1:1 resolution:

 

Built in FSX multisampling:

Capture-8.png

 

8x Sparse Grid Supersampling:

Capture2-1.png

 

8x Sparse Grid Supersampling + FXAA:

Capture3-1.png

 

Now there is nothing that would still keep me in DX9 mode.

Share this post


Link to post

Mike,

 

Thank you for sharing. This works very well indeed.

Share this post


Link to post

I've found 8xSGSS causes too high of a performance drop for me in heavy clouds and have adopted using 4xAA and 4xSGSS.

 

Sent from my VS920 4G using Tapatalk 2

 

Share this post


Link to post

This works very well for me also, but the lack of vsync is killing me in dx10. Is there any way to make it work properly?

Share this post


Link to post

didn't work, are there other settings like aa compatibilty that need to be set?

 

also, this is for dx9, not dx10 (dx10 forum).

Share this post


Link to post

That's what I found, too...I think it's like Steve's blog suggests. i.e.AA is set within FSX. I took a couple of RA SF260 instrument panel pis and compared them - one with Mike's settings, and the other as Steve suggests:-

 

https://www.dropbox.com/sh/c71jj8xm7dw5mv3/vydhphDEBz

 

The one with Mike's settings has an "MK" in the filename, with "SP" for the one with Steve's settings. You can download them and blow them up to 4000 x or higher, with something like Picasa (it has a controllable slideshow-type function with a displayed zoom level) - but I couldn't tell one from the other. They're both so v e r y close.

Share this post


Link to post

kdfw__

 

From what I've found later, this tweak will work only with cards based on Fermi architecture, so GTX4xx and GTX5xx. Unfortunately with your card it won't work.

And it is DX10 tweak, my shots were taken with DX10 with Steve's shaders fix :)

 

Paul

 

First of all, please don't think I'm denying here what you wrote in your guide :) I'm just showing another way of achieving better results.

 

Steve has a Radeon, so what he writes may not apply 100% to what we can do in nVidia drivers. While enabling supersampling on Radeon in DX10 is as simple as moving one slider, we can't do the same in nVidia drivers except the method mentioned above. At least not in DX10, where normal AA controls do not work.

 

 

Multisampling and Supersampling AA are two very different techniques. Multisampling affects only geometry, leaving textures intact. Supersampling affects everything that you see on the screen, including textures. The the problem here is that FSX does poor job when scaling high resolution textures DOWN. With multisampling alone, you get clear shapes, but jaggies everywhere on your sharp textures, cockpit details and gauges.

 

Now the screenshot comparison you've made is a perfect example of the one situation where there is no differece between multisampling and supersampling.

a) you've made a shot at very high resolution and high zoom. In this situation the textures are scaled UP and they start to get blurry. Not thanks to Antialiasing, but just because the screen resolution is higher than textures resolution.

B) the gauges needles are 3D objects, so each antialiasing method works equally good on them.

 

Don't know about you, but I rarely fly with zoom like that :lol:

 

Now if we reverse the situation, and make a screenshot at normal, wide angle, here's what we get. First is 8x multisampling plus highest possible quality using the config tweaks you have described. The second is the same with FXAA on top of that. Third is 8x SGSSAA (what this topic is about), and fourth is SGSSAA with FXAA.

 

Notice how on every screen window frame is nicely smooth. But textures on the gauges are terribly jaggy and unreadable without SGSSAA (supersampling), because MSAA does not touch them at all. And it looks even worse when you move head around.FXAA doesn't help that much, because the lines are too jaggy to fix them in post processing.

 

All screenshots are taken directly from game in DX10 mode and are uncompressed. Note that you have to download them and compare in 1:1 resolution, not scaled to your browser window.

 

https://www.dropbox.com/sh/5jip81dbnuc92x3/waS4tXFkBe/SGSSAA#/

 

And just some cropped fragments for those too busy to click on the dropbox link :)

 

MSAA x8 (via FSX.cfg tweak)

msaa8x.png

 

MSAA x8 (via FSX.cfg tweak) plus FXAA enabled in nVidia drivers

msaa8xFXAA.png

 

SGSAAx8 enabled in nVidia drivers

SGSSAAx8.png

 

SGSAAx8 and FXAA enabled in nVidia drivers

SGSAAx8FXAA.png

Share this post


Link to post

This is a very informative thread.

 

I have to say Fxaa looks much better than the AMD equivalent.

 

Paul I have just sent you a word doc summarising AMD aa settings, its the text of the latest blog entry.

Share this post


Link to post

Wow! Many thanks, Mike! It's painfully obvious I'm out of my league here!!!

 

From what I'm seeing in your (Nvidia-based) pics, Mike - it means I've assumed that this:-

In order to have any AA ... you must ensure that anti aliasing is enabled in game.
(from earlier posts) - applies to Nvidia cards as well as ATI - and this is (now) obviously not quite as simple as the statement sounds. Those basic settings are adequate, but can be improved upon - "tweaked" - plus my example pics are misleading as I don't fully understand the technology. This is OK. I will amend my thinking and clarify - perhaps filling out the "How-To", including, but separating the two technologies and bringing forward the choices that can now be made. Steve's summary concerning the HD7000 series AA is very good, and can stand alone.

 

Soooo - what I would ask here, Mike, giving you all proper credit due - is that I can take parts, or all of your very enlightening post, and merge it into the "How -To" doc, as you are most definitely demonstrating a DX10 tweak that I now understand, and also understand now, why I'm not able to duplicate your pics by way of the method I used to gain a comparison.

It also demonstrates that DX10 is a different Sim, and there are some pieces that need a little deeper thought....

 

Many thanks, Mike. You're right up there on the Totem Pole with Steve!

Share this post


Link to post

What hardware do you have Matt?

Im using a gtx 470 with a 300 series driver and inspector.

Share this post


Link to post

You have the right driver, Matt, and so I assume you also have the latest Inspector (1.9.6.x series) that has a spot at the bottom to take care of it. The caveat is that it only works in full screen mode.

 

"Vertical Synvc Tear Control" ---> Standard.

"Verticall Sync" --------------------> 1/2 Refresh Rate

 

Hope this fixes the issue!

Share this post


Link to post

Hey guys, I'm glad to hear that you like it and the info is useful.

 

 

Soooo - what I would ask here, Mike, giving you all proper credit due - is that I can take parts, or all of your very enlightening post, and merge it into the "How -To" doc, as you are most definitely demonstrating a DX10 tweak that I now understand, and also understand now, why I'm not able to duplicate your pics by way of the method I used to gain a comparison.

It also demonstrates that DX10 is a different Sim, and there are some pieces that need a little deeper thought....

 

Many thanks, Mike. You're right up there on the Totem Pole with Steve!

 

Nowhere near Steve. He did all the work, I only can switch one or two options in graphics drivers. Of course you can use whatever you want in your guide.

What I wrote also applies to DX9 mode, the only difference is that in DX9 we usually set antialiasing through different option and used one of the combined modes in inspector (mixed MSAA/SSAA).

 

It has to be emphasized that this tweak will work only with GTX4xx and GTX5xx cards. Maybe with the future ones too.

Share this post


Link to post

Just forget about fsx.cfg settings for AA and set your nvidia inspector like this:

 

Mike,

I tried your settings in OP and I'm getting jagged lines when the shadows from the sun are displayed on the aircraft panel. Works great on the outside and for the panel itself but not for the great feature of DX10 and that's the sunlight hitting the panel or inside the aircraft. It was really bad until I turned AA back on in the FSX settings. Then it was a bit better but still get jagged lines. I tried turning FXAA on and that did nothing. I tried Nvidia Predefined FXAA usage and that didn't work. I have the EVGA GTX 580 Superclocked Video Card. I have to say the images are appear a bit better that with Paul's settings or mine but I'm getting even more of those dark flickering shadows near land over the water. Where I do my testing is at Friday's Harbor with FTX/Orbx PNW scenery enabled. Perhaps my problem(s) are associated with Texture Filtering AA Settings. Here is a copy of my settings -

 

582DX10_FSX_Settings.jpg

 

Thanks for the info in the OP and your contributions.

 

Best regards,

Jim

Share this post


Link to post

Jim - I found those dark shimmerings, too - I guess they're supposed to represent the showdow/reflection of the land, or islands in the water. It was an issue in DX9 fer darn sure - but in FX10 - I just went from high 2.x down to Med 2.x in the Water thingy. That High 2.x (in DX9) is used to prevent ground flashing when using BP=0 - so I did what a smart guy might do, and made BP=1, with these settings:-

 

 

[bufferPools]

BufferPools=1

PoolSize=8388608

RejectThreshold=786432

 

and:

 

WATER_EFFECTS=5

 

and voila` - no more flashing and no more black bitty things in the distance or under the islands. When flying VFR Low 'n' Slow - which is 80% of the time - I fly out of CYYJ, and around the Orcas Island area, and so it was very noticeable. The sim shows no signs of distress with those settings, no stutters, no anomalies, so it's all good.... :lol:

 

All the best,

Share this post


Link to post

Thanks Paul (again)!

 

I added the BufferPool entries to my FSX.cfg but left Water at 6. Still saw the black shadows on the water. Went back and changed the Water setting to 5 and that did it and it's difficult to see any difference in the quality of the water. Awesome. You the man!

 

Are you see some jagged shadow edges in the cockpit and I mentioned above? It's not a biggy to me as shadows are shadows and they look good no matter what. But, in my earlier testing with FSX AA/AF turned on in FSX and off in the NI settings, it was a lot smoother, not perfect, but smoother lines.

 

Best regards,

Jim

Share this post


Link to post

Yup - those are the current settings. I was kinda proud of that BP=0, (ego again) but FSX doesn't flash any more in very heavy weather: doing that hasn't slowed it down - still sits at 30 - actually I set that to 31, and now I see more 30's and less 29.9's. (It's red and in the corner of the first of three 19" monitors, and I have to move my head over to verify it). With my eyes - 29.9 could be 29.6, 29.2, 28.8, and so on, I can see 30.

 

No, no jaggies in the cockpit pillar (c172, etc.,) This was done last week, when using AA and AF ticked and set (Anisotropic) within the sim, and nothing in Inspector.

 

https://www.dropbox....n3x4/9vFI1znpWB

Share this post


Link to post

im now using your BP settings in the above post...and the NVIDIA inspector settings in your dx10 doc, and the sim just SHINES at 30 fps! FSX is a new sim to me now, and i hope others have similar experiences.

Share this post


Link to post

For the life of me I simply can not get the plane shadows on ground to be AA'ed. I've followed all the settings to a T about 5 times now. DX9 AA works properly but in DX10 AA is on but not on plane ground shadows. Do we have to run the beta 304 drivers for it to work? I'm running the official 301.42s.

 

I've done a complete driver uninstall. Booted to safe mode. Use Driver Sweeper two times. Reinstalled 301 and still no ground shadow AA.

Share this post


Link to post

Here's what I did after reading your post, Bumpy. I'm using Mike Krawczyk's Inspector settings, they work very well on my machine. Yes - I'm using the 304.48 beta. Seems ok.

 

Can you give us some screenshots of what you're seeing - same sort of format?

 

https://www.dropbox....kcxo/vqPZjZ3WAm

Share this post


Link to post

[bUFFERPOOLS]

BufferPools=1

PoolSize=8388608

RejectThreshold=786432

[GRAPHICS]

shader_optimize=1

shader_partial_precision=1

MULTISAMPLESPERPIXEL=8

SHADER_CACHE_PRIMED_10=1693458432

SHADER_CACHE_PRIMED=1693458432

D3D10=1

HIGHMEMFIX=1

TEXTURE_MAX_LOAD=1024

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=1

AIRCRAFT_REFLECTIONS=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=1

AC_SELF_SHADOW=1

EFFECTS_QUALITY=2

GROUND_SHADOWS=1

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

[sOUND]

AmbientUIMusicVolume=-6.000000

SOUND_FADER1=0.270000

 

 

3 pics are here.

http://minus.com/mXp3NFrvd/3

Share this post


Link to post

The only different setting is - I'm using the 304.48 beta driver, Bumpy, with 1.9.6.6 Inspector, and no cockpit ToolTips... Isn't this a strange one??????

 

We'll have to sleep on it, for now - tomorrow's another day. :Thinking:

 

Cheers,

 

pj

Share this post


Link to post

As Mike explains above Multi Sample Anti Aliasing applies to the geometry (edges) of objects that are drawn. Shadows are not drawn as objects, they are lighting calculations that effect the colour of pixels inside other objects as they are being drawn - in this case the runway. Therefore there is no geometry associated with a shadow to antialias in that way.

 

Whether Super Sampling has some slight smoothing effect I am unsure (way out of what I know) - its not a high definition texture subject to the effect that Mike describes above - if it did the shadowing at a higher resolution and down sampled it would but I don't think thats what occurs.

 

The accuracy of the shadow projection calculations depends on the precision with which the depth calculations of other objects are carried out.

 

I would question

 

shader_optimize=1

shader_partial_precision=1

 

 

OK after some experiments! - those settings seem to have no effect positive or negative.

 

With SSAA off so MSAA then as expected the shadows were slightly jagged in dx9 and dx10 - the view from above at an angle shows this off at its worst, its much less noticble at other angles.

 

Trying SSAA, with DX9 the shadow edge was smoothed whilst with DX10 whilst it was improved over MSAA it was inferior to DX10 and much as you show in the picture.

 

 

 

 

Share this post


Link to post
×
×
  • Create New...