Jump to content

Archived

This topic is now archived and is closed to further replies.

Niroshan Silva

navigation display(ND) stuck on ''app'' mode, can someone help..

Recommended Posts

hello, i'm new to fsx and PMDG 747,

my navigation display works fine for about 5mins after start up the simulator but it automatically switch to app mode and stuck there after a while. the ND mode switch can't be moved except for the center button. i have re installed , pmdg 747 updated with 2.1 version , and did it all over twice.i have tried loading different panel states , but only option is to restart fsx after ND switch stucks to get it operational, for another 5mins..

btw i have tried on vc and 2d both, and try to map a key to map mode, but no luck.. nothing works..

 

 

i can fly with FMC pre programmed routes even its not displayed on on ND, i simply can't see any details except for heading in app mode. i goggled this matter even this was a issue no one seems to have a clear answer for it.. :(

 

hope someone can help me.. thanks in advance.

Share this post


Link to post
Share on other sites

What is really odd from your screen shot is that the your MFD is showing map mode even though the display control shows approach mode. What aircraft are you loading as your default? Should be the Cessna or other simple aircraft.

 

Also please sign your name. Besides being a forum rule, its nice to address you personally.

Share this post


Link to post
Share on other sites

thanks for the reply.. i'm in approach mode, and it's shown in ND, the thing is i cant change to any other modes(map , vor , ect).. that knob is not working .. btw what do u mean by default aircraft ? i didn't get it.. i'm just loading PMDG 747 aircraft from select aircraft option.

 

im niroshan silva from sri lanka.. i thought i was using my name..when i sign in.. ok.. i'll look how to sign my name in.. :)

Share this post


Link to post
Share on other sites

Default aircraft would be the plane that FSX displays when you first start it up before you select the PMDG from the aircraft menu

Share this post


Link to post
Share on other sites

turner thanks for ur reply,i still can't change my nav display from approach mode to any other, that knob seems to be stuck some how, in both 3d and 2d views,

i set my default plane to be pmdg 747 still it's not working..

Share this post


Link to post
Share on other sites

You are not supposed to set the PMDG B747 as your default flight. You should set your default aircraft as a non-payware one (e.g., the Cessna that was already in the aircraft menu when you first installed FSX). After starting FSX, you should then select the PMDG B747 from the aircraft menu.

Share this post


Link to post
Share on other sites

i checked setting many planes as default but still ND mode switch is stuck in pmdg b747, it seems to be default plane not causing the error. ND mode switch works for few minutes after loading the plane, but get stuck on 'app mode' after that..

:wacko2: :wacko2: tired of pmdg now..

Share this post


Link to post
Share on other sites

thanks for the reply owen, i have seen those forum posts and I've already submitted a ticket, but i don't have much faith in official site . this product is bit old to have full support service. i guess..

 

can't fly this bird without ND working properly.

it's very frustrating to have this error. or what ever it is.. :wacko:

Share this post


Link to post
Share on other sites

The PMDG B747 is still popular, so I would have some faith in the official support desk. I have submitted two tickets (although not involving the B747), and both were promptly responded to. Sometimes FSX just has random errors. I have one where, when turning, the virtual cockpit camera moves (simulating inertia), but does not return to its original position after completing the turn. Apparently this is another unsolved issue.

 

Hope the support team can help you.

Share this post


Link to post
Share on other sites

i still didn't got any reply from support team. :(

i have seen posts about this error without an answer , so i really don't think this is a random error just happened to me (but can be a conflict between fsx and pmdg as owen said)

 

http://www.flightsim.com/vbfs/showthread.php?190882-pmdg747-ND-stuck-in-APP-mode

 

if u read above post in flightsim.com , he has managed to find a answer to my question in this forum(in avsim.net), but long time ago(in 2008), now that post don't even exist here.

 

http://forums1.avsim.net/index.php?showforum=136

this is the missing post which i think contain the answer..

 

:( :(

Share this post


Link to post
Share on other sites

Hi Niroshan

 

I have experienced different probs with B747 myself, but PMDG always answered my tickets. They were even good enough to take over my PC briefly (with my consent) and resolved a particularly tricky snag for me. I f you haven't had a response within a couple of weeks, I would try another ticket politely referring to the first, but assuming they haven't responded because they are very busy. They respect all their customers and deserve our respect in return.

 

Incidentally, is there any other adverse effect on your flight?

 

Good luck

 

Lin

Share this post


Link to post
Share on other sites

owen it's just 2 days ago.. so i still have to wait.. i guess . i'll definitely post it here if i got a answer. :smile: who knows one day it might help unlucky guy like me.. ^_^

 

thanks for reply Lin, other than this i haven't had any technical issues in the product . i have pmdg md11 as well . it's working as it should be.. and i have flown it many hours with and without FMC programmed, ND works fine and everything's excellent in md11.

that's why i decide to go for b747. but couldn't even complete a single satisfied flight since ND is not switchable.. :(

Share this post


Link to post
Share on other sites

That's the spirit, Niroshan. With mine i tried uninstalling and reinstalling the B747-400 a few times before giving up. Seems that my problem was something to do with my having Acceleration as well as SP2 in FSx... but I don't remember exactly what, sorry.

 

Lin

Share this post


Link to post
Share on other sites

pmdg support team says this is impossible to happen, there is no fix to this, so i have given up on convincing it happened to me. i'm on some trail of finding the answer by myself. i'm a programmer, after all that's what i do . just give me some time and i'll come up with a fix to this with or without help, for now i believe this is protection system used by pmdg against piracy .i have 100% legal copy ,

this is my assumption ,

as i can remember my computer got stuck and had to end task while install it for first time(b747) due to some background processes . this some how ended up wrong values in registry, and eventually it recognize it's not a legit copy of program and deactivated features. still sniffing for the wrong reg values, if my assumptions are correct i'll end up with a answer. :)

Share this post


Link to post
Share on other sites

Sorry to hear support unable to solve your problem. Assuming your copy of PMDG is legal, try a full uninstall of 747-4, reboot - clear the registry and try a fresh re-install of 747.

 

Lin

Share this post


Link to post
Share on other sites

oh, i personally don't use registry repair tools becoz i have some bitter experience with them. i had to clean install windows after once i have used reg repair tool . any way thanks for mention about it owen .

 

i have solved the issue..!!! there was a registry entry which corrupted as i suspected . i think i know why i couldn't find an answer for it . it's piracy protection mechanism used by pmdg . i only noticed ND, but there are several other in-game faults if it's not activated properly. what a wicked way to handle piracy . :D

 

anyway i have cleaned that reg entry and fixed it.and everything just start working as there was no issue...!! it took lots of time for me to figure it . and i don't know if i should post it here so i'm indirectly helping piracy..

 

okey, i'll tell how to fix it if someone have fallen into exact mess as i am,

 

 

open regedit

[HKEY_LOCAL_MACHINE\SOFTWARE\Abraxis\TheftTracking\MBX\htvx1]

goto this folder

delete the default key there.

and re-install the game.

in my case , i just edit the key, and it worked for me. i guess above steps will work .

 

anyway my problem was in that reg value , i don't know same problem occur for any other reason.

forum administrators, please feel free to delete this post if it's against forum rules. i just shared how i solve my issue. again i have legal copy of pmdg which i took from ebay :)

Share this post


Link to post
Share on other sites

Hi niroshan

I had this problem and follow all of your order ... but still it sucks ... I really become confuse ... pls help me to solve this bulsh... problem ...

plsss

Share this post


Link to post
Share on other sites

×
×
  • Create New...