Jump to content

Archived

This topic is now archived and is closed to further replies.

Alan Bateson

SDK Initialisation error

Recommended Posts

Hi,I just bought fs2crew and installed it. When I start up FSX and click on the area to open up the fs2crew panel it says SDK error and a voice stating it failed to initialise the SDK.I have tried everything stated on this forum and nothing seems to work. Can anyone please help?

Share this post


Link to post
Share on other sites

All is okay now. it seems I have found the answer.

 

I thought i'd read all the SDK error posts but one I must have missed it whilst looking.

 

My options.ini file didn't have this in it and once entered it was all okay.

 

[sDK]

EnableDataBroadcast=1

Share this post


Link to post
Share on other sites

I never fly without it now, fantastic product and I can't wait for the emergency procedures!


ProATC X  Official Beta Tester

Aerosoft Official Beta Tester

Mike Collins

AMD Ryzen 7 3700X 4.2 16 gig ram, NVidia 1060 6 gig, Intel 760 SSD M2 NVMe 512 gig, Crucial MX500 SSD

Reality Is For People Who Can't Handle Simulation!

Share this post


Link to post
Share on other sites

All is okay now. it seems I have found the answer.

 

I thought i'd read all the SDK error posts but one I must have missed it whilst looking.

 

My options.ini file didn't have this in it and once entered it was all okay.

 

[sDK]

EnableDataBroadcast=1

Hello how are you i have this same problem SDK error how did you fix this did you download it from the web or how was it done......?

Share this post


Link to post
Share on other sites

All is okay now. it seems I have found the answer.

 

I thought i'd read all the SDK error posts but one I must have missed it whilst looking.

 

My options.ini file didn't have this in it and once entered it was all okay.

 

[sDK]

EnableDataBroadcast=1


Banner_FS2Crew_Instructor.jpg

Windows 7 Ultimate 64-bit | AMD Bulldozer FX 6100 3.9Ghz | H100i | ASUS Motherboard M5A 78L-M | 16GB DDR3 RAM | EVGA Geforce GTX 770 2gb PCI Express DDR3 | 750w Corsair AX750 | 2x 1TB HDD + 180GB SSD | x2 - 24" WideScreen Monitors

Share this post


Link to post
Share on other sites

In addition to ensuring that the line mentioned above is present, ensure you start in the 2D cockpit as per the manual.

 

The FS2Crew installer should have added that line for you, but due to write permission issues if FSX is located in Program Files, it doesn't always seem to happen.

 

This is why you should never install FSX in Program Files.

 

 

 

Cheers,

Share this post


Link to post
Share on other sites

I've all of a sudden started having the same problem from time to time, where do I find this options.ini file associated with FS2Crew? I did a search for it but couldn't find it...? Just want to make sure I have this EnableDataBroadcast=1 entry.


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
Share on other sites

Just realised the name is in fact 737NGX_Options.ini and nothing else and is a NGX file and not a FS2Crew file so you can disregard from my question above. However it already did have this entry so must be some other reason why I get this SDK error from time to time.

 

When you say it's important to start in 2D and not v/c does that imply start the NGX or FS2Crew? That might be the problem because I always start the NGX in 2D panel mode and the switch to v/c and do various preparations and then one of the last things I do before actually starting the flight is to start FS2Crew. I'll try starting FS2Crew right from start instead when I'm still in the NGX 2D panel mode and see if that will do any difference. Strange though is I only have this problem as mentioned from time to time and not on every flight and still I always do the same stuff in the same order...would like to think I would always get this SDK error if starting FS2Crew from the v/c was indeed the real culprit...?


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
Share on other sites

I've all of a sudden started having the same problem from time to time, where do I find this options.ini file associated with FS2Crew? I did a search for it but couldn't find it...? Just want to make sure I have this EnableDataBroadcast=1 entry.

 

Richard, I believe they are referring to the 737NGX_Options.ini located in PMDG/PMDG 737 NGX/

Share this post


Link to post
Share on other sites

 

Richard, I believe they are referring to the 737NGX_Options.ini located in PMDG/PMDG 737 NGX/

 

Thanks mate but already found out.


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
Share on other sites

Hi Richard,

 

You should be able to open FS2Crew initially from the VC... but try opening it initially from the 2D anyway.

 

Is the FSX Trike the default flight? If not, make it so.

 

Sometimes saved situations can problems.

 

Also, here's a trick to try... if you ever get the SDK message after the plane loads, go to the Flights Menu and select 'reset' the flight.

 

There's a weird Simconnect issue -even the all mighty Pete Dowson has commented on it- that the PMDG NGX Simconnect SDK seems to only load on "alternate" attempts.

 

Cheers,

Share this post


Link to post
Share on other sites

Thanks Bryan, I'll take your advice with me should I see the problem again.


Richard Åsberg
Beta tester for FS2Crew and HiFi Simulation Technologies

Share this post


Link to post
Share on other sites

×
×
  • Create New...