Jump to content

Archived

This topic is now archived and is closed to further replies.

FScamp

Any idea why almost all my games look horrible?

Recommended Posts

After I got new motherboard from ASUS many months ago almost all my games got huge amount of jagged edges and general anti-aliasing problems. For example in Skyrim in game AA doesn't seem to work at all, only thing I found to remove jagged edges from it is setting AA to super sample from ATI Catalyst control center and that makes FPS drop to unplayable levels.

 

Same goes with other games too, with most of them only setting AA to super sample (and giving away way too much FPS) seems to help. I've also generally tried to play with about all the possible settings in catalyst control center, nothing seems to fix these problems properly although I've got some not so graphically advanced games such as FSX to look okay using super sample and still get good enough FPS.

 

Any ideas what I could possibly try to fix this?

 

I'm using Win 7 64 bit home with I7 2600k @ 4.4ghz, Radeon 6990, 8GB of RAM, ASUS P8Z77-V LE Socket1155 4xDDR3 Max 32GB ATX Intel Z77 Motherboard, Acer HS244HQ monitor running 1920x1080.

 

Before I got this new motherboard I didn't have such problems, but still I'm not sure if any part is at fault or if there are something wrong with some settings somewhere.

 

My next card will sure be Nvidia but I wouldn't want to waste money on another high end card so soon.

Share this post


Link to post
Share on other sites

Did you install all the latest chipset drivers for the board? BIOS updated? GPU drivers? CCC version?

 

Did this happen the minute you started to use the PC after the mobo change, or was there a time when it was ok, and now is not?

Share this post


Link to post
Share on other sites

You tell us all about how your video card is crap without telling us what video card you have. I assume with a system that good you wouldn't have skimped on this part. One thing comes to mind. This is a pci express 3.0 motherboard. They are supposed to be backwards compatible with pcie 2.0 cards. But perhaps it doesn't like your video card and is downrating your card to pcie 2.0 or even 1.0 at 8x or 4x. This would severely cut your bandwith. When I installed my Nvidia GTX 580 in my new Asus P8Z77-V Deluxe the mobo wouldn't recognize it in the first pcie slot. I tried the second slot and it booted but at pcie 2.0 at 8x. Might have even been 1.0. This severely affected performance in FSX. Supposedly 2.0 8x is as fast as 3.0 16x but that wasn't the case in FSX. If its an older card it should be running 2.0 16x. I would make sure of that. Get GPU-Z and make sure you have it in the first pcie slot.

Share this post


Link to post
Share on other sites

Oh yeah I forgot graphics card, yeah indeed it's Radeon 6990.

 

I think these problems started directly after getting this new motherboard to allow overclock, older one didn't support it.

 

 

CCC version is 2012.0405.2205.37728, BIOS updated to the latest version.

 

Don't know where exactly I can see which driver version I have? There seem to be some driver versions in CCC but not sure which one to copy.

Share this post


Link to post
Share on other sites

Oh well I guess I got to get new motherboard at some point then.

Share this post


Link to post
Share on other sites

As dcgator29 points out, it could be the settings in the bios for the PCI slot you have it in. Motherboards are getting much more complex.

Check it's in a blue slot, either 1 or 2, then go into the bios and check it's set at x 16. Some people put the cards in where ever it fits, due to the huge size of new cards, and make the mistake of putting the card in the 3rd ( black) slot. This one for example, by default, shares bandwidth with 1 and 2, and the default Bios setting for this one is x 2. not good enough.

From ASUS;

1 x PCIe 2.0 x16 (x4 mode, black) *4

 

*4: The PCIe x16_3 slot shares bandwidth with PCIe x1_1 slot, PCIe x1_2 slot. The default setting is x2 mode. Go to the BIOS setup to change the settings.

 

 

There is also an onboard graphics, and something called virtu/MVP. This allow automatic swapping between the onboard graphics and your AMD video card depending on the demand. Again, go into BIOS and either, disable the onboard one or, if you want that feature, make sure it's set to automatic. You may need some software on the disk to make it work. I don't know a lot about it but it could be an issue. I would first disable onboard one to check, however ASUS claims it can boost the AMD cards performance.

 

Get the manual out and have a good read up and check these settings.

 

A long shot but, type DXDIAG into the search box, open, and under 'display' check the direct X 3d acceleration etc. make sure nothing greyed out or disabled.

 

Hope this helps,

 

Ron.

Share this post


Link to post
Share on other sites

×
×
  • Create New...