Jump to content
Sign in to follow this  
HaraldG

Problem with AISmooth

Recommended Posts

For those interested here is the browser, editor I used:

http://sourceforge.n...rror=hivelocity

 

The project page occasionally has a problem but the download will still start.

 

Here's the main page.

 

http://sqlitebrowser.sourceforge.net/

 

If you try this backup the db files. the _RW .db also has your settings table in it so be sure to reset those if you delete and let aismooth rebuild to default settings.

Share this post


Link to post
Share on other sites

I am using AI Smooth V1.11 and AI Separation V1.1, together when running FS2004. With the recommended settings that Dave Sheffield has told people they should use, when running in tandem with each other. I will try AI Smooth V1.20 again with ronzie's settings, I found on a forum post a while back, or with AI Separation with the above setup I mentioned. Interestingly the other day, I ran FS2004 at the same time Day Month and Airport, without running those two programs. And an AI Aircraft a Vueling Airlines A320, now didn't disappear on approach and landed at the Airport when before it was when running them ? I can't remember which other AI Aircraft did or didn't disappear, but that is interesting in itself. But unfortunately without running AI Smooth V1.11 at least. obviously more go arounds resulted, and as is well known, AI Aircraft are deleted by the FS2004 Engine, if they are told to go around more than 3 times by the ATC. Why would without running AI Smooth and AI Separation, the Vueling Airline now land and not disappear on approach ? Does AI Smooth delete AI Aircraft sometimes ? It seems that if I alter certain settings in AI Smooth V1.11 or V1.20, different AI Aircraft disappear, than before. so a Schedule problem I don't think can be the cause. And is there a way that can be prevented from happening ? i.e. modification of the program (if allowed) in some way ? I have alot of AI Traffic. But not too much I don't think, I have Ultimate Traffic installed. But I always carefully unselect the relevant Airlines when doing an "Ultimate Traffic" Traffic File compile, if I install a new package for the same Airline. Or if say two Airlines have merged, and I install the merged Airline package, i.e. un select the now defunct Airlines that merged to make the new Airline from the Ulitmate Traffic Airline Compile menu when Compiling, and also If an Airline has changed i.e. AIR 2000 became First Choice. I would unselect AIR 2000 from "Ulitmate Traffic" Traffic File compilation, before installing the First Choice AI Traffic package, which I have from WOAI. And the same applies with other Airlines. So I don't just overload FS2004 with Traffic I carefully manage it. Also this deletion of AI Aircraft on approach, happens even when I have disabled General Aviation Traffic. Any help and information someone could give me would be much appreciated. I really could do with help, is is very frustrating having this happen so often and it happens more with AI Smooth V1.20 than 1.11 Could it be to do with what has been discussed in this thread ? I.e. the Scenery in question is Aerosoft's Mega Airport (Amsterdam Schipol) i.e. not a stock FS2004 Airport.

Best Regards Eddie Winch

Share this post


Link to post
Share on other sites

I am having difficulty understanding exactly what your problem is. Try using paragraphs.

AISmooth and AI seperation wont change scheldules or delete aircraft, they will just stop an AI aircraft if if meets the requirements you set and either make it go around or remove it from your current flight.

The same aircraft will appear at the same day/time next time you start the sim. If you dont have any seperation programs running, why would you not expect it to approach and land?

 


Peter Schluter

Share this post


Link to post
Share on other sites

Sorry I will space my text out, i am at my voluntary work at the moment. Will sort that out when I get back. I am just saying I was running AI Smooth and AI Separation together, with Dave Sheffields recommended settings.    

This AI Aircraft in question disappeared, on approach to the Airport a Vueling A320. When I ran FS2004 again at the same time day etc without those 2 programs running, the same AI Aircraft didn't disappear on approach and landed.

Why would that happen without those two programs running. But would with them running ? Could a moderator, please edit my previous post so it has paragraphs ? There is no option for me to edit the post. As too much time has passed. Eddie                 

 

Share this post


Link to post
Share on other sites

And it happened before, when I was using just AI Smooth V 1.11 and tried again with V 1.20 same settings with both. Even without running AI Separation V1.1, the AI Aircraft in question disappeared in Flight on approach to the Airport as did others.

Also can AI Aircraft i.e. an Airliner be deleted in flight, by FS2004 if there is insufficient parking or unsuitable parking, at an Airport  when it is approaching it ? Or will it always approach, land and then disappear on the runway only ?

Could it be to do with what has been discussed in this thread ? I.e. the Scenery in question is Aerosoft's Mega Airport (Amsterdam Schipol) i.e. not a stock FS2004 Airport. And when I mean vanish i do mean that. Not disappear briefly, and or be slewed back by AI Separation, to start it's approach again.

Share this post


Link to post
Share on other sites

As I recall, AI Smooth does not slew back aircraft into holding once on the ground. If there is no room it just disappears from the holding stack after expiration time. AI Smooth runs a last-in first-out stack.

 

Share this post


Link to post
Share on other sites

I see ronzie thanks for your suggestion. Could it be a scenery problem ? i.e. could the EHAM Data for the Mega Airport Schipol, be different to the stock FS2004 Schipol Aiport data ? And that cause an issue in AI Smooth ? i.e. in the RO.db file if the data is different for the Aerosoft Mega Airport would I need to change the numbers to match in that file ? Could it only be using data from the Stock FS2004 Airport ? I.e. akin to the problem mentioned, with a non Stock Scenery on page 1 of this thread ?

 

Share this post


Link to post
Share on other sites

I believe the database is based on the stock FS2004 data.

It does not read your installed scenery data however it complies with FSX data as well in version 1.20, the last released found in the FSX utilities section but works with FS9 as well so the default data is close enough for both FS versions.

Too bad the developer is still not working on it. fsuipc's Pete Dowson has a free app that decodes airport data from installed scenery by priority.

In aismooth you can set things like the horizontal range to scan, useful for parallel or near parallel runways simultaneous use. Read the 1.20 pdf documentation. Version 1.20 is what is embedded in its title bar.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...