Jump to content

Sign in to follow this  
Capt. PERO

Majestic Dash 8 Q-400 (module 2.6)

Recommended Posts

Somewhat. But I noticed the Saitek is backwards. Meaning the left display is the inactive side and the right becomes the active side. However, if you change it via the Q-400, it seems to show the active channel on the left. 

 

Any advice on getting the radio panel working with Linda, pretty new to using it. Managed to set the Switch Panel up without to much trouble but havn't got a clue how to get the Radio Panel to work correctly.

 

I'll take the Active and Stanby being the wrong way round just so long as it works.

Share this post


Link to post
Share on other sites

 

 


Any advice on getting the radio panel working with Linda, pretty new to using it. Managed to set the Switch Panel up without to much trouble but havn't got a clue how to get the Radio Panel to work correctly.
 
I'll take the Active and Stanby being the wrong way round just so long as it works.

 

Sorry but I can't help you there. I unplugged my radio panel for now because it was easier to use the Q400 than the Saitek one. The main reason was the LEDs were backwards. I'll experiment with it over the weekend and let you know if I find a better solution.

Share this post


Link to post
Share on other sites

The Q400 radios are not able to be tuned in any way (as far as I know).

AT least not with the current LINDA module


Guenter Steiner
--------------------------------------------------------------------------------------
LINDA Lua Integrated Non-complex Device Assigning

Betatester for: A2A, Hifi, Simstarter, AivlaSoft 
--------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

The Q400 radios are not able to be tuned in any way (as far as I know).

AT least not with the current LINDA module

 

It's pretty much only the NAV/ADF navigation radios you can't use with hardware, since they are the only ones that require to be linked into the Q400 systems. If you are only using NAV for ILS - then let the FMS tune it for you.

 

* COM radios - use default FSX radios (COM only not NAV) with the Radio panel or VRInsight MCP combo. You can still hear the audio from the tuned frequency. Just ignore what is in the VC.You can see the frequency on your hardware anyway.

* Transponder I haven't tried with VATSIM online, but I think if you keep it linked to default FSX transponder you can keep it that way, and other addons that require your transponder code will see the FSX one.

* Transponder/TCAS mode - Map the transponder "MODE" button to a mouse macro that you create by holding the button until it goes to ALT (TCAS). This then becomes a toggle switch you can toggle between standby and ALT/TCAS.

 

Changes to radios in the VC will update what you see in hardware since the VC changes also update FSX, it's just not the other way around i.e. changes in FSX don't update the VC. But this doesn't matter except for radio navigation.


Dan.W

20.jpg

 

Share this post


Link to post
Share on other sites

Hi,

 

One thing I noticed is the landing gear script doesn't always move the landing gear up, just the handle itself. So I map it to the FSX Default landing gear which works fine.

 

Below are some new scripts if you would like to add to the module?

 

I assign the nose wheel steering to the A/T switch since there's no A/T in Q400.

 

Also a script to toggle all panel lighting happen in one go for a spare button. 

 
function NWS_on ()
    ipc.writeLvar("SIDE_PNL_STEERING", 1)
    DspShow ("NWS", "on")
end
 
function NWS_off ()
    ipc.writeLvar("SIDE_PNL_STEERING", 0)
    DspShow ("NWS", "off")
end
 
 
function PANEL_LIGHT_ALL_TOGGLE ()
  if ipc.readLvar('OHD_PNL_LIGHTS_GLARESHIELD_KNOB_ANGLE') == 0 then
    OHD_PanelL_All_50()
  else
    OHD_PanelL_All_0()
  end
end

Dan.W

20.jpg

 

Share this post


Link to post
Share on other sites

Hi Great work guys ! one question though the heading bug course ias etc if i assign it its really slow as in only 1 degree at a time then if i program the button on repeat its ussually to fast and the hdg bug jumps arround like its on steroids :) anything i can do about this ? when i do it with the mouse inside fsx it works fine however through the lua script with an external knob not thanks in advance !

Share this post


Link to post
Share on other sites

Hello,

 

in the current 1.3 version there is HDG incfast etc. implemented.

 

 

But I know, in the MJC Dash it could be a bit of a pain.

I tried it several ways, but I can't get it to work as it is like if you dial in the VC.

But the current implemented way is the best as far as I can say.


Guenter Steiner
--------------------------------------------------------------------------------------
LINDA Lua Integrated Non-complex Device Assigning

Betatester for: A2A, Hifi, Simstarter, AivlaSoft 
--------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Hallo,

 

i have a small Problem.

The ALT will not be synced.

All other work fine.

I use Linda 2.6.3 with the mcp 1. orig.

 

In linda cfg/Aircrafts there are a lot of

config.mcp-xxxxxxxxxx.lua files.

 

is it possible to delete the old files

 

 

 

Frank from EDDM


Frank from (EDDM)

Share this post


Link to post
Share on other sites

Hi Frank

 

The date/time stamped config-mcpxxxx.lua files are backups created for safety purposes every time you saved a configuration or change.  Once you are happy that you have a working and stable setup you can delete all the old backups.


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Hi Steve

 

do you know something about the alt sync Problem.

When i Change the alt at my knob ist not syncron with the Screen.

 

Frank


Frank from (EDDM)

Share this post


Link to post
Share on other sites

Hello,

 

I have an issue with the HDG and ALT selection knobs. I had it in 1.2 so I just upgraded to 1.3 and still I see the issue.

In some time of the flight I have the change between the precise selection of HDG and ALT numbers to the fast change of them beeing totally imposible to make a precise selection.

For example.. in Altitude I can change from 10feet to 10 feet to 1000 feet every little movement in the knob.. and I don't know how to change it back.

Of course the knobs are bug inc and bug incfast (dec also) in both... 

 

any way to resolve it? because everytime it happens I have to tune the HDG angle and altitude in the virtual cockpit.

 

Thanks!


Javier Rollon. Owner of JRollon Planes for Xplane

Share this post


Link to post
Share on other sites

to be honest, I have that problem too.

And I've tried several ways to avoid it, but no chance.

There must be some code deep inside the Dash which is executing this


Guenter Steiner
--------------------------------------------------------------------------------------
LINDA Lua Integrated Non-complex Device Assigning

Betatester for: A2A, Hifi, Simstarter, AivlaSoft 
--------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Hi there to all q400 simmers,

I have the FS2Crew addon for Majestic Dash8 q400 and also tried to load Linda Module .

The conclusion is that Linda works fine but the FS2Crew module has problems in audio (The automated computer (FO) voice is heard with gaps inside the phrases and words lost.

It was unable to work with FS2Crew because i was unable to hear FO answers . 

Is there anyone that has been trying to merge those two addons and succeeded ?

 

Thank you  

Share this post


Link to post
Share on other sites

Hi there to all q400 simmers,

I have the FS2Crew addon for Majestic Dash8 q400 and also tried to load Linda Module .

The conclusion is that Linda works fine but the FS2Crew module has problems in audio (The automated computer (FO) voice is heard with gaps inside the phrases and words lost.

It was unable to work with FS2Crew because i was unable to hear FO answers . 

Is there anyone that has been trying to merge those two addons and succeeded ?

 

Thank you  

 

Hi,

 

I was just wondering if anybody knows of any progress on the audio issues when using the Q400 with FS2Crew, LINDA and the VRInsight MCP2?

 

 

Another forum user (MarkW) has come to this conclusion:

 

For some strange reason, Linda or your MCP is forcing this variable to 0 - L:RADIO1_SERV_INT_KNOB"
 
This is causing the audio in FS2Crew to drop out, which makes it currently unusable.
 
It really would be great to get this hardware/software configuration working. I appreciate it is probably only a small number within the community that have this setup, but it is a huge shame it currently doesn't work.
 
I don't have the knowledge or skill to look into this myself, but if anyone does and needs help with testing etc I'm more than happy to put this time in.
 
Thanks in advance.
 
Mick

Regards,

 

Mick

 

rb_banner_driver.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...