guenseli

Aerosoft Twin Otter Extended (module 1.3)

Recommended Posts

Thank you again, both ways were good enough to give about 75% results! Many functions are working now (like hdg, course, Garmin, most buttons), but altitude and com & nav radios are not working.  Do you think there is still something to do?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Small add-on to my problem if someone has any idea what is the problem… It looks like that the nav & com radio and altitude data comes from FSX to MCP Combo, but it doesn't work to opposite direction from MCP Compo to FSX. I have noticed this partial functionality also with iFly 737 module, but then the problem is with EFIS functionality. However, in case of iFly 737 also EFIS is working when I'm using VRiSim module instead of Linda.

Share this post


Link to post
Share on other sites
Hello,

 

Thank you for this !

 

But I have a VRinsight FCU (Airbus) and I can not operate properly with Linda.

Understand by this that my FCU is well recognized by Linda but even if the screen displays the default altitude no button is active. I have the latest version of FSUIPC paied.

Is this normal? Did I forget something to do?

 

thank you,

Bruno

Share this post


Link to post
Share on other sites

Hello,

 

Thank you for this !

 

But I have a VRinsight FCU (Airbus) and I can not operate properly with Linda.

Understand by this that my FCU is well recognized by Linda but even if the screen displays the default altitude no button is active. I have the latest version of FSUIPC paied.

Is this normal? Did I forget something to do?

 

thank you,

Bruno

Hi Bruno

 

I believe the reason you may be having problems is that the Twin Otter has not been adapted for the MCP2a Airbus. Try selecting the Boeing MCP in setup and see what results you get - it will only be a basic display but it should work. Also check that you have a configure-mcp2a.lua file in /modules/Linda-cfg/aircrafts/{twin otter} (folder name may vary).

Share this post


Link to post
Share on other sites

Thank you Donor.

 

But I have so many questions about this great tool that I'll open a new topic to ask them all at once ...

Share this post


Link to post
Share on other sites

Hi guenseli et all:

I've been using this amazing module (thank you!) with no problem. However, since I updated my Linda to 2.9.2 version, I got a message error "A serious problem has been found. USER module creation error! Exiting LINDA".

I can't tell you this happens with this module only, but other ones I've tested are working fine.

I have tryed to re-install LINDA and this module but the error messege is still on...

Is there anyone else facing this, or is it a local issue?

Thank you.

Share this post


Link to post
Share on other sites

Hello,

you have to add the file user.lua into your modules folder

 

Modules\linda\aircrafts\Aerosoft_DHC6

I have added it now into the module folder, so redownload it please and copy the file as described above.

Sorry

Share this post


Link to post
Share on other sites

Happen to notice there is a problem with the AP "Thumbknob Down" script. Working on fix it. Works now.

function TW_AP_Pitch_thumbknob_up ()

    TWPitchVar = ipc.readLvar("AP_FD_Pitch_Mode_val")

    if TWPitchVar < 10 then
    TWPitchVar = TWPitchVar - 0.25
    elseif TWPitchVar >= 10 then
    TWPitchVar = 10
    end

    ipc.writeLvar("L:AP_FD_Pitch_Mode_val", TWPitchVar)

    ipc.writeLvar("L:AP_Pitch_thumbknob", -1)
    DspShow ("Ptch", (TWPitchVar)*-1)
end

function TW_AP_Pitch_thumbknob_dn ()

    TWPitchVar = ipc.readLvar("AP_FD_Pitch_Mode_val")

    if TWPitchVar > -10 then
    TWPitchVar = TWPitchVar + 0.25
    elseif TWPitchVar <= -10 then
    TWPitchVar = -10
    end

    ipc.writeLvar("L:AP_FD_Pitch_Mode_val", TWPitchVar)

    ipc.writeLvar("L:AP_Pitch_thumbknob", 1)//////This was -1
    DspShow ("Ptch", (TWPitchVar)*1)//////This was -1
end

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.