Jump to content
Sign in to follow this  
cooperwarner8

737 brakes plz help

Recommended Posts

Hi I downloads the pmdg 737 ngx and I think it is an amazing product with great detail. I am able to do a full autoland but after landing when I have turned the autothrottle and the flight director off, I turn off the runway and I use my rudder pedals to turn and brake but after landing they don't work as well as they do when I turn before takeoff and the brakes don't work at all, even though it says down the bottom 'brake'. Plz tell mine if they're is something I can do because I can't taxi


AMD Ryzen 3800X 3.9 GHz Turbo up to 4.2 GHz

GeForce RTX 2080 Ti Windforce 11GB

32GB 3200MHz RAM 

1TB Crucial SSD & 1 500GB Crucial SSD

Honeycomb Alpha & Bravo, CH Products Pro Pedals

Share this post


Link to post
Share on other sites

Hi,

 

Are you using autobrake? If so can you confirm you have turned it off, even if you switched to manual breaking it could still be on.

 

Kind regards

 

Greg


Greg Marshall

Windows 10 x64 | i7-6700K Skylake 4.2 GHz | 16GB DDR4 2133MHz | 750W PSU | GTX 970 4GB | Asus Z170 PRO Gaming Motherboard | H80i V2 CPU Cooler | Cooler Master Silencio 652S Case | Asus 23" Frameless Full HD Monitor | 250GB Samsung 850 EVO SSD for OS & 2TB Seagate HDD for FSX            

Share this post


Link to post
Share on other sites

Yes I made sure that the autobrake switch was off and that it doesn't say brakes down the bottom, it only says that when i press the rudder pedals


AMD Ryzen 3800X 3.9 GHz Turbo up to 4.2 GHz

GeForce RTX 2080 Ti Windforce 11GB

32GB 3200MHz RAM 

1TB Crucial SSD & 1 500GB Crucial SSD

Honeycomb Alpha & Bravo, CH Products Pro Pedals

Share this post


Link to post
Share on other sites

Have you disconnected the AP after the autoland?  If not, it will fight you when you attempt to exit the runway.  It will remain locked on the localizer even though you will be able to overpower it. 

Share this post


Link to post
Share on other sites

Check your calibration settings using the Control Manager if you use a CH product and also review and recalibrate your FSX and FSUIPC (if applicable) control settings.

Share this post


Link to post
Share on other sites

I have done all that but still no luck, any other suggestions


AMD Ryzen 3800X 3.9 GHz Turbo up to 4.2 GHz

GeForce RTX 2080 Ti Windforce 11GB

32GB 3200MHz RAM 

1TB Crucial SSD & 1 500GB Crucial SSD

Honeycomb Alpha & Bravo, CH Products Pro Pedals

Share this post


Link to post
Share on other sites

Calibrate your brakes through FSUIPC and you can adjust the rate/pressure.  Make sure you delete the brakes in FSX if you use FSUIPC.

 

Rob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...