NEW A2A C172 Trainer (module version 1.0.3)

Recommended Posts

Here you can download the LINDA aircraft module for the A2A C172 Trainer


Installation notes:

  • Download and unzip it and place the two folders into: */Microsoft Games/Microsoft Flight Simulator X/Modules
  • Say "yes" if he'd like to overwrite anything
  • Your current Combo settings wouldn't be overwritten, but you find in Modules/linda-cfg/aircrafts/A2A_C172 files named *.default. name them to *.lua to use them

Note:  If you installed the full version of LINDA 2.5.7 you will need to remove the default C172 folder for this module to work.


Find folder \modules\linda\aircrafts\c172 and move to new location or delete.  Do the same for \modules\linda-cfg\aircrafts\c172.


Download: A2A C172 v1.03


See update below.


Update 11 Mar 2015:

1.0.1 > 1.0.2
changed ALT inner and outer knob behave as it wasn't correct.
Same with VS up/down

1.0.2 > 1.0.3
added missing ident.lua file

Edited by ScotFlieger
Updated for 1.0.3 - LINK updated
  • Upvote 2

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

A2A C172 Trainer advanced module is released.


Features you will see:

  • MCP1 and joysticks-only users:
    • 90% of all knobs and switches are available, will add the rest of them if you will ever need them
    • all the common indication and AP controls should work on MCP1
  • MCP2 users:
    • advanced indications on main display
      • static air state
      • fuel cutoff state
      • cabin temperature
      • transponder mode
      • flaps position
      • OBS1/OBS2/ADF course indication and control - press SPD knob to switch between them
    • radios display
      • indication of active COM channel and morse idents for NAV/ADF/DME is changed to '*' near the current radio mode name - so it's constantly visible now
      • ADF has only one frequency
      • second press on ADF button will toggle BFO button 
      • transponder's current state is always shown 
      • second press on TRN button will toggle current sqawk with 1200 and back - don't forget to activate new sqawk with 'swap' button

!!! Attention !!!

A2A C172 module requires this update for LINDA: 1.12 patch


Note for MCP1 users: module was not tested yet with MCP1, so you can experience some problem. Post here your LINDA console output and I'll fix the issue ASAP.

Share this post

Link to post
Share on other sites

Great work.

I have a little problem with the ALT increase and decrease.

It seems only to work in steps by 1000 feet. 100 feet steps are ignored.

Is there a switch to use the inner our outer knob of the AP?

Share this post

Link to post
Share on other sites

What exact actions do you use?


There are to pairs of them:

  • A172_AP_ALT_plus / A172_AP_ALT_minus - for 100 feet increments
  • A172_AP_ALT_plusfast / A172_AP_ALT_minusfast - for 1000 feet increments

Share this post

Link to post
Share on other sites

I use MCP1 and the configuration is as delivered with the new Version 1.0 A"A Cessna 172R

Even one step turning left or right causes a 1000 feet step in both MCP Display and AP-Gauge.

But for a short Moment the MCP-Display shows i.E. 2100 but this is changed quickly to the next 1000, i.e. 3000


No difference if turning fast or slow.


I just did some testing with the tracer.

When tracing VRI.Lua the console displays i.e.

VRI com3 <--- ALT060 [from Lua Plug-in]

VRI com3 <--- ALT070 [from Lua Plug-in]

In Tracer with Set Value  the kap140_InnerKnob or kap140_OuterKnob work as they should.

Share this post

Link to post
Share on other sites

That's weird. Are you sure, you reloaded LINDA after file change?

Anyway... relaod flie from the same link one more time, replace it and check LINDA Console (press F1) for messages while turning the ALT knob. It should show something about 'ALTplus' / 'ALTminus'. Write down all three indications - console, MCP and AP gauge - and report them back here.

Share this post

Link to post
Share on other sites

I'm just doing a clean LINDA-Install, cause I mentioned that pushing the TERR-Button toggles the GPS-Display, but this function is not set in the Modules EFIS Page.

I will report shortly.

Share this post

Link to post
Share on other sites

There was the old Modul for the A2A C172 from Günther also installed, maybe this caused the problem.

So i have now good news and bad news :-)

The good one, Alt-knob works now.


Bad one HDG-Knob does not move the bug, The bug jumps quickly back to the position tuned with the mouse. Fast turning the knob sometimes makes some change.

Pressing the knob works to align the HDG-Bug


Turning the V/S Knob leads into this Error:

[E] *** LUA Error: ...\modules\linda/aircrafts/A2A Cessna 172R/actions.lua:834: attempt to compare number with string

All knobs and buttons on EFIS-Page work.

Share this post

Link to post
Share on other sites

OK works now for me, with your updated Action.lua.

I replaced the VS and HDG rotaries with the FSX-Default one.

Share this post

Link to post
Share on other sites

HDG works now, ALT like before and AP_VS not.

Same error, seems that c in

function A172_AP_VS_plus (a, b, c)

    if c == nil then
        A172_AP_Button_up ()
        if c > 15 then c = 15 end
        VVS_plus (a, b, c)
        if _MCP2 () then DspVVS(c) end

is a string. 

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.