Sign in to follow this  
Pe11e

No Vector Road Lights with UTX

Recommended Posts

No fps hit at all here. Also HiDef virtual cockpit when enabled will cause a fps drop on low spec systems, maybe.

 

Sent from my U8815 using Tapatalk 2

 

Try flying around the Miami, Ft Lauderdale area with a traffic addon set from middle to high settings. I was getting between 14-16 fps with the terrain edits, when I normally get 35-40 (locked at 40) at night without. With UTX disabled and Global vector lighting using default roads, I was getting 25-30 which is very acceptable, while flying A2A C172.

 

I have a feeling that Orbx Vector product will be more efficient...well I really hope so anyway.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi,

 

Managed to get this working eventually.  I didn't get any UTX vector lights when FTX Central was in hybrid mode. A quick cycle between hybrid to non-hybrid and back again has seemed to have fixed the problem.

 

However, not all of the UTX roads I expect to have the lights, do so.

 

An example is at KSFO.  Taking off in the ultra light from 28L and then turning left to approx 200 I get lights in front of me and stretching into the distance to my right, but they suddenly stop to my left (heading approx 110) with only the non UTX roads remaining lit.  Even if I fly towards the non lit sections the lights do not appear.

 

Anyone else noticed anything similar.

 

Thanks,

Daz

Share this post


Link to post

Try flying around the Miami, Ft Lauderdale area with a traffic addon set from middle to high settings. I was getting between 14-16 fps with the terrain edits, when I normally get 35-40 (locked at 40) at night without. With UTX disabled and Global vector lighting using default roads, I was getting 25-30 which is very acceptable, while flying A2A C172.

 

I have a feeling that Orbx Vector product will be more efficient...well I really hope so anyway.

One thing about the UTX roads is that there are a lot more of them than default, so that equals a lot more lights.  This was a big issue for me before the first FTXG update was released, to the point where I stopped using the vector lights.  After the update to 1.1 though, at least on my system, the lights are a lot more FPS friendly.

 

 

Hi,

 

Managed to get this working eventually.  I didn't get any UTX vector lights when FTX Central was in hybrid mode. A quick cycle between hybrid to non-hybrid and back again has seemed to have fixed the problem.

 

However, not all of the UTX roads I expect to have the lights, do so.

 

An example is at KSFO.  Taking off in the ultra light from 28L and then turning left to approx 200 I get lights in front of me and stretching into the distance to my right, but they suddenly stop to my left (heading approx 110) with only the non UTX roads remaining lit.  Even if I fly towards the non lit sections the lights do not appear.

 

Anyone else noticed anything similar.

 

Thanks,

Daz

UTX roads are separated between urban and rural.  If you added the lights only to the urban roads (per my post earlier), you will see the lights stop where the road transitions from urban to rural.  I believe that if you add them to the rural, they will show up everywhere.

Share this post


Link to post

Hi,

 

However, not all of the UTX roads I expect to have the lights, do so.

Anyone else noticed anything similar.

 

Thanks,

Daz

Yes, I have.

I'm not on my FSX PC now.

 

Just to add to what Galen wrote above. In my setup (UTX Alaska + UTX TAC) terrain.cfg has 40 UT_ROAD_ texture types (urban, rural, bridges, dirt, driveway, etc.), some use the same textures, others differ in the Layout, width, etc.

 

I believe we must address all of them to attain the best results with vectored lights and UTX.

 

Cheers.

Share this post


Link to post

Yes, I have.

I'm not on my FSX PC now.

Just to add to what Galen wrote above. In my setup (UTX Alaska + UTX TAC) terrain.cfg has 40 UT_ROAD_ texture types (urban, rural, bridges, dirt, driveway, etc.), some use the same textures, others differ in the Layout, width, etc.

 

I believe we must address all of them to attain the best results with vectored lights and UTX.

 

Cheers.

Thanks for the info.

 

I thought I had edited them all but I'll have another search through the terrain.cfg. I assumed all the entries were basically grouped together in the cfg file.

 

If I have no joy I will post a screenshot of the issue.

 

Thanks,

 

Daz

Share this post


Link to post

"themachine" and "Bunkers" deserve some type of special merit award to solving this mystery. I tried it and it transformed my night flying.

 

Here is a request for the forum administrator:

 

Is it possible to rename this thread to something more meaningful. For example: "Solution for making FSGX Vector lights work with UTX". This is such an important thread, that I fear some folks aren't going to read far enough to find the solution. Just a thought.

Share this post


Link to post

Dang.

 

I just finished an app that automates setting or removing VectorAutogen to all or some UT_ROADS_ in terrain.cfg. and about to add a mix and match for textures.

 

I was about to ask ORBX and Scenery Solutions for permission to display their textures in the app but reading ORBX answer on another thread here, 
doing that seems is a lost cause.

 

So there goes my VectorAutogen  & mix and match texture application,  probably won’t see the light of day or make it public.

Share this post


Link to post

Dang.

 

I just finished an app that automates setting or removing VectorAutogen to all or some UT_ROADS_ in terrain.cfg. and about to add a mix and match for textures.

 

I was about to ask ORBX and Scenery Solutions for permission to display their textures in the app but reading ORBX answer on another thread here, 

doing that seems is a lost cause.

 

So there goes my VectorAutogen  & mix and match texture application,  probably won’t see the light of day or make it public.

 

I would not allow you to make it public either. No offense.

 

Bob

Share this post


Link to post

I want to make sure, it's ok to keep "(Large divided highway with road signs and generic signs and large billboards and median barrier and middle lights)" segment in the edits correct?  I didn't want to make the edits to find out the syntax is incorrect.

 

Nice work guys

Share this post


Link to post

it's ok to keep "(Large divided highway with road signs and generic signs and large billboards and median barrier and middle lights)"

 

 

Yes it's ok   :good:

Share this post


Link to post

While on the subject of UTX lighting, I recently read the UTX manual and it says the amount of night lighting is directly related to the "Complexity Slider". Yes, I actually read the manual!

 

Also, I did some testing while flying in the USA and Canada, it appears with UTX lighting enabled, from within Orbx FTX Central, the Lights Tweaker has no effect at all. I control the lights using the "Change Lighting Effects Brightness" within the UTX Setup Tool.

Share this post


Link to post

Dang.

 

I just finished an app that automates setting or removing VectorAutogen to all or some UT_ROADS_ in terrain.cfg. and about to add a mix and match for textures.

 

I was about to ask ORBX and Scenery Solutions for permission to display their textures in the app but reading ORBX answer on another thread here, 

doing that seems is a lost cause.

 

So there goes my VectorAutogen  & mix and match texture application,  probably won’t see the light of day or make it public.

 

Can you at least share your texture findings? No need for the app...

Share this post


Link to post

Dang.

 

I just finished an app that automates setting or removing VectorAutogen to all or some UT_ROADS_ in terrain.cfg. and about to add a mix and match for textures.

 

I was about to ask ORBX and Scenery Solutions for permission to display their textures in the app but reading ORBX answer on another thread here, 

doing that seems is a lost cause.

 

So there goes my VectorAutogen  & mix and match texture application,  probably won’t see the light of day or make it public.

Strictly legally speaking I guess you would not be changing any ORBX or UTX stuff if you limit your changes to the terrain.cfg. The terrain.cfg is Microsoft core stuff.

 

This might change the way ORBX or UTX is displayed but this is also changed by moving the sliders, or changing the resolution.

 

SO I guess as long as you do not shift ORBX/UTX files or change those directly, you should be good ...

Share this post


Link to post

Can you at least share your texture findings? No need for the app...

...... if you limit your changes to the terrain.cfg.

Making changes to texture calls for each affected Road [TEXTURE.???] within terrain.cfg, alone and editing layout parameters won’t work.

You’ll end up with a nasty mismatch and checkerboard road pattern. IMO Work has to be done with texture files. (Mix and Match)

 

However, I understand the IP issues at hand; that is why I wanted to ask permission in the first place.

 

Cheers.

Share this post


Link to post

Hi,

 

Managed to get this working eventually.  I didn't get any UTX vector lights when FTX Central was in hybrid mode. A quick cycle between hybrid to non-hybrid and back again has seemed to have fixed the problem.

 

However, not all of the UTX roads I expect to have the lights, do so.

 

An example is at KSFO.  Taking off in the ultra light from 28L and then turning left to approx 200 I get lights in front of me and stretching into the distance to my right, but they suddenly stop to my left (heading approx 110) with only the non UTX roads remaining lit.  Even if I fly towards the non lit sections the lights do not appear.

 

Anyone else noticed anything similar.

 

Thanks,

Daz

 

Did you get this sorted Daz? I added all the rural roads, bridges & ramps I could find  - hoping to resolve the problem this particular area south of KFSO but got no joy.

 

Is there a 'definitive' list of road objects that need to be massaged?

Share this post


Link to post

 

 


just finished an app that automates setting or removing VectorAutogen to all or some UT_ROADS_ in terrain.cfg. and about to add a mix and match for textures.

 

Besides the legal issues here, UTX already has this capability in the advanced options. You can use alternate or create your own texture sets, for most UT objects, including Roads.

Share this post


Link to post

Did you get this sorted Daz? I added all the rural roads, bridges & ramps I could find  - hoping to resolve the problem this particular area south of KFSO but got no joy.

 

Is there a 'definitive' list of road objects that need to be massaged?

 

Hi,

 

No, still have a problem there.  I have edited all entries based on number of lanes with the vector lights I think would be relevant, including ramps, bridges, highways etc.

 

I've noticed the lights seem to occupy scenery grids and when they stop as in KSFO, they all stop abruptly at the same scenery grid edge if that makes sense.

 

Daz

Share this post


Link to post

 

 


I've noticed the lights seem to occupy scenery grids and when they stop as in KSFO, they all stop abruptly at the same scenery grid edge if that makes sense.

Same here - never thought of it as related to a scenery grid. I guess the proper course is to find out if this problem is independent of UTX and this terrain.cfg workaround and if so, take it up with the Obrx support people.

Share this post


Link to post

Ive noticed that increasing the LOD_Radius does not increase the UTX_lighting radius concurrently

Share this post


Link to post

Same here - never thought of it as related to a scenery grid. I guess the proper course is to find out if this problem is independent of UTX and this terrain.cfg workaround and if so, take it up with the Obrx support people.

 

If you enable UTX lights, do they continue where the FTX vector lights cease to continue? (I haven't tried this).

Share this post


Link to post

If you enable UTX lights, do they continue where the FTX vector lights cease to continue? (I haven't tried this).

Okay - UTX road and intersection lights both work perfectly over this area when enabled. I disabled UTX using the quick disable control under the 'terrain' tab in the UTX configuration tool and I still had issues. This is hardly conclusive since UTX is still on my system.

 

Could someone without UTX USA installed on their system try a night flight out of KSFO and have a look at the area South East of the airport (Burlingame, San Mateo, Redwood City) and see if you have Vector lights along the roadways?

Share this post


Link to post

Did you get this sorted Daz? I added all the rural roads, bridges & ramps I could find  - hoping to resolve the problem this particular area south of KFSO but got no joy.

 

Is there a 'definitive' list of road objects that need to be massaged?

Be careful about adding it to all roads. FSX has trouble handling it. I find you can add it to all the 2 and 3 lane roads, but not the 1 lane roads (There is just too many of them), as it appears to overload FSX, and FSX can't keep up.  (At least on my system which is admittedly not the strongest.)

Share this post


Link to post

Be careful about adding it to all roads. FSX has trouble handling it. I find you can add it to all the 2 and 3 lane roads, but not the 1 lane roads (There is just too many of them), as it appears to overload FSX, and FSX can't keep up.  (At least on my system which is admittedly not the strongest.)

I hear you. The vector lights really drag down my system too (night or DAY!)... but I am trying to troubleshoot this little problem and then do some streamlining of which roads get it and which don't.

Share this post


Link to post

Okay - UTX road and intersection lights both work perfectly over this area when enabled. I disabled UTX using the quick disable control under the 'terrain' tab in the UTX configuration tool and I still had issues. This is hardly conclusive since UTX is still on my system.

 

Could someone without UTX USA installed on their system try a night flight out of KSFO and have a look at the area South East of the airport (Burlingame, San Mateo, Redwood City) and see if you have Vector lights along the roadways?

 

The vector road lights appear again once I approach KPAO and beyond, they are also OK across the bay.

 

What I have noticed is that if I edit the terrain.cfg to disable some road lights etc, I have to switch FTX central to a full region and then back to global or I lose the vector lights on UTX roads completely.  FTX central also gives me an error regarding restore.bat but I guess this is because the current and backed up terrain.cfgs do not match at that point in time.

Share this post


Link to post

 

 


What I have noticed is that if I edit the terrain.cfg to disable some road lights etc, I have to switch FTX central to a full region and then back to global or I lose the vector lights on UTX roads completely. FTX central also gives me an error regarding restore.bat but I guess this is because the current and backed up terrain.cfgs do not match at that point in time.

Never seen this on my system but I've been careful to only edit the terrain.cfg, not swap it out. Also, I have no regions, only FTXG.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this