Hello,   I have been having long pauses and freezes with the 777 from day one and have not had the chance to do a whole flight as this issue was driving me crazy.   Well, someone asked me to try and deactivate the FSUIPC autosave and try it. I just completed two short flights (EDDF-EGLL and back) and had ZERO pauses or freezes of any kind. The flights were amazing. I am going to try a long haul flight and see how that one goes. Will report tomorrow.   It looks like in my case, the problem was with the FSUIPC settings. Not sure if anyone esle can get their pause/freeze issues corrected by doing this but it worked for me.   Thank you McLaren and B247NG for your suggestions. Now, Let's Go Flying!!!!! B)   Regards,   llavi01