Sign in to follow this  
Lurk

DX10 glitch with bloom enabled

Recommended Posts

I'm having this bug I can reproduce when bloom is enabled in DX10.

I'm using DX10fixer, but it was happening before. Whenever I cross cloud altitude, I get these fast flashing black squares in the sky.

As soon as I am above the clouds, the effect disappears. I've seen this happening on the last two full re-installations of FSX Acceleration. I'm using REX clouds (changing cloud res doesn't matter).

 

This bug completely disappears as soon as I disable bloom in FSX display settings.

 

Anyone have an idea what might be causing this?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

My first thought was it could be the strobe or exterior lighting of the plane you are flying bugging out due to Bloom. I use SweetFX to enable bloom and disable the bloom within FSX, and have not had this problem you describe, and I am using DX10Fixer.

Share this post


Link to post

the squares appear right in front of me at approximately half screen height and randomly, flashing very quickly, in front of the panel in vc - or in any view for that matter - when and only when I reach and cross cloud altitude. Then they stop and never show up again.

 

I too use SweetFX bloom, but native bloom is definitely better, especially after the Fixer.

 

I have a feeling it's related to how the bloom shader works, maybe even in relation with REX clouds. I'm hoping to find the culprit because DX10 bloom is a subtle yet very nice touch I would like to keep, but this glitch is really quite distracting : (

Share this post


Link to post

Hmm I have never seen this specific issue you describe, but as you say it must have something to do with the Bloom filter interacting with ur plane as it transits cloud layers. All I can say is try it with and without native bloom, try lower res. REX clouds, try a diff. plane in case it is something about external lights of the model bugging out with bloom when u transit clouds. Sorry i am as stumped as you are, wish I could help more...

Share this post


Link to post

I'm stumped as well. Any of the default planes exhibits this behavior, and I'm pretty sure it has nothing to do with the planes themselves, rather probably with REX clouds, although, as I've said, changing their resolution does absolutely nothing in this respect.

 

Only way to fix the problem is to disable native FSX bloom, which is a real pita since it's one of the very reasons it's worth using DX10.

 

I'm at wit's end, and giving up REX clouds is absolutely not an option.

Share this post


Link to post

I'm having this bug I can reproduce when bloom is enabled in DX10.

I'm using DX10fixer, but it was happening before. Whenever I cross cloud altitude, I get these fast flashing black squares in the sky.

As soon as I am above the clouds, the effect disappears. I've seen this happening on the last two full re-installations of FSX Acceleration. I'm using REX clouds (changing cloud res doesn't matter).

 

This bug completely disappears as soon as I disable bloom in FSX display settings.

 

Anyone have an idea what might be causing this?

I have exaclty the same issue.

Share this post


Link to post

maybe with some help we can narrow it down, I hate to give up DX10 bloom.

Do you use REX clouds? If so it might be fixed by checking their textures. I'm only guessing here...

Share this post


Link to post

Whenever I cross cloud altitude, I get these fast flashing black squares in the sky.

 

I have Bloom enabled with REX Clouds (HD 2048), no black squares in my clouds and I'm running FSGRW with cloud draw distances at 160mi.

 

EDIT: I don't have SweetFX

Share this post


Link to post

I've tried without SweetFX and the problem persists.

Share this post


Link to post

What graphics board do you have? Nvidia or ATI ?

Share this post


Link to post

really annoynig bug, tried about everything and I'm pretty damn sure it has to do with REX clouds. I'll try flying on a clear sky tonight.

I own ATI. As I said 1.000 times, turning off bloom in the sim solves the problem and it is the only bug I've seen with bloom enabled.

Share this post


Link to post

tried about anything tonight to solve this, including messing with shader files. the issue is persistent, I can't seem to get rid of it : (

Share this post


Link to post

tried a flight with clear skies last night after deleting FSX Shader folder and reinstalling original, re-installing DX10Fixer libraries, clearing and rebuilding shader cache.

Results ---> clear skies = no flashing black squares

             ---> clouds = flashing black squares when crossing first cloud layer

 

I need some expert help on this, I don't want to give up bloom! :-(

Share this post


Link to post

Please, Lurk - add your system specs to your profile, so that it appears under you avatar at left, then copy your fsx.cfg somewhere, and rename it as "lurk_fsx.txt", and then attach it to your reply using the "More Reply Options" (bottom-right corner). Lastly - publish your Inspector or RadeonPro settings on a fileshare site, such as PhotoBucket, PostImage.org, MediaFire or a Dropbox somewhere, so that we don't have to keep guessing at some kind of answer. There could be a million things causing this.

 

Thanks,

 

pj

Share this post


Link to post

thx Paul J, I've updatedmy profile with relevant info, not using RadeonPro, the glitch appears with or without SweetFX and even on an untouched freshly recreated FSX.cfg.

Hope we can narrow those million things down to a few! :P

Share this post


Link to post

I'd suggest you:

 

1.  Disable Crossfire.

2.  See if you have the problem on a single monitor - 5996 x 1080 is 3 monitors, but not sure how you got 5996?

3.  Make sure you have the latest AMD drivers AND (important) the associated CAP for that driver.

 

My hunch is something driver related.

Share this post


Link to post

Hi, I've been having this problem for the past 4 or 5 driver releases, I'm on the latest betas from AMD (no CAP needed).

5996 is a bezel compensated resolution.

I've just ended an agonizing FSX session where I've tried to solve the problem by disabling a lot of features (AI aircraft, UTX scenery entries, you name it) and changing all sorts of FSX display parameters, but this show-stopping glitch keeps rearing its ugly butt.

I'll try on a single screen and with Crossfire disabled, then I can hopefully get some rest!

 

thx for your suggestions

Share this post


Link to post

OK thanks for the good info - now we can see what's going on. I just looked at your config, Lurk. You have very high expectations, it seems!!  :lol:   

 

Listen - read this list, and then adjust everything back to the minimums which are listed. Remember - this is only temporary, while we fiddle around, and diagnose. Leave your bloom enabled. Leave only one of your traffic settings at 20 - either AI or GA, airport traffic at 1, and the rest at zero. Rob will figure out your AMD gpu, as I'm an Nvidia guy, maybe Charles will pipe in, too.

At first look at the cfg - I think you're getting those black squares/flashes because you're way overloading your graphics system.

 

Anyway - have fun - I'll be back here tomorrow morning - it's bedtime here. 

 

All the best,

 

pj

Share this post


Link to post

 

 


Rob will figure out your AMD gpu, as I'm an Nvidia guy, maybe Charles will pipe in, too.

 

I'm on nVidia these days, but I was on AMD a couple years back.  

 

 


I'll try on a single screen and with Crossfire disabled, then I can hopefully get some rest!

 

Basic idea of my suggestion is to get back to the basics and make sure it's working, then start moving up/adding and see what breaks it for you.  Single monitor and Crossfire disabled is part of getting back to the basics ... certainly not a suggestion you can only use 1 monitor, just for diagnostics.

 

Rob

Share this post


Link to post

thanks everyone for the precious input, I've just tried with Crossfire disabled and one monitor only. I've disabled additional add-ons such as freeware alps meshes. Needless to say, the sim REALLY flies! :Big Grin: but guess what, the flashing black squares are ALWAYS there at the same altitude!!! :angry:

Paul J, thanks for the info, I am going to follow your directions and report back tomorrow!

 

cheers to everyone

Share this post


Link to post

but guess what, the flashing black squares are ALWAYS there at the same altitude!

 

One more idea comes to mind, are you using any 3rd party clouds?  AS2012 or REX or something else?

 

Also, after I installing any 3rd party product, I always fire up DX10 Controller as it will scan for changes and/or new files that might need to be updated.

 

And finally, what version of the DX10 Controller are you using?

 

One more thing to try, delete your Shaders10 folder (it gets regenerated) - C:\Users\...\AppData\Local\Microsoft\FSX

Share this post


Link to post

thx Rob, I'm using REX clouds and am pretty convinced there lies the culprit. I tried a flight with clear skies and guess what, the problem disappeared.

I've already done the Shader folder deletion and cache regeneration about a thousand times :P with no success.

I've followed Paul's advice by turning down settings as per instructions, and although it seemed the flashing black squares were reduced in number, I did still see a couple popping out.

For the time being I've simply decided to live without bloom, as it is the only way to completely eliminate the problem.

 

I'm also investigating my WOAI aircraft textures as it seems a lot of them have missing mipmaps and alpha channels (I'm using ALphaSearcher). Due to their large number (hundreds?) going out there and actually fixing them is a whole different business, so I'll probably procrastinate this for a while! (and I'm not even qute sure how it's done!  :blush:)

 

thx for your precious help :smile:

Share this post


Link to post

What are your cloud settings in REX?  Make sure you have DXT5 Optimized Clouds checked.  I'm using REX also with no issues, my clouds are:

 

 

 

You may also want to use a different texture set, here is what I'm using:

 

 

 

 

Share this post


Link to post

thx again Rob, I do have that option selected and I have already tried random textures, maybe there is an entire bunch of clouds which exhibits this problem with bloom enabled on my system. I just started a flight and soared for a while, bloom disabled: very refreshing to have everything running smooth without those awful squares! I've started the process of converting my WOAI aircraft bmp's that lack mipmaps and will give bloom another try when done. Who knows, maybe some AI aircraft are glitching when rendered through clouds...

Share this post


Link to post

Coupla docs here, that will help you add the missing alphas and mips, Lurk.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this