Sign in to follow this  
Rob Ainscough

D3DCSX_43.DLL crash on P3DV2 startup ... D3DCSX_46.DLL?

Recommended Posts

I have posted and emailed LM regarding repeated crashing (event log provided) with D3DCSX_43.DLL. See here: http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=4706#postid-22025

 

Here is the Event Log listing of the error:

 

P3DV2Error1.jpg

 

I'm posting here in addition to LM as to gather information about this error, has anyone else experienced this problem?  

 

I'm thinking because I have Visual Studio 2012 Ultimate installed and SlimDX.  LM use SlimDX also (can see it listed in the Prepard3D root directory) - but they use a much older version of SlimDX going back to 2010, I use a newer version date in 2012.  SlimDX is a wrapper around DX11 API calls for .NET applications.

 

D3DCSX_43.DLL is a DX11 compute shader extension ... there are several flavors of it depending on one's platform (I have three version D3DCSX_42.DLL, D3DCSX_43.DLL, and D3DCSX_46.DLL)  43 is dated 2010, 46 is 2012 for Win7 (DX11.1) ... this is also a 47 for Windows 8/8.1 exclusively.

 

Problem:

Start P3DV2 and wait for it to go thru the loading process, get a black screen then will get the above error about 50% of the time.

 

Here is a good blog (from MS developer) around some of the issues of DX deployment: http://blogs.msdn.com/b/chuckw/archive/2010/09/08/not-so-direct-setup.aspx

 

I'm wondering if this is my problem - DLL hell, the very thing .NET framework was supposed to resolve.  Thoughts?  Anyone confirm?

 

Thanks, Rob.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I did have the same exact problem after I installed FSDream Ground Services, problem went a way when I started removing add ons one by one till I uninstalled (My Traffic 2013) and problem was solved, re installed every add on I have (Orbx FTX-G, FSDream KJFK2, FSDream KLAX2, FSDream GS and My traffic 2013), did not have any problem so far ( about 2 weeks ), so I suggest removing add ons one by one starting with any one that has no dedicated P3DV2 installer and see what happens.

 

Good luck.

 

Ali A.

Share this post


Link to post

Good luck.

 

Thanks Ali, but I'm a little confused ... you removed all add-ons, then added them ALL back and the problem went away?  Was there a particular sequence you used when adding back?  Just curious, did you change your default Airport to be a standard P3DV2 one or an FSDT one?

 

My hunch ... and that's all it is ... is that there is some DX11 compatibility issue with FSDT airports (in my case KSFO)

 

DX11 (and 11.1) can't be deployed, there is no runtime to deploy with an application so what I have on my system for DX11 components is whatever Windows Update provided (I have no real choice in the matter).  DX11 comes with Win7 SP1 and any updates are via Windows Update.  I guess Microsoft decided this is yet one more way to force/leverage customers onto Windows 8/8.1 by controlling DX11 onwards  deployment.  The D3DCSX_43.DLL is a D3D 11 component.

 

As a test, I'm going to set my Default airport to some other P3DV2 default airport location (no 3rd party), and delete my shaders folder and see what happens.

 

Thanks for your input, appreciate it.

Share this post


Link to post

SOLVED:

 

Turned out to be some issue with have my Default startup flight using FlightBeam and/or Virtuali ... I was using FB's KSFO as my default.  Set my default startup flight to Minnesota-St. Paul (P3DV2 default airport) and after 15 successful P3DV2 starts, not a single error.  I'm guessing FB or Virtuali is doing some process that perhaps starts BEFORE P3DV2 is fully initialized?

 

Anyway, if anyone else runs into this problem, try setting a native P3DV2 airport as you default startup.

 

Rob.

Share this post


Link to post

Hi Rob'

Glad to see thing going well for you.

Sorry about the start up flight, YES I did delete my start up flight and shaders folder before I remove any add on but when I started P3d problem came back after loading the sim when I was preparing for take off from default airport (sim some times loads fully then crashes after a few seconds into cockpit, or it will crash during loading), removed add ons one by one after that and problem was cleared after removing My Traffic 2013, then started adding them back one by one (testing in between) and every thing was OK, but yes again shaders folder and start up flight were deleted first (but I was not lucky to have it solved).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this