Jump to content

Archived

This topic is now archived and is closed to further replies.

Lizz

LED64 configfiles driving me "crazy..."

Recommended Posts

I just connected a second Phidget LED64 board to drive my annunciator panel in my homecockpit. It works fine and I was very pleased.

So I started to make the final assignements for all datarefs to be adressed by the Phidget boards and adapted the existing config file accordingly.

When I started X-plane it simply crashed and looking into the log.txt file it crashed because of the  Phidget64 sender application.

Putting back the original configfile (also with 2 boards) doesn't crash X-plane so I started to look for the differences between the two files. Unfortunately I am unable to determine what makes x-plane crash on one file while it simple starts OK on the other file.

Below you will find both config files (the one that crashes X-plane and the one which is OK).

 

Problem is that the Phidget64 plugin simply doesn't give any clue on what is causing the crash, it simply crashes X-plane and that's it!!!

Or is there a 'hidden' logfile somewhere that gives some insight on why the plugin crashes?

 

The manual is also not very clear on any required conventions (e.g. remarks in the file, sequence, valid Datarefs etc...) other then the structure of one line entry.

 

I'm very happy that it is possible to connect 2 Phidgetboards and it works great but this kind of behaviour drives me totally nuts..... :wacko: :wacko:

 

This is the configfile that crashes X-plane:

;Copyright © 2013, BajuSoftware LLC
;Configuration File for datarefs
;Version 2.41
;Format: Port|ID|dataref
;------------------------------------------
;IP Address
127.0.0.1
;Interval
0.2
;DataRefs
50001|1I_00@0|sim/cockpit2/annunciators/flight_director
50001|1I_01@0|sim/cockpit2/annunciators/autopilot
50001|1I_02@0|sim/cockpit2/annunciators/master_warning
50001|1I_03@0|sim/cockpit2/annunciators/master_caution
50001|2I_04@0|sim/cockpit2/annunciators/generator_off
50001|2I_06@0|sim/cockpit2/annunciators/igniter_on
50001|2I_08@0|sim/cockpit2/annunciators/oil_pressure_low
50001|1I_10@0|sim/cockpit2/annunciators/ice
50001|1I_11@0|sim/cockpit/warnings/annunciators/ice
50001|1I_12@0|sim/cockpit2/annunciators/pitot_heat
50001|1I_13@0|sim/cockpit2/annunciators/landing_taxi_lite
50001|1I_14@0|sim/cockpit2/annunciators/fuel_quantity
50001|1I_15@0|sim/cockpit2/annunciators/inverter_off
50001|1I_16@0|sim/cockpit2/radios/indicators/outer_marker_lit
50001|1I_17@0|sim/cockpit2/radios/indicators/middle_marker_lit    
50001|1I_18@0|sim/cockpit2/radios/indicators/inner_marker_lit
50001|1I_19@0|sim/cockpit2/annunciators/autopilot_disconnect
50001|2I_20@0|sim/cockpit2/annunciators/fuel_pressure_low
50001|2I_22@0|sim/cockpit2/annunciators/oil_temperature_high
50001|3F_24@0|sim/flightmodel2/gear/deploy_ratio
50001|3F_27@0|sim/flightmodel2/gear/deploy_ratio
;
50001|1I-03@1|sim/cockpit2/annunciators/hvac
50001|1I-07@1|sim/cockpit2/annunciators/cabin_door_open
50001|1I-10@1|sim/cockpit2/annunciators/landing_taxi_lite
50001|1I-12@1|sim/cockpit2/annunciators/GPWS
50001|2I-13@1|sim/cockpit2/annunciators/fuel_pressure_low
50001|2I_18@1|sim/cockpit2/annunciators/generator_off
50001|2I-20@1|sim/cockpit2/annunciators/oil_pressure_low
50001|2I_22@1|sim/cockpit2/annunciators/engine_fire
50001|2I_24@1|sim/cockpit2/annunciators/bleed_air_off
50001|1I-26@1|sim/cockpit2/annunciators/fuel_quantity
50001|1I-27@1|sim/cockpit2/annunciators/hydraulic_pressure
50001|2I_28@1|sim/cockpit/warnings/annunciators/chip_detected
50001|1I-30@1|sim/cockpit2/annunciators/ice
50001|1I_31@1|sim/cockpit2/annunciators/pitot_heat
50001|1I_33@1|sim/cockpit2/annunciators/autopilot
50001|1I-34@1|sim/cockpit2/annunciators/low_voltage
50001|1I-35@1|sim/cockpit2/annunciators/no_inverters
50001|1I-36@1|sim/cockpit2/annunciators/cabin_altitude_12500
50001|1I-37@1|sim/cockpit/warnings/annunciators/autopilot_disconnect
50001|1I-48@1|sim/cockpit2/annunciators/crossfeed_on
50001|1I_50@1|sim/cockpit2/annunciators/yaw_damper
50001|1I-51@1|sim/cockpit2/ice/ice_window_heat_on
50001|1I-54@1|sim/cockpit2/ice/ice_inlet_heat_on
50001|1I_56@1|sim/cockpit/electrical/landing_lights_on
50001|1I-57@1|sim/cockpit2/ice/ice_surface_boot_on
50001|1I_59@1|sim/cockpit/electrical/taxi_light_on
50001|1I-60@1|sim/cockpit2/ice/ice_prop_heat_on
50001|1I_62@1|sim/cockpit2/annunciators/flight_director
50001|1I-63@1|sim/cockpit2/annunciators/speedbrake

 

This is the configfile that works OK:

;Copyright © 2013, BajuSoftware LLC
;Configuration File for datarefs
;Version 2.41
;Format: Port|ID|dataref
;------------------------------------------
;IP Address
127.0.0.1
;Interval
0.2
;DataRefs
50001|1I_00@0|sim/cockpit2/annunciators/flight_director
50001|1I_01@0|sim/cockpit2/annunciators/autopilot
50001|1I_02@0|sim/cockpit2/annunciators/master_warning
50001|1I_03@0|sim/cockpit2/annunciators/master_caution
50001|2I_04@0|sim/cockpit2/annunciators/generator_off
50001|2I_06@0|sim/cockpit2/annunciators/igniter_on
50001|2I_08@0|sim/cockpit2/annunciators/oil_pressure_low
50001|1I_10@0|sim/cockpit2/annunciators/ice
50001|1I_11@0|sim/cockpit/warnings/annunciators/ice
50001|1I_12@0|sim/cockpit2/annunciators/pitot_heat
50001|1I_13@0|sim/cockpit2/annunciators/landing_taxi_lite
50001|1I_14@0|sim/cockpit2/annunciators/fuel_quantity
50001|1I_15@0|sim/cockpit2/annunciators/inverter_off
50001|1I_16@0|sim/cockpit2/radios/indicators/outer_marker_lit
50001|1I_17@0|sim/cockpit2/radios/indicators/middle_marker_lit    
50001|1I_18@0|sim/cockpit2/radios/indicators/inner_marker_lit
50001|1I_19@0|sim/cockpit2/annunciators/autopilot_disconnect
50001|2I_20@0|sim/cockpit2/annunciators/fuel_pressure_low
50001|2I_22@0|sim/cockpit2/annunciators/oil_temperature_high
50001|3F_24@0|sim/flightmodel2/gear/deploy_ratio
50001|3F_27@0|sim/flightmodel2/gear/deploy_ratio
;
50001|1I_00@1|sim/cockpit2/annunciators/master_warning
50001|1I_01@1|sim/cockpit2/annunciators/stall_warning
50001|1I_02@1|sim/cockpit2/annunciators/yaw_damper
50001|1I_03@1|sim/cockpit2/annunciators/pitot_heat
50001|1I-28@1|sim/cockpit2/annunciators/cabin_altitude_12500
50001|1I-05@1|sim/cockpit/warnings/annunciators/autopilot_disconnect
50001|1I-06@1|sim/cockpit/warnings/annunciators/autopilot_trim_down
50001|1I-07@1|sim/cockpit/warnings/annunciators/autopilot_trim_up
50001|1I-08@1|sim/cockpit2/annunciators/landing_taxi_lite
50001|1I-09@1|sim/cockpit2/annunciators/cabin_door_open
50001|2I-10@1|sim/cockpit2/annunciators/auto_feather_arm
50001|1I-12@1|sim/cockpit2/annunciators/low_voltage
50001|1I-14@1|sim/cockpit2/annunciators/hydraulic_pressure
50001|1I-15@1|sim/cockpit2/annunciators/speedbrake
50001|1I-16@1|sim/cockpit2/annunciators/GPWS
50001|1I-17@1|sim/cockpit2/annunciators/ice
50001|2I-18@1|sim/cockpit2/annunciators/fuel_pressure_low
50001|2I-20@1|sim/cockpit2/annunciators/oil_pressure_low
50001|1I-22@1|sim/cockpit2/annunciators/fuel_quantity
50001|2I-23@1|sim/cockpit/engine/fuel_pump_on
50001|1I-29@1|sim/cockpit2/annunciators/no_inverters
50001|1I_33@1|sim/cockpit/electrical/taxi_light_on
50001|1I-48@1|sim/cockpit2/ice/ice_window_heat_on
50001|1I-49@1|sim/cockpit2/ice/ice_surface_boot_on
50001|1I_50@1|sim/cockpit2/annunciators/flight_director
50001|1I-51@1|sim/cockpit2/annunciators/hvac
50001|1I-52@1|sim/cockpit2/ice/ice_prop_heat_on
50001|1I_53@1|sim/cockpit/electrical/landing_lights_on
50001|2I-54@1|sim/cockpit2/annunciators/generator_off
50001|2I-58@1|sim/cockpit2/annunciators/igniter_on
50001|1I-60@1|sim/cockpit2/annunciators/crossfeed_on
50001|2I-61@1|sim/cockpit2/annunciators/bleed_air_off
50001|1I-63@1|sim/cockpit2/ice/ice_inlet_heat_on

Share this post


Link to post
Share on other sites

I have noticed that you are sometimes using an underscore (_), sometimes a dash (-), they should all by underscores, but I don't know if this causes the problems.

Can you e-mail me both configuration files as an attachment to support@simplugins.com ? Just want to get the originals for debugging the issue.

 

Thanks

Share this post


Link to post
Share on other sites

I have tested both files (I just copied and pasted them from this post) and they both are running ok for me. No crashes, even with the dashes (instead of the underscores).


I've sent you a PM for downloading the software again.

Share this post


Link to post
Share on other sites

×
×
  • Create New...