Jump to content

Sign in to follow this  
Alec

HORRIBLE FSX performance with 780 Ti

Recommended Posts

Hey guys

 

So I bought a 780 Ti a while ago. It's a very powerful card, runs every game I have with easy! But FSX seems to be it's nemesis!! it runs SO bad this simulator, I think it runs worse than my GTX670 used to do!

 

I did a complete FSX Clean Install, when I Installed FTX Global, PMDG 777, some scenery, Mesh, and that's it. My fsx.cfg is using AffinityMask, BP=0, basically this. My Nvidia Inspector is set for 8xS and 2x sparse grid supersampling. I used to run my GTX670 like this before, I don't think this is too high for a GTX 780Ti!!!

 

PMDG 777 sitting at an airport I get like 8 Fps!!! What's wrong here???

 

Can somebody help? This is driving me crazy! I thought this card would make my FSX smooth, but it seems to have made it totally unflyable

 

Thank you

Share this post


Link to post
Share on other sites

Could you comment the BP ? Sometimes it does not work for all.  Maybe a small issue somewhere in NI. Does the bad performance issue occur on a particular scenery / aircraft ?

 

I see that you have XPX too, how is the performance on XPX ?

Share this post


Link to post
Share on other sites

I'll try the FSXMark 11 scenario so that I can compare my performance with others! I will let you guys know

Share this post


Link to post
Share on other sites

I would get rid of any tweaks to your fsx.cfg you added, better yet, delete your fsx.cfg and let FSX build a new one.

 

After the new fsx.cfg is built do not add any tweaks, only add the standard things that most people now consider should have been part of the fsx.cfg in the first place

"HIGHMEMFIX=1"

"DisablePreload=1"

"WideViewAspect=True"  only if you have a widescreen monitor

 

To start off you could also change your TML to 1024 if it is set to 4096 now.

"Texture_Max_Load=1024"

Share this post


Link to post
Share on other sites

Result of FSXMark 11, running like the doc suggested, but I have FTX Global installed

 

Frames, Time (ms), Min, Max, Avg
  1225,    300000,   2,   8, 4.083
 

4Fps average! Wow...

Share this post


Link to post
Share on other sites

Yeah... Even disabling AutoGen I get bad FPS. Something very serious is happening here...

Share this post


Link to post
Share on other sites

Try a different driver version - newer is not always better.

 

Cheers!

Luke

Share this post


Link to post
Share on other sites

In addition to letting FSX rebuild FSX.CFG from scratch, also delete the FSX shader cache that's located in a hidden folder at:

 

C:\Users\<user name>\AppData\Local\Microsoft\FSX\Shaders.

 

FSX will rebuild the cache. The shaders are compiled from source code (High Level Shading Language for DirectX or HLSL) into the binary files which are located in the cache. The compilation can be quite specific to each video card.

 

I would also suggest you run in DX10 mode, if you are not already doing so and that almost mandates purchasing DX10Fixer.

 

Finally, with that kind of GPU, you would be better off with DX11 and P3d2.

Share this post


Link to post
Share on other sites

There is hope here, I am running a GTX 780TI also and am getting 40-60 FPS all settings maxed out with FTX global, Vector, and REX 4 using the citation Mustang and no AI traffic. With UT2 settings at 70% for both airlines and GA IT drops to 25-30 and in Los Angeles it will drop to 25. I will attach my CFG to my next post when I get to my desktop.

Share this post


Link to post
Share on other sites

CFG. sorry so long

 

[VirtualCopilot]
VirtualCopilotActive=0
[sOUND]
AmbientUI=0
AmbientUIMusicVolume=-6.000000
PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_LOD=1
SOUND_QUALITY=2
UISound=1
VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND_FADER1=0.500000
SOUND_FADER2=0.500000
SOUND_FADER3=0.500000
SOUND_FADER4=1.000000
AmbientUIMusic=FSX01
[DISPLAY.Device.NVIDIA GeForce GTX 780 Ti.0]
Anisotropic=1
AntiAlias=1
Mode=1920x1080x32
[slewTextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
[AContain]
LabelColor=FFFF0000
LabelDelay=1000
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelAirspeed=0
ShowLabelAltitude=1
ShowLabelContainerId=0
ShowLabelDistance=1
ShowLabelFlightPlan=0
ShowLabelHeading=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabels=0
ShowUserLabel=0
[ATC]
AutoOpenAirTrafficWindow=1
COMM_MSG_AI_ATC_COLOR=FFFF7840
COMM_MSG_ATC_AI_COLOR=FF00FF00
COMM_MSG_ATC_USER_COLOR=FFB6FFB6
COMM_MSG_NONE_COLOR=FFFFFFFF
COMM_MSG_USER_ATC_COLOR=FFFFD21B
PilotVoice=0
ShowATCText=1
UsePilotVoice=1
[TextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
WindDirectionAndSpeed=1,6
[AccelerationPack]
ControlsFirstRun=0
HomePageFirstRun=0
[iNTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[CONTROLS]
Controls_Current=Standard
Controls_Default=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[FACILITIES]
CITY=
COUNTRY=
GTL_BUTTON=1244
STATE=
[TextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
FuelPercentage=2,4
GForce=2,3
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
WindDirectionAndSpeed=1,6
[PointOfInterestSystem]
CycleSetting=0
[GRAPHICS]
AC_SELF_SHADOW=1
AIRCRAFT_REFLECTIONS=1
AIRCRAFT_SHADOWS=0
ALLOW_SHADER_30=1
COCKPIT_HIGH_LOD=1
D3D10=0
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
HIGHMEMFIX=1
IMAGE_QUALITY=0
LANDING_LIGHTS=1
NUM_LIGHTS=8
See_Self=1
TEXTURE_MAX_LOAD=1024
TEXTURE_QUALITY=3
Text_Scroll=1
SHADER_CACHE_PRIMED_10=1693500672
SHADER_CACHE_PRIMED=1693500672
[TrafficManager]
AIRPORT_SCENERY_DENSITY=3
AirlineDensity=57
FreewayDensity=20
GADensity=62
IFROnly=0
LeisureBoatsDensity=40
ShipsAndFerriesDensity=40
[DynamicHeadMovement]
HeadMoveTimeConstant=1.000000
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
RollAccelOnHeadLat=0.010000
RollAccelOnHeadRoll=0.100000
YawAccelOnHeadLat=-0.100000
[REALISM]
AllowEngineDamage=False
AutoCoord=False
AutoTrim=False
CrashDetection=True
CrashTolerance=1.000000
CrashWithDyn=False
GEffect=True
General=1.000000
GyroDrift=True
GyroEffect=1.000000
ManualLights=True
PFactor=1.000000
RealMixture=True
StressDamage=True
Torque=1.000000
TrueAirspeed=False
UnlimitedFuel=False
[Weather]
AdjustForMagVarInDialog=1
CLOUD_COVERAGE_DENSITY=8
CLOUD_DRAW_DISTANCE=4
DETAILED_CLOUDS=1
DisableTurbulence=0
DownloadWindsAloft=0
DynamicWeather=0
MaxGustRampSpeed=200
MaxGustTime=500
MaxVarRampSpeed=75
MaxVarTime=50
MinGustRampSpeed=1
MinGustTime=10
MinVarRampSpeed=10
MinVarTime=5
THERMAL_VISUALS=0
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
WeatherServerAddress=fs2k.zone.com
WeatherServerPort=80
WindshieldPrecipitationEffects=1
[Misc]
Com_Rate=7
[Main]
HideMenuFullscreen=0
HideMenuNormal=1
Location=1172,44,1902,630,\\.\DISPLAY1
Maximized=1
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\UT2 Aircraft
User Objects=Airplane, Helicopter
ProcSpeed=7937
PerfBucket=7

[TextInfo.2]
FrameRate=1,1
FuelPercentage=1,4
GForce=1,3
LockedFrameRate=1,2
[uSERINTERFACE]
DisplayFuelAsWeight=1
Map_Orientation=2
OpenATCOnCreate=0
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
PageID=6
SHOW_MISSION_CAPTIONS=0
SITUATION=C:\Users\Chris\Downloads\Desktop\Documents\Flight Simulator X Files\Default
SelectAircraftManufacturer=All
SelectAircraftPublisher=All
SelectAircraftType=All
ShowAllACPaintSchemes=1
[bUFFERPOOLS]
PoolSize=5000000
RejectThreshold=131072
UsePools=0
[sIM]
SYSCLOCK=1
[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
BLOOM_EFFECTS=0
ChangeTime=4.000000
InfoBrakesEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=40
TextureMaxLoad=30
TransitionTime=4.000000
UPPER_FRAMERATE_LIMIT=0
WideViewAspect=True
[JOBSCHEDULER]
AffinityMask=14
[slewTextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
[PANELS]
DEFAULT_VIEW=0
IMAGE_QUALITY=1
PANEL_MASKING=1
PANEL_OPACITY=100
PANEL_STRETCHING=1
QUICKTIPS=0
UNITS_OF_MEASURE=0
[sTARTUP]
DEMO=0
LoadWindow=1
SHOW_OPENING_SCREEN=1
STARTUP_DEMO=0
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[TERRAIN]
AUTOGEN_DENSITY=5
DETAIL_TEXTURE=1
LOD_RADIUS=4.500000
MESH_COMPLEXITY=100
MESH_RESOLUTION=25
SWAP_WAIT_TIMEOUT=2
TEXTURE_RESOLUTION=29
WATER_EFFECTS=5
[sCENERY]
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=5
LENSFLARE=1
MAX_ASYNC_BATCHING_JOBS=3
SmallPartRejectRadius=4.0
[FlightPlanMap]
LineWidth=2
SHOW_AIRPORTS=1
SHOW_AIRSPACE=1
SHOW_APPROACHES=1
SHOW_DATATAGS=1
SHOW_FLIGHTPLAN=1
SHOW_INTERSECTIONS=1
SHOW_JET=0
SHOW_NDBS=1
SHOW_TERRAIN=1
SHOW_VICTOR=0
SHOW_VORS=1
SHOW_WEATHERSTATIONS=1
SHOW_WEATHERSYSTEMS=1
show_ac_twr=1
show_airways=1
show_markers=1
show_volume_boundaries=1
show_waypoints=1
[MULTIPLAYER]
condAccoutPassword=0
VoiceVolume=2.000000
 

Share this post


Link to post
Share on other sites

Try a different driver version - newer is not always better.

 

Cheers!

Luke

 

Not the greatest advice on a newly released card like this - older driver versions likely don't even support it.

 

I had a similar issue happen when I moved from a GTX 260 to a 570. Performance was terrible in FSX. I reformatted and it was a night and day difference. I know that's a pain to do but I've seen it first hand - changing the card can cause weird stuff to happen in Windows. I always reformat when I make any major hardware changes as a result now.

Share this post


Link to post
Share on other sites

Not the greatest advice on a newly released card like this - older driver versions likely don't even support it.

 

 

It's not hard - you can go to nvidia's site and do a manual driver search. They'll tell you exactly what driver versions support your card.

 

I had a problem with my GTX 560 where the 331 series killed my frame rates. Going back to (I think) the 302s solved it, then when I got my GTX 760 the 331s worked fine.

 

Cheers!

Luke

Share this post


Link to post
Share on other sites

I just upgraded from an amd 7770 to a GTX 760. All I did was delete the shader folder, ran my cfg file through http://www.venetubo.com/fsx.html and I'm getting great performance. I'm using bp=0 instead of rejected threshold. I'm using DX10 which is set to 8xcs and ni set to 4x sparse grid ss.

Share this post


Link to post
Share on other sites

I'd add that I get excellent performance from my 780 Ti. Well, I should say that I have about as good as I could expect, considering that with this card, FSX is completely CPU limited, in my opinion (I only mildly overclock).  It was however, a notable improvement.

 

I moved from an ATI card, so not wanting to reformat, I extensively cleaned all traces of old drivers from both the hard drive and the registry.  I also had to use some of my backed up default shader files, since I had previously modded my shaders to get decent performance in clouds. Seemed to work for me.

 

In P3Dv2, I get very good performance indeed, on par with what I'd expect from this card when turning on all the eye candy that actually loads the card up.

Share this post


Link to post
Share on other sites

There is hope here, I am running a GTX 780TI also and am getting 40-60 FPS all settings maxed out with FTX global, Vector, and REX 4 using the citation Mustang and no AI traffic. With UT2 settings at 70% for both airlines and GA IT drops to 25-30 and in Los Angeles it will drop to 25. I will attach my CFG to my next post when I get to my desktop.

Noticed in your BUFFERPOOLS section you also added USEPOOLS=0 , doesn't this turn pools off so you are infact running with BP=0

Share this post


Link to post
Share on other sites

Noticed in your BUFFERPOOLS section you also added USEPOOLS=0 , doesn't this turn pools off so you are infact running with BP=0

Ya so I was reading kostas guide on tweaking your configuration file and he said usepools=0 and BP=0 actually both accomplish the same thing from my understanding.

Share this post


Link to post
Share on other sites

I switched from a gtx570 to a 780Ti about a month ago, and with no changes to anything I got noticeably better performance in FSX. I get 40-60fps even in dense scenery areas. Hang in there, you will find the issue that is causing the lousy fps eventually.

Share this post


Link to post
Share on other sites

Ya so I was reading kostas guide on tweaking your configuration file and he said usepools=0 and BP=0 actually both accomplish the same thing from my understanding.

Thats right you can use the command as a switch to turn bufferpools on or off.

I suppose the idea is whilst testing with different bufferpool sizes you can use the switch to do this and it saves time in editing the cfg file.

Share this post


Link to post
Share on other sites

Thanks for the suggestions guys!

 

As Tabs said, with such a newer card, it's hard for me to go back on older drivers, specially since I have many games that depends on the improvement these newer drivers bring,  it's really night and day difference for some games!

 

I have come to the conclusion maybe it doesn't have to do with FSX. I'm now trying DX10 mode, and the FPS is better. But it's not even close to the 40-60 fps some of you with the 780 Ti are reporting. Running the FSXMark11 test with FTX Global and Autogen Very Dense I get around 15fps. My CPU is OCed to 4.4Ghz, so that's not the issue.

 

The only difference is that I now have a Single Channel 8GB DDR3 memory instead of a Dual Channel 2X4GB, but I don't think it would bring the system to it's knees like this. I read all the time the difference is lower than 5% in games.

 

Unfortunately I'm a little low on cash right now, so buying the DX10 Fixer is not a great thing to do to my wallet, but I'm very curious to check it if does improve FPS from the default DX10 FSX mode.

 

And I did a system reinstall after I got this card! It runs Assassins Creed 4 well, which is a VERY heavy game.

 

I will let you know if I reach a conclusion!

Share this post


Link to post
Share on other sites

Not the greatest advice on a newly released card like this - older driver versions likely don't even support it.

 

I had a similar issue happen when I moved from a GTX 260 to a 570. Performance was terrible in FSX. I reformatted and it was a night and day difference. I know that's a pain to do but I've seen it first hand - changing the card can cause weird stuff to happen in Windows. I always reformat when I make any major hardware changes as a result now.

 

 

 

+1 to this , Windows can really screw things up installing a new card. Formatting is the best way

 

 

PMDG777+ Flytampa Dubai i have 45-65fps sitting with engine running in gate

 

FSDT-KLAX Gate 30 =40-50fps 

 

 

Michael

Share this post


Link to post
Share on other sites

I don't doubt that reformatting may have profound effects generally in Windows, but that seems extreme at best. Try clearing out all Nvidia drivers using Driver Sweeper, and follow Nick N's guide to the T in regards to clean installing new drivers.

Share this post


Link to post
Share on other sites

 

 


Try clearing out all Nvidia drivers using Driver Sweeper,

 

X2

I'm betting this will clear up the issue. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...