Jump to content
Sign in to follow this  
Guest

P3DV2.1 stutter or no stutter

P3DV2.1 Stutters Yes or No  

247 members have voted

  1. 1. Are you getting stutters in P3DV2.1?

  2. 2. What OS are you running?

  3. 3. Do you use controllers (yokes, joysticks, rudders)?



Recommended Posts

Guest

I should have been more specific, you'll have to use settings (or an airport/scenery area) that will allow for a frame rate higher than the refresh rate of your display, which I assume is 60Hz so you'll need to obtain frame rates higher than 60 fps.

 

Oh I see, well my problem with that is I'm just not interested (visually) in what P3DV2.x offers at 60 fps or higher.  Are you just wanting to know if the V-sync is the Adaptive type?

 

 

WOW!  You could go bonkers reading everything in this thread...lol.

 

I don't know about others, but bonkers definitely fits me well  :lol:

Edited by Guest

Share this post


Link to post

Oh I see, well my problem with that is I'm just not interested (visually) in what P3DV2.x offers at 60 fps or higher. Are you just wanting to know if the V-sync is the Adaptive type?

 

 

 

 

If you set the frame rate to unlimited and you are able to get over 60+ fps, when v-sync enabled it will keep the frame rate from going higher than the refresh rate (60Hz/60 fps). It's a test to see if v-sync is really enabled or not.

 

I just got done with a fresh install of Windows 7/SP1 64 and just like I've seen with Windows 8.1 when I exit out of the sim with v-sync enabled, it's not working when restarting Prepar3D. The frame rates are showing over 120 fps when I start a new flight, going back into the graphic settings and then exiting re-enables v-sync and the frame rate display doesn't go above 60 fps.

 

 

At this point I suspect many users who claim they are seeing stuttering aren't even running the sim with v-sync enabled which because of frame rate fluctuations will produce stuttering.

Edited by nyc01

Share this post


Link to post
Guest

Does the number of cascades control the quality of shadows?

 

Not the quality of the edges, if that's what you mean. Afaik it has to do with the amount of shadows you see. Somehow. Here's a copy and paste from the Learning center. I think it means that higher numbers shows MORE shadows.

 

"A cascade is a small area that encompasses the field in the player's view. This value can be between 2 and 12. At a value of 2 cascade, one cascade displays detailed shadows close up, and the rest of the shadows are encompassed in the second, so they are less detailed further away from the view origin. On the other hand, the more cascade that are added, the more detailed the shadows have to distribute across the player's view. Twelve cascade gives the highest ability to create detailed shadows at farther distances."

 

It's cleary anyway that cascades are what's hurting performance at higher levels: I don't see much difference in performance with the shadow distance at higher numbers and the other shadow option (Log Partition) is equal at all settings by default.

Edited by J van E

Share this post


Link to post

Agree, increased realism is never free ... in many ways.

 

If I were doing something more than GA/commercial type flying, the fluidity would be more important to me ... but for relatively slow speed slow maneuvers I can live with these stutters.  LM are taking a looking at these issues seriously.

 

I keep 3 sets of P3DV2.x on my computer, virgin P3DV2.0, virgin P3DV2.1, and P3DV2.1 add-on equipped set -- it's relatively easy to swap them in/out ... Just have to remember that if I ever do another uninstall, I have to make sure I have my P3DV2.1 set "active".

 

Rob.. how are you switching between versions on the fly.. for now I have a "virgin" folder, then a fully installed 2.0 and one for 2.1, all with different names and I just rename them in windows explorer to make the swap.. a little tedious but effective.. curious how you are getting it done?


MSI z690-a Unify; 1000 watt evga SuperNova Platinum; 12900kf at 1.255 adaptive LLC6, auto avx, auto Pcore, E-4.0ghz, Ring-4.1ghz, PL 241watt (Cine96c, games 83c case side On); DDR5 Gskill F5-6400J3239G16GA2-TZ5RS  at 6400mhz autovolt, Kraken x73 360mm; Thermaltake v51 Case; Gigabyte 4090 OC;  VR-Varjo Aero;  AstronomicallySpeaking:

Share this post


Link to post
Guest

Rob.. how are you switching between versions on the fly

 

To be clear, I don't switch while flying - so not really "on the fly". 

 

I wrote a small program I call FS Manager that will do the switching for me.  There are a lot of registry entries (some more important than others), but as far as I can tell I should be fine with same path and making sure if I ever do uninstall, it's done from my last "installed" version.

 

I also use a program called SysTracer (on v2.8) to do snapshots of specific directories used by P3D and specific registry entries (key ones) used by P3D.  Also use another product called UltraCompare if I want to get down and dirty and look into actual bits and bytes of file changes.

 

I keep the version sets on an external drive and actually copy them back and forth, but a rename would be just as effective if you have them all on the same drive.

Edited by Guest

Share this post


Link to post

I reran my tests, both in fully installed v2 and v2.1 folders.

 

The good ole fsmark07 flight came in like this:

 

v2.1:  36.40 with massive stuttering after around the 48 second mark (point at which plane is banking with ground in sight).. doesnt stutter the whole time but in spurts, also blurry textures with about a 3 second lag if you hit pause

 

v2.0:  38.44 with minimal stuttering at the same 48 second or so spot, no real blurry textures.. snappy loading (even with this test flight)

 

In v2.1 i've swapped out the autogen folder as well (no real help though).

v2.0 for me has spotty stuttering whereas 2.1 has more and slightly lower frames.

 

I've tried every tweak in the book at this point, nothing has really cured the bigger stutters or the blurries with 2.1 for me.  V2.1 is certainly "useable" under most situations though and looks great though some flickering cars and objects at the airports.

 

In comparing these two.. everything was held equal.. ie: the NI profile, the cfg files etc.


I reran my tests, both in fully installed v2 and v2.1 folders.

 

The good ole fsmark07 flight came in like this:

 

v2.1:  36.40 with massive stuttering after around the 48 second mark (point at which plane is banking with ground in sight).. doesnt stutter the whole time but in spurts, also blurry textures with about a 3 second lag if you hit pause

 

v2.0:  38.44 with minimal stuttering at the same 48 second or so spot, no real blurry textures.. snappy loading (even with this test flight)

 

In v2.1 i've swapped out the autogen folder as well (no real help though).

v2.0 for me has spotty stuttering whereas 2.1 has more and slightly lower frames.

 

I've tried every tweak in the book at this point, nothing has really cured the bigger stutters or the blurries with 2.1 for me.  V2.1 is certainly "useable" under most situations though and looks great though some flickering cars and objects at the airports.

 

In comparing these two.. everything was held equal.. ie: the NI profile, the cfg files etc.

 

Wanted to share my current settings.. i've tried various vsyncs all with no real difference whether on off or set differently too as well:

 

[

 

settings1.jpg

settings2.jpg

settings3.jpg

settings4.jpg

settings5.jpg

ni1.jpg

 

Some things I have in my prepar3d.cfg as well 

[bUFFERPOOLS]
usepools=0
TEXTURE_BANDWIDTH_MULT=400
UPPER_FRAMERATE_LIMIT=0 (as per image)
TEXTURE_MAX_LOAD=2048 (as in image)
 
//tweaked
SHADOW_DRAW_DISTANCE_LOW=12000
SHADOW_DRAW_DISTANCE_MID=12000
SHADOW_DRAW_DISTANCE_HIGH=12000
SHADOW_DRAW_DISTANCE_ULTRA=12000
[JOBSCHEDULER]
AffinityMask=1364
LOD_RADIUS=6.500000

FIBER_FRAME_TIME_FRACTION=0.22

 

Trying without AM made no different for stutters or blurries in my i7 12 core cpu.. playing with FTF made no difference either.. again the issue with blurries seems to be 2.1 based in my case.

 

 

 

 

Edited by theskyisthelimit

MSI z690-a Unify; 1000 watt evga SuperNova Platinum; 12900kf at 1.255 adaptive LLC6, auto avx, auto Pcore, E-4.0ghz, Ring-4.1ghz, PL 241watt (Cine96c, games 83c case side On); DDR5 Gskill F5-6400J3239G16GA2-TZ5RS  at 6400mhz autovolt, Kraken x73 360mm; Thermaltake v51 Case; Gigabyte 4090 OC;  VR-Varjo Aero;  AstronomicallySpeaking:

Share this post


Link to post
Guest

On a positive note, had a nice flight last night in V2.1 ... stutters were minimal and fraps locked at 30 didn't drop below (range was 33-50 fps).

 

 

So I think overall I've made progress:

P3D.CFG

FIBER_FRAME_TIME_FRACTION=0.10

AffinityMask=1364

 

Here display settings here: http://www.robainscough.com/Prepar3D_Settings_2.html

 

Cheers, Rob.

Share this post


Link to post

On a positive note, had a nice flight last night in V2.1 ... stutters were minimal and fraps locked at 30 didn't drop below (range was 33-50 fps).

 

Does the A2A C172 work without issues for you? I'm hearing about lots of problems with after 2.1.

Share this post


Link to post
Guest

 

 


Does the A2A C172 work without issues for you? I'm hearing about lots of problems with after 2.1.

 

Out of all the 3rd party Aircraft I own, it's actually working out to be the most compatible.  I did report a problem I was having that seems to have been OE (operator error)  :blush:

 

It's relatively slow speed also does wondering for allowing the terrain engine to keep up.

 

But not many clouds in my flight ... clouds and SGSS don't appear to mix well, FXAA works much better with clouds in terms of performance ... or just fly clear, clean, and naked.  Funny thing is, I thought LM specifically disabled AA for cloud processing?  Maybe the NI "enchance driver setttings" is the cause for clouds performance ... have to look into this more.  I know the ground debris effect (blowing of snow in front of the aircraft) will bring my system to it's knees, think 2-3 fps until it clears then back up to 50 fps.

Share this post


Link to post

But not many clouds in my flight ... clouds and SGSS don't appear to mix well, FXAA works much better with clouds in terms of performance ... or just fly clear, clean, and naked.  Funny thing is, I thought LM specifically disabled AA for cloud processing?  Maybe the NI "enchance driver setttings" is the cause for clouds performance ... have to look into this more.  I know the ground debris effect (blowing of snow in front of the aircraft) will bring my system to it's knees, think 2-3 fps until it clears then back up to 50 fps.

 

FXAA is a post-processing AA mode that just blurs pixels when it detects a significant colour difference, no wonder it works well because it's extremely easy on performance.

 

As for particle effects killing performance, I don't think that's any different from FSX. Especially when the snow or debris blowing from the ground fills my entire screen, it goes below 1 FPS.

Share this post


Link to post
Guest

 

 


Maybe the NI "enchance driver setttings" is the cause for clouds performance ...

 

I am sure it is. At least, that's clearly the case on my PC. Without NI enhancements (and crappy AA in P3D ^_^ ) performance is great, clouds or no clouds: I really don't notice a difference. But with NI's enhancements (and great AA!) performance is ok (though overall lower than without those settings) but when I fly into clouds, performance very obviously drops. Those NI settings don't play well at ALL with clouds. It's one of the reasons why I usually fly with only some high cirrus. ^_^ Other reasons are that I don't feel like buying REX4 for cloud textures only AND I am not too happy with the rotating clouds 'feature'. I am sure though that one day I'll be sick and tired of flying with a blue sky but maybe by then we'll have another patch or another PC. :P

Share this post


Link to post
Guest

 

 


I am sure though that one day I'll be sick and tired of flying with a blue sky but maybe by then we'll have another patch or another PC.

 

Wait until they release clouds casting shadows and sunlight rays ... I hope they have SLi or Tri-SLi or Quad-SLi utilization by then - we're gonna need it.

Share this post


Link to post
Guest Novation

I reinstalled P3Dv2.1 yesterday... totally clean, no add-ons and its jumping around like lunatic - stutter - hick-up - jump - hitch. I didn't have this with my patched, add-on filled previous install. I swear this bloody program is possessed [maybe those rotating clouds are a sign, like the head of the demonic child in The Exorcist] .... maybe we should call a priest :lol:

 

I dumped any NI profile for P3D long ago... its amazing with FSX but I can't get it to play nice with v2x at all.

 

I'm going to leave P3D alone until the hotfixes appear.... I simply can't stand any more mucking about :(

Share this post


Link to post
Guest

 

 


I simply can't stand any more mucking about

 

Don't you mean 'fannying about' ?

 

 

A classic!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...