Sign in to follow this  
Noel

Saitek Cessna Trim wheel requires me to unplug/replug in w/ every boot ;o(

Recommended Posts

I'm stumped.  I bought it, and experienced this first thing.  So I tried connecting it to a different PC--same outcome.  So I ordered a replacement--same outcome.   So apparently I'm doing something wrong as I don't find comment about this anywhere in my web search.  I chose not to install the Smart Technology software (I think it's called) as I've seen some comments that no drivers are required.  And indeed-it works perfectly...as long as I pull the USB connector out, and put it back in.  Doesn't matter which of the 3 different USB ports I've tried this in either.  FWIW, I have FSUIPC installed, and have had the boxes relating to disconnecting the elevator trim when the A/P is on both checked and unchecked but to no avail.

 

Thoughts?  Thanks in advance--I really like this thing but don't know how to keep it connected!!  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this