Jump to content

Sign in to follow this  
Noel

Major FPS problem

Recommended Posts

My system is as follows:Intel P4 3.2GHz CPU1.25GB DDR RAMATI Radeon X800XT Platinum 256MBAs far as I can tell, this is a pretty good system (it cost enough to upgrade after all!), and should run FS extreamly well.However, I seem to have a problem somewhere.Using the default 737 at the default KJFK, with all the settings set to "ultra high", i only get about 20 fps around the terminal buildings. I was expecting to get quite a bit higher than that, considering the CPU and card cost over


Phil Brown

Share this post


Link to post
Share on other sites

Hi Phil, what kind of mainboard do you have? I know my board requires equal number of DDR dimms to allow it to run in Dual Channel mode, so 1.25GB on my particular board would reduce FSB bandwith in half, so I run 2 x 512MB dimms for 1GB total. You should def be getting much better perf than what you are getting. There are a host of potential problems, besides the mem issue, that could be the problem(s).Noel


Noel

System:  9900K@4.8Ghz Noctua NH-D15S, 32Gb 3200mHz DDR4, NVme 2Tb x 2, GTX Titan w/ latest WHQL, Win10 Pro, 3440x1440

 

Share this post


Link to post
Share on other sites
Guest firehawk44

I have to reply since I have the same video card. Something must be seriously wrong as I get between 17-30 FPS using the PMDG 737 and the Simflyers KJFK. I have all sliders set to max except Autogen which is set around 70%. Clouds are maxed out too. What I found to get better FPS is turning off vertical sync on your card. I have AA set at 6x and AF set at 16x at the Display settings. For me, turning off vertical sync was like going from night to day. Just awesome. The second thing I would look at is your display drivers. It seems that whenever I upgrade my ATI drivers to the latest version, I get a lot of stuttering and my FPS drastically drop until FS9 "sees" the changes to my video drivers (usually after starting FS9 a couple of times and turning off and restarting my system a couple of times). Even though my drivers appear to be properly installed with no problems, I have, on occasion manually installed the drivers (i.e., going into Device Manager, opening the properties for my video card, and updating the drivers. I point to the location where the ATI drivers are located on my hard drive). Everytime I do this, the wizard goes through the install procedure and doesn't come back telling me I have the latest drivers already installed. After I do this, FS9 appears to wake up dramatically and I have great FPS. I normally get 49 FPS flying from Simflyer's KLAX to FlyTampa's KSFO. So you should expect much higher FPS with your system. I hope this helps you. Good luck!Jim

Share this post


Link to post
Share on other sites

I tested my system with PC Pitstop, and it concluded that I have unusally low disk speeds. My hard drive disk speed is about 17 MBs per second, compared to 47MB/sec on systems similar to mine. I'm wondering if it could be due to this? It's one of the few things yet to be changed in my system.-Phil


Phil Brown

Share this post


Link to post
Share on other sites

Whatever is causing your framerate impact... disk drive speed is not going to be it. If you had pauses loading scenery etc, a fast disk drive might help, but frame rates are determined by the interplay of your processor, motherboard, memory, and video card.


Bert

Share this post


Link to post
Share on other sites

Hi, I have the X-800 Pro, should have waited for the XT, but I was wondering, where can I find the Vertical sync option in the catalyst control panel?Thanks in advance,Jeff USAF


Jeff

Commercial | Instrument | Multi-Engine Land

Share this post


Link to post
Share on other sites
Guest firehawk44

Hi Jeff,I don't have the CCC installed at this time but had it installed on previous occasions. If I remember right it's where it states view all options then go down to wait for vertical sync and switch it to Always Off. I believe the CCC has a help button too and you can search for vertical sync. Turning it off (not the default) really increased the FPS for me.Jim

Share this post


Link to post
Share on other sites

Thanks for your reply. Unfortunately there is no vertical sync option, I even did a search for it and all i got was a monitor adjustment page where you could change the vertical position of the monitor. Can I ask what drivers you are using. Also, I used powerstrip to disable V-sync so hopefully that will do the trick, but i'd rather use my ati control panel to disable it.Jeff USAF


Jeff

Commercial | Instrument | Multi-Engine Land

Share this post


Link to post
Share on other sites

Turned off vertical sync, but frame rates are still crappy. I'm resigned to the fact that I have a major problem somewhere, just a case of nailing it down.Thanks for all the help though.For Jeff, the vertical sync is listed as "Wait for display refresh". On the Catalyst Control Panel, go to the 'No Preview' bit on the left hand side, and then scroll down on the bottom half of the main screen (I missed the scroll button when I first looked).-Phil


Phil Brown

Share this post


Link to post
Share on other sites

Yeah I just figured it out, thanks. Also, I turned mine off and have gained a noticable amount of FPS. Have you tried any power tools, like Powerstrip, you can ultra edit your settings, a lot of people on these forums suggest you turn your PCI latency down and you will be amazed, I did, but I don't know how much of a difference it made, but I will keepp my PCI latency at 64 regardless. Also, I would try turning your target frame rate to unlimited and then fly around and hit shift Z to check your frames, I've been doing that and have gotten 99 fps, I was shocked, I never get less than 20 unless I'm using my simflyers scenery.I too have had problems getting a good frame rate, but with all the posts on the forums concerning the subject, I have been able to improve significantly. I'm running a P4 2.8 800 FSB 1 gig DDR and the x-800 pro 256 megs. (not overclocked).Jeff USAF


Jeff

Commercial | Instrument | Multi-Engine Land

Share this post


Link to post
Share on other sites
Guest firehawk44

I'm glad to see you gained some FPS by turning off vertical sync. It definitely has a major impact to gamers. This tweak guide may be of interest to you (and others) in regard to the latest ATI drivers: http://www.tweakguides.com/ATICAT_1.html. Page 6, I believe has a nice blurb/explanation on vertical sync and the troubleshooting section talks about fixes for "Stuttering/Intermittently Freezing Graphics". It's an excellent guide and updated as soon as new ATI drivers are released.Jim

Share this post


Link to post
Share on other sites

No Phil, it's not your drive, IMO.


Noel

System:  9900K@4.8Ghz Noctua NH-D15S, 32Gb 3200mHz DDR4, NVme 2Tb x 2, GTX Titan w/ latest WHQL, Win10 Pro, 3440x1440

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    10%
    $2,630.00 of $25,000.00 Donate Now
×
×
  • Create New...