Jump to content
Sign in to follow this  

P3D 2.2 CTD Unless Starting As Administrator

Recommended Posts

I was using P3D 2.2 latest version over the past few days - including today - without issue, and just exited P3D after completing a flight. I have not installed any addons since Sunday Morning.


Current addons are Airbusx, GSX, various FSDT Sceneries, ASNEXT, Megascenery Earth, FSUIPC 4.929, all installed and tested without incident Saturday and Sunday.


Starting a few minutes ago - Upon restart of P3D, I get immediate CTD during initialization.


I decided to then try loading P3D as an administrator, and it started without incident. I never had to start it as an administrator before.


Now, it CTDs every time I start it, unless I start it as an administrator.


I even tried this after applying the latest hot fix - same results.


RESOLVED: ASNext needs to update two files in C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\as_srv

1) btstrp.txt

2) log.txt


I updated user permissions to allow updates to C:\Program Files (x86)\Lockheed Martin\ and all sub-directories.






Michael DelFranco



Log Name:      Application
Source:        Application Error
Date:          4/15/2014 1:39:14 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MDF-XPS-L702X
Faulting application name: Prepar3D.exe, version: 2.2.10438.0, time stamp: 0x53468776
Faulting module name: ntdll.dll, version: 6.1.7601.18247, time stamp: 0x521ea8e7
Exception code: 0xc0000005
Fault offset: 0x000222d2
Faulting process id: 0x21c0
Faulting application start time: 0x01cf586cfe8c2e23
Faulting application path: C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Prepar3D.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: 4712c81f-c460-11e3-a0db-88532e1c5a83
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2014-04-15T05:39:14.000000000Z" />
    <Security />
    <Data>C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Prepar3D.exe</Data>

Share this post

Link to post

Faulting module path: C:\Windows\SysWOW64\ntdll.dll


NTDLL.dll – Several possibilities as follows:

Heap metadata can become corrupted and it has been identified by Microsoft as one of the most common causes of application failures. When an application crash shows the faulting module as ntdll.dll along with the Memory Access Violation (0xc0000005), then Windows places the application on a watch list and, if the application crashes at least four times or more in an hour, the fault tolerant heap service will configure the application to use the fault tolerant heap service in the future (Source - Chapter 10, Memory Management, Windows Internals, Part 2: Covering Windows Server 2008 R2 and Windows 7 by Mark E. Russinovich, David A Solomon, and Alex Ionescu). The service is part of the Security Center service so you need to make sure this service is turned on.
You might get an NTDLL.dll shown as the faulting module if you have MyTrafficX 5.4c installed. It is believed to be caused by an AI scheduling programming error. A fix was being worked on.
An NTDLL.dll crash can also occur if your system overheats or you have wrong voltages set for your installed RAM or CPU but this is less likely as you will most likely get a BSOD instead of a CTD.
Removing the UIAutomationcore.dll from the main FSX folder will also fix NTDLL.dll CTD’s for many.
Check your dll.xml for duplicate entries or any corruption. Some have fixed the NTDLL.dll CTD by removing duplicate entries and/or old software entries where the software is no longer on your system.
Taken from the AVSIM CTD Guide. 

David Graham, Network+, Cisco CSE, Cisco Unity Support Specialist, A+, CCNA


Share this post

Link to post

I am using P3D - not FSX. 


I just isolated this problem by disabling the following in dll.xml - it is for Active Sky Next for P3D V2,2 - which has been working fine until now.




Information from ASNext web site documents requirement to either run P3D as administrator, or, change ownership or permissions to update the C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\as_srv directory.


There are two files in this directory which need to be updated during execution:

1) btstrp.txt

2) log.txt


I updated permissions and re-enabled the entry in dll.xml - no more CTD - and it doesn't require being run as admin.

Share this post

Link to post

I am aware. P3D is built on the FSX platform. Still applies. As you have found out. Since it was is in you DLL.xml 

David Graham, Network+, Cisco CSE, Cisco Unity Support Specialist, A+, CCNA


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.

    $13,405.00 of $25,000.00 Donate Now
  • Create New...