Jump to content

Sign in to follow this  
Guest baksteen33

FS2004 Stuttering Even With High Frame Rates

Recommended Posts

Guest yuma

Is "stuttering" (frame randomly freezes for second or two) in FS2004 related to frame rates? I consistantly get frames rates of 40fps and above, sometimes 70fps to 80 fps, but I still get stuttering. I don't think I can get any higher frame rates. Anyone have any suggestions how else the stuttering can be eliminated?

Share this post


Link to post
Share on other sites
Guest gasebah

Try to limit your framerates to 40 or 30. I saw this happen with some airarft and real fast graphics cards. Also you can try to set your video cards latency to a lower value. It is possible that the cad hogs the PCI bus. Do a search at the hardware forum for latencycfg.Alex

Share this post


Link to post
Share on other sites

Depends on what you mean by stuttering. If you are getting random freezes for 1-2 seconds this DOES NOT have to do with frame lock or frame rates (unless your FPS is 1/sec or worse). Most likely you have another process demanding your CPU's attention, such as loading of weather with one of the Addon weather programs such as ActiveSky. You can get brief pauses when weather updates. You may also get this when .wav files load if they are large and your file system is slow and/or badly fragmented. Or, you could have some other program running such as AV software or something which grabs the CPU for a brief period. If you are having steady "pause and release" behavior, as in when you look at the scenery outside it seems to stick very briefly then "catch up" rhythmically--this can be related to NOT having your frames locked to a lower rate specifically. This is my educated guess about your freezes.How many processes running in the background? Noel


Noel

Share this post


Link to post
Share on other sites
Guest tdragger

I agree. If you're running with unlimited frame rate then you're just asking for stutters as the CPU will inevitably get choked if it's trying to run the sim and keep the GPU filled. Try setting target frame rate to something like 35 or 40 and see what happens.

Share this post


Link to post
Share on other sites

Higher framerates do not seem improve performance much in fs9 once you get to higher numbers (30+) At least on my system. . I tried experimenting with unlimited frames, and even though I was getting on average of 40+fps, things were no smoother. There were still small stutters. Not sure why exactly. One thing that helps reduce my stuttering is turning off AI traffic completely. Even in cruise this helps it somewhat.


-------------------------

Craig from KBUF

 

Intel Core 2 Quad Q9650 3.0 ghz

4gb RAM

Windows 7 64-bit

Nvidia GTX 275 896mb

Share this post


Link to post
Share on other sites
Guest yuma

First, thank you, and all the others who replied to my message and offered suggestions. I REALLY appreciate your suggestions.I reduced my frame rates from Unlimited to 30, but that didn't seem to help. The problem still occurs. I test for the problem by setting up an aircraft on autopilot, straight and level flight. Then I use spot view to rotate the image continuously around the aircraft. Aproximately every 2 360 degree rotations, the frame will freeze for about one half to three seconds, and then continue. I also go to virtual cockpit and rotate the view from inside the aircraft. Same thing happens. One thing I have noticed is that the freezing seems to happen more often and for longer times when the view I am scanning includes both sky and ground. If the view inculdes only ground, or only sky, it seems to perform better. No idea why.Some other information:Computer: Dell Dimension 8400, 3.4 GHz, 1 GB RAM, Windows XP Professional Sp 2, DirectX 9.0c, Dell 1901FP flat panel display (70 Hz refresh rate, 1280 X 768 resolution, 32 Bit color), Creative Audigy 2 sound card, ATI Radeon X700 PRO PCIe video card with 256 MB memory, latest driver (I use ATI Catalyst software to automatically configure the card for performance/quaility. I currently have it set to maximize quality because setting it to maximize performance doesn't solve the frame freezing problem.)I use FSAutoStart to start FS2004, defragment the memory, and close all processes and programs except for the following:Processes: ATI Hotkey Poller DCOM Server Process Launcher DHCP Client DNS Client Event Log IAA Event Monitor MSSQL$MICROSOFTBCM Network Connections Plug and Play Print Spooler Protected Storage Remote Access Connection Manager Remote Procedure Call (RPC) SAVSCAN Security Accounts Manager System Restore Service Telephony Terminal Services Windows Audio Windows Firewall/Internet Connection Sharing Wireless Zero Configuration Work Station Programs: ASMon.exe CLI.exe explorer.exe firefox.exe IAAnotif.exeFS2004 settings: Everything maxed out (I do this because adjusting the settings at lesser values doesn't eliminate the frame freezing problem)except for the following: Scenery Land Only (No water effect) AutoGen Very Dense Weather Sight Distance 60 mi. Cloud Distance 30 mi. 3-D clound percentage 10 Cloud Density Medium Hardware Anti-Aliasing Unchecked (controlled by video card) Bilinear Filtering MIP Mapping 4 Hardware Rendered Lights 8 Global Max Texture Size Massive Again, if anyone has any ideas how to solve the frame freezing problem, I greatly appreciate your help. I would think that with my particular computer configuration, I shouldn't have any problems running FS2004, but, obvioulsy, I do.

Share this post


Link to post
Share on other sites
Guest papatango

I had exactly the same problem, a 1-2 second stutter every few seconds when I continually rotated the camera around the plane in the outside view.The solution for me was to set the Global Max Texture Size on the hardware tab to High, instead of Massive. This reduces the stutters greatly for me doing the same above test, and I see no visual difference.Also, did you download Airport Environment Upgrade 7.0? This has some pretty large textures, and some users were reporting stutters, which I assume were due to the loading of the textures.Scott

Share this post


Link to post
Share on other sites

>First, thank you, and all the others who replied to my>message and offered suggestions. I REALLY appreciate your>suggestions.>>I reduced my frame rates from Unlimited to 30, but that didn't>seem to help. The problem still occurs. I test for the>problem by setting up an aircraft on autopilot, straight and>level flight. Then I use spot view to rotate the image>continuously around the aircraft. Aproximately every 2 360>degree rotations, the frame will freeze for about one half to>three seconds, and then continue. I also go to virtual>cockpit and rotate the view from inside the aircraft. Same>thing happens. One thing I have noticed is that the freezing>seems to happen more often and for longer times when the view>I am scanning includes both sky and ground. If the view>inculdes only ground, or only sky, it seems to perform better.> No idea why.>>Some other information:>>Computer: Dell Dimension 8400, 3.4 GHz, 1 GB RAM, Windows XP>Professional Sp 2, DirectX 9.0c, Dell 1901FP flat panel>display (70 Hz refresh rate, 1280 X 768 resolution, 32 Bit>color), Creative Audigy 2 sound card, ATI Radeon X700 PRO PCIe>video card with 256 MB memory, latest driver (I use ATI>Catalyst software to automatically configure the card for>performance/quaility. I currently have it set to maximize>quality because setting it to maximize performance doesn't>solve the frame freezing problem.)>>I use FSAutoStart to start FS2004, defragment the memory, and>close all processes and programs except for the following:>>Processes:> ATI Hotkey Poller> DCOM Server Process Launcher> DHCP Client> DNS Client> Event Log> IAA Event Monitor> MSSQL$MICROSOFTBCM> Network Connections> Plug and Play> Print Spooler> Protected Storage> Remote Access Connection Manager> Remote Procedure Call (RPC)> SAVSCAN> Security Accounts Manager> System Restore Service> Telephony> Terminal Services> Windows Audio> Windows Firewall/Internet Connection Sharing> Wireless Zero Configuration> Work Station> >>Programs:> ASMon.exe> CLI.exe> explorer.exe> firefox.exe> IAAnotif.exe>>FS2004 settings: Everything maxed out (I do this because>adjusting the settings at lesser values doesn't eliminate the>frame freezing problem)except for the following:> Scenery > Land Only (No water effect)> AutoGen Very Dense> Weather> Sight Distance 60 mi.> Cloud Distance 30 mi.> 3-D clound percentage 10> Cloud Density Medium> Hardware> Anti-Aliasing Unchecked (controlled by video card)> Bilinear Filtering> MIP Mapping 4> Hardware Rendered Lights 8> Global Max Texture Size Massive> >Again, if anyone has any ideas how to solve the frame freezing>problem, I greatly appreciate your help. I would think that>with my particular computer configuration, I shouldn't have>any problems running FS2004, but, obvioulsy, I do.>>Geez your settings are very modest. You should be able to get much more image quality than what you ahve here with 10% 3D clouds, bilinear, etc. I would go through and eliminate every one of the programs that aren't essential for FS. And also try getting rid of unnec services, such as ATI hotkey poller. What the heck is SAVSCAN? Sounds ominous! How about getting rid of Foxfire, and whatever the other ones are. You should should try eliminating ALL programs and services that aren't critical. Make sure you have any chipset drivers installed, reinstall DirectX, etc.Noel


Noel

Share this post


Link to post
Share on other sites

>Anyone have any suggestions how else the>stuttering can be eliminated?Uhm, I'd suggest a step-by-step process: try to start with minimal settings (video, sound and AI aircraft) and to set your video card drivers to Performance Mode. Then go ahead turning up only some parameters a time (you can start turning up video card drivers settings, then go on to FS9 settings), and every time check out if the stutters are gone. This way you should be able to isolate the "stuttering factor" :)If stutters are still present with minimal settings, then maybe there's something to change in BIOS, or in FS9.cfg, or something else...


"The problem with quotes on the Internet is that it is hard to verify their authenticity." [Abraham Lincoln]

Share this post


Link to post
Share on other sites

My experience is that stutters are caused by CPU intensive operations of all kind.This can be hard drive transfers (e.g. loading of textures), rendering of visuals (e.g. you pan with the spot camera and FS needs to calculate the image for the new view angle), calculation of the behaviour of objects (e.g. aircraft, clouds, AI traffic, all in respect to weather conditions, gauges) etc. etc.I suppose you'll for sure get more or less stutters if your FS is beefed up with various add-ons.Teh formual is simple: the more things there are to display and the more complex it is to calculate an image to display them, the more stutters you get.I for my part have a _very_ clean WinXP and FS installation, a better-than-average system, but lots of add-ons and aircraft, and I almost always get stutters, and I don't expect them to ever go away.Remember, FS is so ressource hungry that it would currently cost you several ten-thousands of Euros to build a system capable of running it fluently with everything maxed out.Andreas


Andreas, LOWW

- Nihil sumus et fuimus mortales. Respice, lector: In nihil ab nihilo quam cito recidimus.

Share this post


Link to post
Share on other sites

It helped me to turn down my sound acceleration in dxdiag. I found that most of my stutters were occurring when ATC was talking to someone. This could be the case even if it's not on your frequency. You migh give it a look and see what happens.best

Share this post


Link to post
Share on other sites

FS has ALWAYS stutterd for me in spot view if I pan more than about 90 degrees around the aircraft. I have come to the conclusion its the way the sim loads the textures, in particular the terrain. Does not seem to matter what type or how complex the aircraft either. I dont believe Microsoft wanted this to be a "spot view" sim but with all the wonderful models we have as add-ons we want to watch from outside. I have noticed that as long as I stay inside the cockpit, my sim experience is a LOT smoother. If i go to spot view I will get occasional mocro stutters and panning will give me the type of stutters you are seeing but they are much shorter in duration. Its just the way it is, I dont think there is much you can do about it.I have a P4 at 3.0ghz, 1G of PC2100ram, a Radeon 9800pro and an Audigy sound card. Clean system running nothing in the background while FS is running. I can get easily frames in the 30's and pretty smooth if locked. Dips into low 20's and high teens with complex scenery, wx, and traffic.Hornit

Share this post


Link to post
Share on other sites
Guest Zevious Zoquis

Yep, I pretty much echo Hornit's thoughts. Theres something about the way FS loads and caches the textures. It almost seems to me that it loads high res textures that are in front of you and quickly forgets whats off to the sides and if you start panning around more than about 30 - 40 degrees in either direction it has to reload the textures. My system is modest by current standards, but I've got it pretty well optimized and FS9 runs really nicely on it (I get pretty consistent 20 - 25fps performance even in the VC of most planes) and as long as I'm not panning around the sim is absolutely stutter-free. It's really only when I start rubber-necking in the VC or panning around in spot view that things start to get funky. The issue does get worse if the plane happens to be really texture heavy I find (which I why I always convert everything I can to dxt textures).

Share this post


Link to post
Share on other sites

>Theres something about the way FS loads and caches the textures. It>almost seems to me that it loads high res textures that are in>front of you and quickly forgets whats off to the sides and if you>start panning around more than about 30 - 40 degrees in either>direction it has to reload the textures.Yeah, I came to formulate the "10 seconds rule" for texture loading in FS: after 10 seconds, texture are dumped and need to be loaded again. Try to take off in dusk, get airport to 3 o'clock, switch to right view, then switch back, wait like 12-15 secs, then again right view: you'll notice all airport textures need to be loaded again...this really sucks IMHO, most 3d engine don't behave this way...


"The problem with quotes on the Internet is that it is hard to verify their authenticity." [Abraham Lincoln]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...