Jump to content

Sign in to follow this  
haztronic

Black flashes/tearing when panning outside

Recommended Posts

Hi everyone,

So i've had this problem on and off for some time now, and i have bufferpools=0 a and water to high which is supposed to fix this issue but i still get it. I get it in areas that are heavy on frames, like flightbeam sfo, or lax, when i pan i just get these quick black tearing marks on my screen, and once i stop panning, it disappears. I have a gtx 580, i7 2600k @ 4.1ghz. If anybody can help me with this annoying issue that would be great.

 

Thank you

Share this post


Link to post
Share on other sites

Hiya, well, I had exactly the same issue with my 580, which disappeared after upgrading to the 770 4gb card. You could try alternative drivers, but I personally found absolute zero benefit from doing so. Any flashing spikes and so forth is generally attributable to GPU overload. To confirm this simply set Bufferpools=1 and drop the water slider setting to LOW 2X. Use this as a test simply to confirm one way or another.

Share this post


Link to post
Share on other sites

haztronic,

 

I use to get this too with BP =0 when using Autogen I had to revert to BP =1 and RejectThreshold=xxxxxxxxxxx to stop it but then got a bit of stuttering when panning....it is a trade off.

 

I do not use AG now as I think it looks like toy town...IMHO...so I am back on BP =0 with no artifacts....and smooth panning

 

All the best

Share this post


Link to post
Share on other sites

I suspect your system doesn't play well with usepools=0.  You may need to revert to usepools=1 and perhaps try a reject threshold (google for details of the numbers to try or run your cfg through Bjoote's on-line system).

 

I'm assuming that you have vsynch enabled in fsx and your videocard software as this is normally the casue of tearing.

 

IAN

Share this post


Link to post
Share on other sites

Hi everyone,

So i've had this problem on and off for some time now, and i have bufferpools=0 a and water to high which is supposed to fix this issue but i still get it. I get it in areas that are heavy on frames, like flightbeam sfo, or lax, when i pan i just get these quick black tearing marks on my screen, and once i stop panning, it disappears. I have a gtx 580, i7 2600k @ 4.1ghz. If anybody can help me with this annoying issue that would be great.

 

Thank you

There is no reason why you can't continue to use BP=0.

 

Reduce water to one notch below max.

 

Reduce Autogen a notch or two.

 

Basically your GPU is being swamped with more than it can handle.

 

The symptoms you describe are typical when sliders aren't adjusted to accommodate BP=0.

 

It's unlikely to be anything to do with vsync, given that you get the symptoms when frame rate is low. Tearing due to lack of vsync occurs when frame rate is higher than monitor refresh rate.

 

I had the same issue when I switched to a more powerful CPU, basically it was flooding my GPU with more data than it could handle. Backing off the sliders a bit did the trick.

Share this post


Link to post
Share on other sites

I do not use AG now as I think it looks like toy town...IMHO...so I am back on BP =0 with no artifacts....and smooth panning

 

AG meaning autogen? I lowered my autogen  to normal last night hoping to see a difference but i still got the artifacts. Personally, I think i need a new graphics card because i've also been getting the popup saying nivida drivers stopped responding but have now recovered.

Share this post


Link to post
Share on other sites

OK so i dropped the water to Low 2, changed BP to 1, and also went to Anisotropic instead of trilinear. So far my FPS have gone up and steady, and i am not getting the artifacts. Touch wood it stays like this, but i think I will have to upgrade to a 780 GTX within 2 months, my 580 is getting on a bit now. By the way, is 58c while running fsx on my GPU ok for temps? and the fan is at about 60%?

Share this post


Link to post
Share on other sites

got the same problem rolling with a gtx titan. got black texture flashing . BP 0. got the driver 340.52

 

With a titan?! Wow, wouldn't have expected that. Do what I did and see if it helps

Share this post


Link to post
Share on other sites

Got to say that if I ran any AG with BP=0 I got spikes flashes etc....without AG all good.

 

As I said I do not run AG it is just not my thing.......I am using. a GTX 770 4gb

Share this post


Link to post
Share on other sites

I have a GTX 760 and I had a lot of stuttering and black flashing when panning outside, but the bp=0 fixed all of it. I guess it depends on your cpu and gpu. 

Share this post


Link to post
Share on other sites

I'd be interested to hear how you get on. I get the occasional black ground texture when looking out of the virtual cockpit too. Its a bit worrying to hear that you can get this even if you have a mighty graphic card such as the Titan. Doesn't having water on 2xHigh kill framerates?

 

flyuk_sig.php?id=UKV1523

Share this post


Link to post
Share on other sites

I have water settings on high and I don't suffer major FPS problems. Sometimes I get black flashes but I think its unavoidable with this sim from the stone age.

Share this post


Link to post
Share on other sites

Got to say that if I ran any AG with BP=0 I got spikes flashes etc....without AG all good.

 

As I said I do not run AG it is just not my thing.......I am using. a GTX 770 4gb

 

Is autogen basically just trees and stuff? maybe some more buildings?

Share this post


Link to post
Share on other sites

You should never turn AG completely off. Sparse or normal will suffice. Turning completely off actually decreases performance, which is the opposite to fs9, where turning AG off helped.

When I was using Dx9 ( on DX10 now ) with my 580, and I mentioned a couple of posts back, changing pre render to 1 stopped the spikes. In Dx10, this is not required.

Have you guys tried the pre render ?

Share this post


Link to post
Share on other sites

No, not available, but there is the freeware version here at Avsim. But you would need Addon Converter X for certain AI aircraft to work.

You have almost identical system as mine, so I see no reason the pre render will not work. Let me know what NV insp settings are and maybe I can guide you in the right direction.

Share this post


Link to post
Share on other sites

No, not available, but there is the freeware version here at Avsim. But you would need Addon Converter X for certain AI aircraft to work.

You have almost identical system as mine, so I see no reason the pre render will not work. Let me know what NV insp settings are and maybe I can guide you in the right direction.

 

Can't you buy it under a different name somewhere? I mean, the difference in both FPS and overall performance and stability in DX10 mode is lightyears ahead of the outdated DX9. Plus you drastically reduce OOMs. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...