Sign in to follow this  
soppie

Eureka! I found the cure for my periodic stutterfest problem (but not the cause)

Recommended Posts

Ever since 2.3 was released I've been plagued by intermittent stutter attacks. During testing I've been cruising along at 60+ fps but every few minutes they'd drop to single figures with severe stuttering. These attacks lasted between 1 and 10 seconds before things returned to normal. I'm not a pc expert and staring at the different screens in Task Manager gave me no clue as to what was causing this.

 

Anyway, today I thought I'd try playing with the affinity settings and in TM unchecked CPU 0 and also set Priority to High. I locked frames to 33 in p3d and set off flying. 4 hours later not a single stutter and I am now confident that I've fixed an issue that was driving me nuts! I can only guess that something runs on my pc once in a while and that was interfering with my cpu in a way that manifested itself with severe stuttering. Freeing up CPU 0 presumably gives that process the power it needs. I could be miles off with that analysis but no matter, I'm just so pleased to be able to enjoy p3d 2.3 at last.

Share this post


Link to post

I was also mainly able to fix my issues, I think, by setting the priority to real time.  I had the exact problem as you, and it seems to be mostly gone.

Share this post


Link to post

Hmmmm... interesting... exactly how does one change these settings?

Share this post


Link to post

This sounds interesting, I have been banging on about micro stutters in P3D...it seems some see them some do not.

 

I will give this a try, the issue I see is the scenery is smooth then stutters then smooth...weird...still not sure though that it is linked to Vsynch problems...

 

Got to say If this is not going to get any fix or a fix can be found as much as I like P3d I will go back to FSX.

 

All the best

Share this post


Link to post

If setting the process priority to high or even real time cured a periodic stutter then the first thing I'd do is to check the process list for suspicious update demons or any applications that are running in the background and might download / process a significant amount of data at regular intervals.  Real time virus checking is notorious for that kind of stuff.

You could try this: while you're running P3d with process priority at normal turn off your internet (either by completely blocking every connection via firewall, turning off your router or wireless or what have you). If the stutters are gone you are one step closer to finding the culprit.  

Of course if you don't care there shouldn't be any problem at all running at high. I wouldn't go for real time because (while I really don't know how it's implemented in windows) that might lead to starvation of system processes. Probably wouldn't but there is a risk.

Share this post


Link to post

On my pc I use Game Booster.

It shuts down processes I don't need.

So no updating in the backgrounf when running P3D.

Share this post


Link to post

I locked frames to 33 in p3d and set off flying. 4 hours later not a single stutter and I am now confident that I've fixed an issue that was driving me nuts!

 

Maybe it was locking frame rates to 33 instead of your 60+ that solved the problem?

 

gb.

Share this post


Link to post

Hi GB, I'd tried every setting permutation you can think of as well as installing and uninstalling different addons to see if they impacted these occasional bursts of severe stuttering. The only thing that made any difference was changing the affinity setting in Task Manager and, touch wood, that hasnt just reduced the severity or the frequency, its totally eliminated them. Part of me wants to get to the bottom of the issue but I havent the necessary skills. I am intrigued by the suggestion above to disconnect from the internet but I think I'll resist and just get on with flying.

Share this post


Link to post

Setting the process priority to "real time" gave me sound problems within P3D v2 but setting it to "high" is fine.

Spirit

 


Hmmmm... interesting... exactly how does one change these settings?
 

 

AM and priority can be set in Task Manager. AM can be set in cfg-file too. The priority can be set when starting P3D v2 with this

C:\Windows\System32\cmd.exe /c start "Prepar3d v2" /High "E:\Lockheed Martin\Prepar3D v2\prepar3d.exe"

Use a shortcut doing so.

Spirit

Share this post


Link to post

Yes that does work but on some machines/os's, it can affect addons. I had problems with my controls and saitek panels. This was before I moved to win 7. Maybe I will try again.

 

Bob

Share this post


Link to post

Yes that does work but on some machines/os's, it can affect addons. I had problems with my controls and saitek panels. This was before I moved to win 7. Maybe I will try again.

 

Bob

Hi Bob,

works well here on Windows 8.1 and with Logitech G940 controls but I always use FSUIPC4 to connect them.

Spirit

Share this post


Link to post

Hi! Soppie,

 

For me didn't fix... I continue having intermittent stutter attacks in my p3d v2.3. I tried to fix like you and I tried to use game booster like GSalden and nothing.

 

I don't know how to fix this.

 

I think that I will wait the v2.4 for fly again.

 

Best Regards,

JL :( 

Share this post


Link to post

Hi! Soppie,

 

For me didn't fix... I continue having intermittent stutter attacks in my p3d v2.3. I tried to fix like you and I tried to use game booster like GSalden and nothing.

 

I don't know how to fix this.

 

I think that I will wait the v2.4 for fly again.

 

Best Regards,

JL :( 

Don't be surprised, LM is still adamant that all cores should be used, (last I heard).

 

gb.

Share this post


Link to post

 

 


I think that I will wait the v2.4 for fly again.

Why do you think P3D v2.4 will solve your problem?

Spirit

Share this post


Link to post

Why do you think P3D v2.4 will solve your problem?

Spirit

 

I am expecting that LM will solve, because many people have this problem. I hope that will be fit it in v2.4.

 

JL

Share this post


Link to post

I am expecting that LM will solve, because many people have this problem. I hope that will be fit it in v2.4.

 

JL

Impossible without a full screen exclusive mode and LM wrote in his forum that he will not.

There are only two solutions:

 

- Set P3D and weather engines so you always have the FPS equal to the refresh rate of the monitor.

- Find a monitor at 30hz

Share this post


Link to post

I would like to show that problem already informed to LM.

 

- http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=8239

 

- http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=8442

 

- http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=8412

 

:huh:


Impossible without a full screen exclusive mode and LM wrote in his forum that he will not.
There are only two solutions:

- Set P3D and weather engines so you always have the FPS equal to the refresh rate of the monitor.
- Find a monitor at 30hz

 

Sorry! Pincopanco,

 

But I didn't understand!!!

 

:(  :(  :(

Share this post


Link to post

JLuis,

 

the full screen of P3D 2.x is a false full screen, it is a windowed mode without the top bar.

So, or you have the settings to always have 60 FPS (60hz monitor) or you find a monitor at 30hz with 30 FPS.

Share this post


Link to post

At last,

 

Others are seeing the stutters I have been going on about in P3d dispute being told it is my System or I need to reduce this or that! by some....

 

Ball is in LM court......

Share this post


Link to post

On my pc I use Game Booster.

It shuts down processes I don't need.

So no updating in the backgrounf when running P3D.

 

AlacrityPC does the same kind of thing - I use both to be on the safe side!   ^_^

Share this post


Link to post

AlacrityPC does the same kind of thing - I use both to be on the safe side!   ^_^

 

Well I'm old skool just a simple bat file will do it :-)

Share this post


Link to post

After many fights with my notebook I found what was the cause for my periodic stutterfest problem. My Cpu was having overheating when the temperature reach 96 C the system reduce the frequency for half causing stutter.

 

I changed my power settings for reduce 12% of my frequency cpu and now i have maximum 76 C and no more  periodic stutters.

 

ok! My problem was solve. :P

Share this post


Link to post

After many fights with my notebook I found what was the cause for my periodic stutterfest problem. My Cpu was having overheating when the temperature reach 96 C the system reduce the frequency for half causing stutter.

 

I changed my power settings for reduce 12% of my frequency cpu and now i have maximum 76 C and no more  periodic stutters.

 

ok! My problem was solve. :P

 

Personally I find 76C rather still hot ;-) my I7-4770K at 4.3Ghz is around 55c full load on air :wink:

Share this post


Link to post

Personally I find 76C rather still hot ;-) my I7-4770K at 4.3Ghz is around 55c full load on air :wink:

 

I agree, but you know keep notebook cold is complicate!!! B)

With my i7-4790k at 4.4ghz is around 55/60 C with Corsair H100i.

Share this post


Link to post

I agree, but you know keep notebook cold is complicate!!! B)

With my i7-4790k at 4.4ghz is around 55/60 C with Corsair H100i.

Do you use a cooler-mat?  One way to experiment with this...is to fill the old rubber bladder bags with ice...and have that on your lap..and the bottom of the notebook upon the top of the ice-filled bladder.  Then...open up the freq setting of your CPU once more...and see if there is a difference. If so...you might be able to construct your own custom cooler-plate/mat...and enjoy the end of heat, and its performance robbing ways....  Just a thought.  BTW,  for my notebook, I built one out of an old and small in-window air conditioner. I extended the cooler matrix (condenser) (copper tubes and aluminum fins) out from the front interior of the unit, and placed it in a horizontal, wooden frame, that had small feet, and between the feet, ran a computer case fan to force airflow up and out of the wooden case. I then placed a 1/4 inch thick wood frame on top of that...which the bottom of the notebook rested on. That allowed air to flow free between the condenser, and the bottom of the notebook. It worked like a charm!  I no longer have a notebook..but, I can tell you, this home solution...did in fact drop drastically the internal temperature of the motherboard, chips upon it, .and I can't even remember the fan coming on in my IBM'er...with this rig in play.  You can pick up a 5,000 to 8,000 BTU in-window, for a song.....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this