Sign in to follow this  
asifjamali

PMDG 747X Panel Freeze

Recommended Posts

Hi,

 

I wonder if someone can offer solution to the following problem with my PMDG 747 X installation.

 

The aircraft works perfectly until about 30-40 minutes into the flight, and then something happens, causing the following anomaly (although the aircraft continues to fly, evident from the outside view):

 

- Instrument panels (PFD, ND, EICASs) Freeze

- The aircraft stops following the FMC planned LNAV, VNAV

- The instruments come alive if the display is changed from full to windowed mode or vice versa. However, FMC commanded VNAV, LNAV, or speed, heading interventions on the MCP do not work.  The aircraft can only manually be flown.

 

Note that  the default FS 747 works fine (no panel freezes). The panel freeze occurs in both windowed as well as full screen mode.

 

I have already taken following measures, without any luck:

 

- View changes (A, shift+A)

- Uninstalled every add-on, one by one. Testing after each uninstall.

- Uninstalled/re-installed  PMDG 747X. 

- Uninstalled hardwares (MCP, EFIS, CDU); 

- Uninstalled FSX fully, formatted the drive it resided on. Checked the registry and deleted remnants of it or any add-ons 

- And lastly, did a clean install of FSX+Acceleration and PMDG747X 

 

It has not worked after all these steps. I have no idea what caused this problem to pop up; the aircraft had been working fine for more than two years.

 

The only other thing left is a clean re-installation of Windows 7. But before I did that, I wanted to check with experts .

 

Look forward to your suggestions.

 

PS: all products I have installed are licensed  :smile:

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Asif:  Don't reinstall your OS!  Try troubleshooting your hardwares (MCP CDU... you have a add on EICAS hardware??). The problem you describe is not typical.  Try a couple flights with no external hardware except your game controller (joystick or yoke) and see if problem persists.

 

I can't think of a valid reason to reinstall the PMDG aircraft, even corrupt files can be restored by using the REPAIR option in the installer. Good luck.

Share this post


Link to post
Share on other sites
downscc: Thanks for your advice.  I did disconnect all the hardwares, excluding the yoke, and uninstalled the relevant drivers and programs from the PC. The PMDG Technical Support also suggested that it could be the                 Motherboard  battery issue, which I changed.  No luck after these steps too; the problem persisted.  

However, I have done something that has caused the problem go away - at least for now. Following is what I did:

 

- Uninstalled the graphics card (EVGA Classified nVidia GTX 780). Did not remove the drivers.

 

- Booted the PC with the stock display output.

 

- Reinstalled the nVidia graphics card after turning off the PC

 

- Turned the PC back on, and connected the monitors to nVidia card.

 

Note that I did NOT update the nVidia driver when prompted. I am assuming it is using the legacy driver or something which it could find on the PC/OS.

 

The aircraft is now working fine and the panels are not freezing anymore (have done four 2-hour test flights so far).

Let's hope the problem does not resurface!

Share this post


Link to post
Share on other sites

I gotta add that I too had this exact same problem.  And I mean every single issue mentioned above.  I went through other posts and suggestions that had me changing the CFGs and regedit keys but nothing worked.  

 

I am also running a Nvidia card, (GTX 770 with trip monitors).  This suggestion worked.  I uninstalled the vid card driver only.  Rebooted and installed the older driver from the disc.  I too did not update to the latest driver.  My Queen of the skies is now running better than ever.  No issues.

 

Thank you for sharing this fix. :dance:

Share this post


Link to post
Share on other sites

Well sadly(and probably expected) this was only a temp fix.  I normally leave my computer on sleep, but I rebooted and the system updated to the current vid driver.  I have not been able to trick it with the old drivers.  All of the problems have come back.  I give up. gonna open a ticket

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this