Sign in to follow this  

Addon A/C not working in v2.4

Recommended Posts

Good morning AVSIM!


I recently uninstalled v2.2 and all addons (everything worked great) and installed v2.4 along with a few addon aircraft and none of my addon aircraft are working correctly. All of the models work perfectly, look great, but I have many system issues, different on all aircraft (all default P3D aircraft work).  Here are the ones I have installed and their issues:


Feelthere E135/45 - Nothing is clickable

Feelthere E170/90 - Displays show enlarged pictures of the autopilot knobs and MCP is not present

Aerosoft a320/1 - NAV display will not turn on (all other displays work)

A2A C172 - Nothing turns on, mait hangar wont let me fix anything, control surfaces do not work


I have tried reinstalling numerous times, even reinstalled v2.2 and it now has the same problems.  Tried installing the most current SDK as a shot in the dark, didnt work.  Tried installing through the migration tool, no luck.  Admin permissions all around, anti-virus turned off during installation and P3D drive is exempt from scans, and everything runs as admin when opened.  The only other thing I could think of was simconnect, I have v10.0.60905.0 (cant find any of the others) installed along with ESP simconnect and FSX and P3D SDKs.  But native P3D installs shouldnt need those I wouldnt think, ie A2A C172.


Anyways, I need some flying in my life, so any help would be so greatly appreciated!

Share this post

Link to post
Help AVSIM continue to serve you!
Please donate today!

Navydude sorry to hear you are having issues.  I have P3D v2.4 with FSX not installed, and all the above planes except the 172 installed, running great.


So here is a question, did you install those planes with or without Migrator?


So you have FSX installed?


Sometimes you have to look at %AppData%\Lockheed Martin\Prepar3d\dll.xml, and verify that the required files have populated this area.


One other thing that I have found can cause issues is FONT.  Some planes require a certain font installed to operate correctly.

Share this post

Link to post



please make sure you install the FSX simconnect files. They are included with your P3D installation if not installed automatically.




Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this