guenseli

New LINDA 2.9.3 released! (4 Mar 17)

252 posts in this topic

DOWNLOAD LINDA 2.9.3 v1 (New Server)


LINDA 2.9.3 - INSTALLATION INSTRUCTIONS AND NOTES
by Andrew Gransden

LINDA provides Flight Simmers an easy and convenient way of supporting a wide variety of joystick devices, VRInsight Combo panels and aircraft add-ons with sophisticated functions in the easy to learn LUA programming language.

LINDA 2.9.x provides full compatibility with all variants of the VRInsight Combo panel: the original MCP1, the Combo II MCP (Boeing) and Combo FCU (Airbus). It supersedes all previous versions.

This version requires FSUIPC4 4.964 to be installed.

This version addresses the following issues:

  • Added option to edit aircraft user written functions (user.lua) from Edit Aircraft Module dialog.
  • Fix to correct error creating user.lua for selected aircraft from template.
  • Fix to ensure Settings page correctly displayed on start up and when no aircraft selected.
  • Fix to ensure FSXSync state correctly remembered.
  • Fix to errors and LINDA closure when FSX Default aircraft config-hid.lua file was missing.
  • Added separate configuration file backup folder and functionality to reduce clutter and numbers of backup files created.
  • Added a new page holder for maintenance operations (for future development).

Saitek Panel users should ensure that the Saitek Panel checkbox (in LINDA Setup) is deselected/unticked to allow LINDA to control these devices. This is different to the wording on the page.

See the release notes in the download for full details of key changes.

It is worth considering a fresh installation when upgrading. After backing up your \modules\linda and \linda-cfg, install 2.9.x before copying back you \linda\aircrafts and \linda-cfg\aircrafts folders. Additionally, restore the Joystick device configuration file (\linda-cfg\system\config-hid.lua) to ensure that previous joystick setup are correctly restored. You will need the latest paid and licenced version of FSUIPC installed.

All bug and issues should be reported on the project thread on the LINDA support sub-forum.

Backup
BEFORE TRYING TO INSTALL THIS VERSION YOU SHOULD BACKUP YOUR COMPLETE CURRENT LINDA INSTALLATION. BACKUP FROM YOUR MAIN FSX/FSX-SE/P3D MODULE FOLDER THE FOLLOWING FILE AND FOLDERS: LINDA.EXE, LINDA.LAU, IPCREADY.LUA, /LINDA AND /LINDA-CFG.
NO RESPONSIBILITY OR LIABILITY CAN BE TAKEN FOR ADVERSE AFFECTS ON YOUR INSTALLATION.

Installation

For users who have not successfully installed LINDA 2.8.x, you are recommended to delete all LINDA files and folders after backing up. After the next step copy back you \linda\aircrafts and \linda-cfg\aircrafts.
Un-zip the folder and copy the files into the main FSX folder.
You must have also installed the VRInsight software and drivers for the Combo II (Boeing) and Airbus FCU from http://vrinsight.com/devel_shot/ under the link Install Base Package VRiSim. However, once installed you should not run the VRiSim software at the same time as LINDA.

Known Issues

  • When using LINDA to control the Saitek Pro Flight Panels (Switch, Radio and Multi), it is necessary to operate all switch/button on each panel prior to take off to ensure that the panel state is correctly read.
  • There can be a delay on operating the Saitek controls and the displays updating.
  • When the Saitek Switch Panel is first operated 3 sound errors appear in red in the Console window. This has no effect on correct operation.

Previous Versions

Previous LINDA 2.9.2 v3

Previous LINDA 2.8.9 v2

Previous LINDA 2.8.6 v2

LINDA 1.13 - for MCP1 (original) users

2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Some clarification needed here  :rolleyes: :

 

1) In the installation notes (under the title Backup) you are talking about 2.5 being a Beta-Version? Is that so?

2) How do I proceed with all my "old" A/C modules that I use on my original MCP combo uner LINDA 1.XX (I have approx. 20 others in use apart from the NGX and the A318-21 in use). My guess is that they are not compatible anymore with LINDA 2.5....?

 

Oskar

0

Share this post


Link to post
Share on other sites

Hi Oskar,

 

Thanks for your questions.

 

1.  LINDA 2.5 is the formal release. The 'beta' comment in the notes  was not deleted. However, with all software it is strongly recommended that you make a backup of your existing LINDA setup as detailed.

 

2. Your old Aerosoft Airbus and PDMG 737NGX configurations will not be overwritten with this installation. Any existing VRInsight MCP panel and joystick configuration will work with LINDA 2.5.  They may however be updated on the first save after any alterations you may make.  A automatic timestamp backup is made of all config-mcp*.lua files.

 

Regards

 

Andrew

0

Share this post


Link to post
Share on other sites

Thank you Andrew, that answers all my questions! I will therefore soon start the transition from LINDA 1.13 to 2.5 - hopefully not with too many glitches  :rolleyes:  Thank you also very much (and of course all people involved) that you have brought LINDA a remarkable step forward. For me LINDA is essential from day 1 of its appearance and it is with great pleasure that the community can see its further development.

 

Oskar

0

Share this post


Link to post
Share on other sites

Many congratulations on the new release, gentlemen!    :BigGrin:

 

 

However, before installing it I have a few more questions, if you would be so kind (the words between double quotes are taken from the pdf file in the release package):

 

 

1. "You must have also installed the VRInsight software and drivers for the Airbus FCU from http://vrinsight.com/devel_shot/ under the link 'Install Base Package VRiSim'”.

 

Q. I don't have the Airbus FCU (only version 1 of the MCP); furthermore I have never found it necessary to install any VRinsight software with the old version of LINDA (as I explained in my 'detailed manual'). Is it really needed now? It's just that long and sometimes bitter experience has taught me not to install any software that can be done without.   :wink:

 

 

2. "A new user.lua has been added...."

 

Q. I have added a great deal of code to my existing lib-user.lua file to provide additional functions: will any of this code need to be rewritten, or are the new functions all additions?

 

 

3. The document says:

"LINDA 2.5 provides full compatibility with all 3 variants of the VRInsight Combo panel"
but also —
"While every effort has been made to retain backward compatibility with the original MCP1 panel, there has only been limited testing and compatibility can not be guaranteed".

 

:nea: Q. Those two statements appear to conflict with each other. Could you please be kind enough to elucidate the areas in which I might find support for the v1 MCP to be patchy?

 

 

And finally....

 

4. Q. I seem to recall that problems have been reported with the v1 MCP when using the PMDG 777 WIP module. Could you please confirm the status of that 777 module when using LINDA v2.5?

 

 

Many thanks in advance for your reply, and for your great work in bringing the new version to us.   :smile:

 

Brian

0

Share this post


Link to post
Share on other sites

Hi Brian

 

Thank you for your post and comments.  I'll try and answer your questions.

 

1.  The basic VRiSim software contains the USB-serial driver for connecting to the VRInsight panels. After initial installation there is no need to run it again.  FSX/LINDA will then connect automatically to the panel indicated by the brief flash of the panel lights on start up. If you have been successfully using LINDA with your panel, there is probably no need to reinstall VRiSim.

 

2.  The new User.lua file provides a convenient way for users to modify LINDA functionality on an aircraft-by-aircraft basis without 'damaging' the base code. It also provides a means of allowing future updates to be installed without affecting user's own changes and adaptions. Your User-Lib will continue to work but you might wish to copy some of your aircraft-specific functions to the related user.lua file.

 

3.  We have worked with a few owner's of the original MCP panel in the beta testing but without extensive testing I can not guarantee that everything will work.  However, any reported problems will be promptly investigated and fixed.

 

4.  Regarding the PMDG 777, I do not own a copy of the 777 sim and Günter does not own an Airbus FCU panel.  Therefore, while the 777 module should work fine with the original MCP and MCP Combo II (Boeing), we have been unable to do any testing with the FCU Airbus panel.  This also applies to all aircraft modules other than Aerosoft Airbus (new) and PMDG 737NGX.

 

I hope that answers your questions and allows you to use LINDA 2.5. If you hit any problems, come back on this forum and I will get straight onto it.

 

Regards

 

Andrew

0

Share this post


Link to post
Share on other sites

Hello, Andrew!

 

And many thanks indeed for your prompt and informative reply — all of which is excellent news.    :yahoo:

 

I look forward to installing and using the new version of LINDA.    ^_^

 

Huge thanks once again,

 

Brian

0

Share this post


Link to post
Share on other sites

Hi out there,

what was the latest Linda Version before the 2..beta? Was ist Linda 1.1.3?

Cheers Tom

0

Share this post


Link to post
Share on other sites

Hi Tom

 

LINDA 1.13 was the formal release covering VRInsight original MCP Combo I and MCP Combo II (Boeing) panels.

 

Linda 2.0 was aimed primarily at owner's of Airbus FCU panels and the Aerosoft Airbus Extended X (2.7).  It was my pet project under Project Linda2Airbus and went through several public beta and release candidates.

 

LINDA 2.5 is the latest formal release aimed at providing full support for all VRInsight MCP/FCU panels and is compatible with the new Aerosoft Airbus A318/A319/A320/A321 (module 4.0) and the PMDG 737NGX (module 3.0).  Only limited testing with the original MCP has been possible and a few issues have been reported.

 

I hope that helps.

0

Share this post


Link to post
Share on other sites

Hi Tom

 

LINDA 1.13 was the formal release covering VRInsight original MCP Combo I and MCP Combo II (Boeing) panels.

 

Linda 2.0 was aimed primarily at owner's of Airbus FCU panels and the Aerosoft Airbus Extended X (2.7).  It was my pet project under Project Linda2Airbus and went through several public beta and release candidates.

 

LINDA 2.5 is the latest formal release aimed at providing full support for all VRInsight MCP/FCU panels and is compatible with the new Aerosoft Airbus A318/A319/A320/A321 (module 4.0) and the PMDG 737NGX (module 3.0).  Only limited testing with the original MCP has been possible and a few issues have been reported.

 

I hope that helps.

Yes thnx it helps - I do have the Linda 1.1.3 version which works perfectly for me.

 

Some time ago I asked for a key shortcut for reloading Linda in game - is it possible to bring it in the next update?

Cheers Tom 

0

Share this post


Link to post
Share on other sites

Hi Tom

 

I have had a quick look at how LINDA is reset.  This is done within LINDA.exe with calls to FSUIPC that first shutdowns the LUA side of LINDA and then restart the LUA code.  This operation cannot be coded from with the LUA side as it would kill itself.  I will keep it in mind for future updates if it proves possible.

 

Andrew

0

Share this post


Link to post
Share on other sites

Hello Günther,

can you tell us something about "Added Flight Autosave functionality to save flights on user defined conditions."

Couldn't find this documented inside or outside LINDA.

0

Share this post


Link to post
Share on other sites

Yes, this is a well undocumented feature ... ;)

 

Give me some days and probably remember me again, then I will write something about it

0

Share this post


Link to post
Share on other sites