Sign in to follow this  
tomsch01

Attitude indicator change in FSX not picked-up by indicator in Panel Builder

Recommended Posts

I am building my own cockpit (hardware) panel and I am using Simconnect ATTITUDE_BARS_POSTION_DOWN(UP) commands via FSUIPC to change attitude indicator with rotary knob. This works for indicator displayed in FSX but PanelBuilder indicator does not change. The rotary knob in PanelBuilder artificial horizon does work for its own indicator but does not seem to be connected with FSX itself. Changing the FSX indicator via mouse klicks or key assignments in FSX also seem to be disconnected from PanelBuilder artificial horizon. Note that my approach does work for all other instrument rotary knobs, Solution?   

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Any update on this ? I double checked my version - it really is 2.92. All panel instrument rotary knobs work except for the attitude adjustment knob of the artificial horizon. I am a great fan of the software (since 2012) and hope this glitch can be solved. Regards.

Share this post


Link to post
Share on other sites

Hi,

 

Fairly new SimPlugins user here.  I've had it up and running in my sim pit for a couple months now

It's working great with the exception the problem referenced above regarding the attitude adjustment.  Just as the other user is doing I am using the ATTITUDE_BARS_POSTION_DOWN and UP commands from FSUIPC to change attitude indicator with rotary encoder knob.

 

I believe I am using the latest version it shows as 2.9 when I run the software.  Has a fix been found for this?

Share this post


Link to post
Share on other sites

Hi, have you tried using the FSUIPC interface instead of the SimConnect interface. The attitude adjustment also might be implemented in addon aircraft and gauges so may not even be part FSX.

Share this post


Link to post
Share on other sites

I'll try that next and see what happens.  I just pulled the instrument panel apart to do some mechanical work so I might be delayed a bit but I'll post back with my findings as soon as I am able.

Share this post


Link to post
Share on other sites

On some of the AI indicators the bars only move when using the knob on the instrument itself, but nothing is sent to FSX. I believe the C172 version of the AI has this implemented, I have to confirm. Also, this was done in one of the latest version updates.

Share this post


Link to post
Share on other sites

Problem Solved.

 

I decided after several other things failed to do a re install of the software.  All is working now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this