Sign in to follow this  
madsaint

Panel Builder in p3d Instruments going crazy

Recommended Posts

Hey all, I've installed panel builder on a second networked pc (both windows 7, with switch box) but whenever I start prepar3d and connect PB, all instruments are going crazy. It looks like they're getting the wrong data or something. I'm not quite sure what's going wrong though. I also updated pr3d to 2.5 version so could that be the issue?
I'm totally new to networking pc's so forgive me if this a stupid question...

greets, Daan



 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

No, P3D V2.5 works fine with Panel Builder.

 

What do you mean by switch box? A network switch or a router?

If you don't have a router, you need to assign IP Addresses to both computers.

Share this post


Link to post
Share on other sites

Sorry, that's a network switch. But where do I assign these adresses, in the multicast group address?


edit: tried that, but with no result other than a crashing panel builder.

Share this post


Link to post
Share on other sites

No, you need to assign fixed IP addresses to your network adapters in Windows.

 

I suggest to use:

 

Computer 1: 

IP Address: 192.168.0.1

SubNet mask: 255.255.255.0

 

Computer 2:

IP Address: 192.168.0.2

SubNet mask: 255.255.255.0

 

This is done in the windows control panel under Networking and Sharing Center / Change Adapter Settings. Then right click on the network adapter and choose Properties. Now click on 'Internet Protocol Version 4' and then on Properties. Select 'Use the following IP Address' and enter the values I described above.

Share this post


Link to post
Share on other sites

Thanks for the reply RJHussel, I've got a connection between the two pc's. Plan-g is installed as well, and works fine on the client pc. The problem is more that whenever I open the throttles all instruments go crazy. It doesnt matter if I control the throttles with the mouse or joystick, it just looks like the instruments are getting the wrong data. I also checked all the ports for the instruments, but they are all just fine....

Share this post


Link to post
Share on other sites

Did you try the fixed IP Addresses? Panel Builder will need to have them on the same network, other applications might not.

Share this post


Link to post
Share on other sites

Problem solved! Thanks for all your advice rjhussel, but it turned out be a different region mistake. So once I changed the decimal sign from comma to period on the client pc, it all worked fine!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this